LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   glib >=2.0 failed dependency (http://www.linuxquestions.org/questions/linux-software-2/glib-%3D2-0-failed-dependency-44131/)

kwanc 02-04-2003 09:48 PM

glib >=2.0 failed dependency
 
I'm running YDL 2.3 with GNOME 2.0.3, and I'm having some serious compile-from-soucre issues. I installed glib2 via RPM and Source, and yet when I try to compile something depending on glib2 I get a dependency error. What's going on? should I kill TerraSoft for giving me crap? help a brotha out.

Mara 02-05-2003 06:48 AM

What's the dependency error? I guess it's during configure that glib2 cannot be found. If so, you need to check if you have /usr/local/lib in your LD_LIBRARY_PATH or /etc/ld.conf.so.

vladkrack 02-05-2003 07:00 AM

Did you instaled gli2-devel?

lopoetve 02-05-2003 01:43 PM

ldconfig. Run it. That might help.

kwanc 02-06-2003 07:34 PM

none of the above works; although I don't know how to check if /usr/local/lib is in my LD_LIBRARY_PATH.

I added it to /etc/ld.so.conf though.

getting the same error; and apparently I don't have ldconfig, are there any special arguments i need to run it?

kwanc 02-06-2003 07:57 PM

okay, I installed glib 2.2.1 from source. Now, when I try to install, this comes up.

checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.0.7, but GLIB (2.2.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at http://www.gtk.org/.


grrrr.

acid_kewpie 02-07-2003 02:51 AM

well then you need to upgrade glib-devel, or rather remove it if you installed glib from source. i'm not totally sure who pkgconfig deals with source installed pacakges, but i guess you could probably just edit the existing glib-2.0.pc file if you can find it.

kwanc 02-08-2003 04:14 PM

i recompiled glib-2.2.0 and pkgconfig. now, configure scripts get past the glib >= 2.0.0, but they then fail on GTK+ >= 2.0.0. same error:


checking for GLIB - version >= 2.0.0... yes (version 2.2.0)
checking for pkg-config... (cached) /usr/local/bin/pkg-config
checking for GTK+ - version >= 2.0.0... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.
configure: error:
*** GTK+ 2.0 is required to build Gaim; please make sure you have the GTK+
*** development headers installed. The latest version of GTK+ is
*** always available at http://www.gtk.org/.

Mara 02-08-2003 04:44 PM

Do you have gtk-devel package?

acid_kewpie 02-09-2003 03:38 AM

i would have thought that seeing as you fixed your problem and now have *excatly* the same problem with a different library that the answer would be nothign short of obvious...


All times are GMT -5. The time now is 08:15 PM.