Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 10-16-2009, 09:31 PM   #1
William (Dthdealer)
Registered: Jan 2009
Location: Sydney, Australia
Distribution: Debian Testing
Posts: 99
Blog Entries: 39

Rep: Reputation: 19
GIMP leaves 'brush droppings' on canvas.

When I move a brush (not including cursors) around the canvas in the GIMP it leaves every frame of the brush outline. These are temporary and disappear in areas that are redrawn by editing or moving around the window.

This problem occurred after upgrading from 2.4 to 2.6 (after I added the XunstableX testing repository to sources.list)

See attached image - I moved my mouse over the image with two different brush-styles, not clicking or painting. During this I also accidentally had a window move over it and so you can see a sharp cut out of some.

The reason I am not reporting this on their bugtracker is I believe it is a video/Xorg problem and can be fixed with some parameters in xorg.conf. I am unsure however and am asking for help towards this irritating problem.

Debian Etch (squeeze/sid)
Attached Thumbnails
Click image for larger version

Name:	brush_droppings.png
Views:	6
Size:	12.5 KB
ID:	1757  

Last edited by William (Dthdealer); 10-17-2009 at 06:14 AM. Reason: Fixed repository name typo
Old 10-17-2009, 05:12 AM   #2
Registered: Feb 2009
Distribution: FreeBSD, OpenBSD, NetBSD, Debian, Fedora
Posts: 770
Blog Entries: 52

Rep: Reputation: 68
Actually, you should report this to the bug tracker.
You should also check hardware and Xorg.
Have you downgraded to the previous version to see if the problem has only to do with 2.6?

And an unstable repository. Any long standing debian user will tell you not to mix repositories if you don't know what you are doing.
Old 10-17-2009, 06:13 AM   #3
William (Dthdealer)
Registered: Jan 2009
Location: Sydney, Australia
Distribution: Debian Testing
Posts: 99
Blog Entries: 39

Original Poster
Rep: Reputation: 19
Sorry, I'm using testing and not unstable.

I'll downgrade and check if it is mixed packages making the problem. If not I'll report it



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Best of GIMP brushes: 35+ brush sets (1400+ brushes) LXer Syndicated Linux News 0 01-20-2008 10:30 PM
Open Canvas? gymnart Linux - General 0 07-27-2007 01:45 PM
Old intermediate user looking to brush-up skills...couple questions DJ_Maiko Linux - Distributions 8 06-04-2007 05:37 AM
Krita and duplicate brush The slayer Linux - Software 0 07-09-2006 03:10 AM
regionally undoing curves/levels changes in gimp layer? (i.e. using black brush) webazoid Linux - Software 1 04-16-2005 12:14 PM

All times are GMT -5. The time now is 04:20 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration