LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   gimp-2.2 segfaults (http://www.linuxquestions.org/questions/linux-software-2/gimp-2-2-segfaults-304633/)

pingu 03-22-2005 05:50 AM

gimp-2.2 segfaults
 
I'm running LormaLinux 5.0, installed gimp2.2 using apt.
Gimp starts to load, but dies with error:
Code:

[peterh@killbill ~]$ gimp-2.2
(gimp-2.2:26543): GLib-GObject-WARNING **: specified class size for type `GimpContainerEntry' is smaller than the parent type's `GtkEntry' class size

(gimp-2.2:26543): GLib-GObject-CRITICAL **: file gtype.c: line 2319 (g_type_add_interface_static): assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(gimp-2.2:26543): GLib-GObject-CRITICAL **: file gobject.c: line 819 (g_object_new): assertion `G_TYPE_IS_OBJECT (object_type)' failed

(gimp-2.2:26543): Gimp-Widgets-CRITICAL **: file gimpcontainerview.c: line 535 (gimp_container_view_set_preview_size): assertion `GIMP_IS_CONTAINER_VIEW (view)' failed

(gimp-2.2:26543): Gimp-Widgets-CRITICAL **: file gimpcontainerview.c: line 306 (gimp_container_view_set_container): assertion `GIMP_IS_CONTAINER_VIEW (view)' failed

(gimp-2.2:26543): Gimp-Widgets-CRITICAL **: file gimpcontainerview.c: line 450 (gimp_container_view_set_context): assertion `GIMP_IS_CONTAINER_VIEW (view)' failed

(gimp-2.2:26543): Gtk-CRITICAL **: file gtkwidget.c: line 5592 (gtk_widget_set_size_request): assertion `GTK_IS_WIDGET (widget)' failed

(gimp-2.2:26543): Gtk-CRITICAL **: file gtkbox.c: line 373 (gtk_box_pack_start): assertion `GTK_IS_WIDGET (child)' failed
Segmenteringsfel  (=segmentation fault)   
[peterh@killbill ~]$

I simply don't understand these messages. Is there a fix? I could try installing gimp-2.0 but apt doesn't find it.

__J 03-22-2005 06:03 AM

i'd say there is something wrong with a dependency, but that's just a guess. you could strace it, to see where it is segfaulting:

strace gimp-2.2


All times are GMT -5. The time now is 01:44 AM.