LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 05-24-2011, 12:20 PM   #1
bootleg550
LQ Newbie
 
Registered: May 2011
Location: Texas
Distribution: Redhat v5 (Centos)
Posts: 3

Rep: Reputation: Disabled
Getting errors while installing perl-dbi


I’m receiving warnings and errors while trying to install perl-DBI.

Here’s the command line syntax and messages.

rpm -ivh perl-DBI-1.611-1.el5.pp.i386.rpm
warning: perl-DBI-1.611-1.el5.pp.i386.rpm: Header V3 DSA signature: NOKEY, key ID 6971f6ac
error: Failed dependencies:
perl(RPC::PlClient) >= 0.2000 is needed by perl-DBI-1.611-1.el5.pp.i386
perl(RPC::PlServer) >= 0.2001 is needed by perl-DBI-1.611-1.el5.pp.i386

Here are the vitals:
Redhat V5(Centos)
Perl-DBI V. 1.611-1.el5.pp.i386 (trying to install)
cpan RPC::PlClient = (0.2020) (v2.25)
cpan RPC::PlServer = (0.2020) (v2.25)
Perl V. perl-5.8.8-32.el5_5.2

Should I try to uninstall PLClient & PlServer .02020 and try locate 0.2001?

I’m still working through this but any suggestion would be great!

Thanks.
Steve.

Last edited by bootleg550; 05-24-2011 at 12:40 PM. Reason: Added more Info
 
Old 05-24-2011, 01:14 PM   #2
sundialsvcs
Guru
 
Registered: Feb 2004
Location: SE Tennessee, USA
Distribution: Gentoo, LFS
Posts: 5,455

Rep: Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172Reputation: 1172
It might be most useful for you to pursue your question here:

http://www.perlmonks.org

(Please sign up for a user-account and join this very-active Perl community ... It's free, of course. Just don't be "anonymous.")
 
Old 05-24-2011, 01:56 PM   #3
bootleg550
LQ Newbie
 
Registered: May 2011
Location: Texas
Distribution: Redhat v5 (Centos)
Posts: 3

Original Poster
Rep: Reputation: Disabled
Thanks, I'll give it a try!
 
Old 05-24-2011, 02:59 PM   #4
16pide
Member
 
Registered: Jan 2010
Posts: 418

Rep: Reputation: 83
try this instead of rpm command:
Code:
yum install perl-DBI
yum is supposed to take care of dependencies (as long as you configured your repositories correctly
 
  


Reply

Tags
error, installing, odbc, perlscript, warning


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
perl dbi:mysql shows error syntax error dbi:mysql ?? haxpak Linux - Server 4 02-27-2009 12:09 AM
perl dbi module error "error at dbi:" dbi-> connect statement mysql haxpak Linux - Newbie 1 02-25-2009 09:22 AM
Perl DBI Queries baddah Programming 1 05-13-2008 06:56 PM
Error using DBI with Perl bostonantifan Ubuntu 0 11-11-2007 02:47 PM
Installing Perl DBI/ADO/Win32/OLE krzykard Linux - Software 0 11-19-2003 01:09 PM


All times are GMT -5. The time now is 11:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration