LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-21-2003, 02:15 AM   #1
patientzero
Member
 
Registered: Aug 2003
Location: Toronto
Distribution: Gentoo 1.4
Posts: 95

Rep: Reputation: 15
Gentoo hates my XF86Config


Hello..

So back again with lovely linux fun, this time in distro a la Gentoo.

(Gentoo owns btw... thought I'd let you all know...)

I tried to install the new nvidia driver from nvidia's website, whatever the nvidia driver is for non-norad cpu's NVIDIA-blahblah.sh

Install goes fine. Configure my XF86Config file to use my nvidia driver and (insert favorite power down sound here) X craps out on me telling me that I'm useless and that white boys can't jump.

The error it has is something about not being able to parse the config file... now, I throw the little letters in my Device "Geforce" section to "nv" instead of the almighty-wanted "nvidia" and X works. Figure that one out eh?

Enclosed is a copy of my XF86Config as I would imagine it should run normally...

(albeit I stole it from my RH9 /etc/X11 dir .. hehhe ;P)

# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Hansol Electronics Mazellan700P"
HorizSync 30.0 - 85.0
VertRefresh 50.0 - 120.0
Option "dpms"
EndSection

Section "Device"
Identifier "Geforce"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 3 (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Geforce"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Anyways, ideas and directions like: "do this and it will be fixed" are welcome!

Thanks again,

0
 
Old 09-21-2003, 02:28 AM   #2
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
After installing the Nvidia drivers, did you then modprobe them?

As root:
modprobe nvidia
Then, as your user:
startx

Cool
 
Old 09-21-2003, 01:26 PM   #3
patientzero
Member
 
Registered: Aug 2003
Location: Toronto
Distribution: Gentoo 1.4
Posts: 95

Original Poster
Rep: Reputation: 15
Sure, but do I do that EVERY time?
 
Old 09-21-2003, 01:27 PM   #4
patientzero
Member
 
Registered: Aug 2003
Location: Toronto
Distribution: Gentoo 1.4
Posts: 95

Original Poster
Rep: Reputation: 15
Startx also doesn't actually work well, it gives me just X by itself with no window managers, I have to do a gdm ...
 
Old 09-21-2003, 01:48 PM   #5
patientzero
Member
 
Registered: Aug 2003
Location: Toronto
Distribution: Gentoo 1.4
Posts: 95

Original Poster
Rep: Reputation: 15
OK so nvidia is loaded at boot according to lsmod and i tried running gdm anyways after modprobe ing and x just gives me a garbled screen...

furthermore, when I changed it back to nv from nvidia, x doesnt start and says "cannot open virtual console 7 (input/output error)

so @KJH@KJ@H@@!!!

bastards!
 
Old 09-21-2003, 02:01 PM   #6
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
You've got to setup a .xinitrc to launch your prefered window manager from startx. And look at /etc/modules.d/nvidia to see if there is a problem in the syntax in there to modprobe your nvidia driver. How did you go about installing it, emerge or grab the actual driver from Nvidia's website?

Cool
 
Old 09-21-2003, 03:47 PM   #7
patientzero
Member
 
Registered: Aug 2003
Location: Toronto
Distribution: Gentoo 1.4
Posts: 95

Original Poster
Rep: Reputation: 15
initially, i did the ermerge -k nevidia kernel, dunno if thats what i was suppsoed to do for it, and then i alsa grabbed the driver and installed it through the sh thing....
 
Old 09-21-2003, 03:50 PM   #8
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
I don't have much luck with emerging nvidia-kernel and nvidia-glx, so instead I just grab the drivers from nvidia.com and install via the sh 'thing'

Afterwards, you should ensure that /etc/modules.d/nvidia looks correct for the module name, and that you can indeed modprobe the nvidia module. Then, startx.

Be sure you have properly killed gdm, and that you are in runlevel 3 (don't panic this time, when you telinit, you may have to log back in):
telinit 3

Cool
 
Old 09-21-2003, 06:43 PM   #9
patientzero
Member
 
Registered: Aug 2003
Location: Toronto
Distribution: Gentoo 1.4
Posts: 95

Original Poster
Rep: Reputation: 15
My autoload thing loads an nvidia module, but when I do the emerge nvidia-kernel option, it says that the module changes from NVdriver to nvidia.o

So i tried using that in my xf86config-same problem, then i looked in the nvidia module.d thing and it doesnt even look at a module, just specifies a char and alias ....


This sucks...
0
 
Old 09-21-2003, 09:30 PM   #10
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Don't do the 'emerge nvidia-kernel' thing, instead use the driver from www.nvidia.com Then, make sure your /etc/modules.d/nvidia looks like:
Code:
# Nvidia drivers support
alias char-major-195 nvidia
alias /dev/nvidiactl char-major-195

# To tweak the driver the following options can be used, note that
# you should be careful, as it could cause instability!!
#
#   To enable Side Band Adressing:  NVreg_EnableAGPSBA=1
#
#   To enable Fast Writes: NVreg_EnableAGPFW=1
#
# To enable both for instance, uncomment following line:
#
options nvidia NVreg_EnableAGPSBA=1 NVreg_EnableAGPFW=1
Cool
 
Old 09-21-2003, 11:39 PM   #11
patientzero
Member
 
Registered: Aug 2003
Location: Toronto
Distribution: Gentoo 1.4
Posts: 95

Original Poster
Rep: Reputation: 15
Yeah, it does.... looks exactly like that...

I suck

=\
 
Old 09-22-2003, 01:34 AM   #12
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
And it doesn't work eh? Upon reboot, you don't get the module loading, or you do, but startx still doesn't work (don't do the gdm bit)?

Cool
 
Old 09-22-2003, 05:21 PM   #13
patientzero
Member
 
Registered: Aug 2003
Location: Toronto
Distribution: Gentoo 1.4
Posts: 95

Original Poster
Rep: Reputation: 15
nvidia loads, and lsmod shows it, but startx, or gdm don't work ...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gentoo hAtes me!!!!!!! HELP! Linuxfrog Linux - Distributions 6 10-20-2005 06:08 PM
root@localhost:~# xf86config -bash: xf86config: command not found klemen Slackware 17 01-06-2005 03:56 AM
where can I find the XF86Config and XF86Config-4 files? souaw Mandriva 4 04-21-2004 10:30 AM
Gentoo XF86Config help xquizit Linux - Newbie 3 07-13-2003 02:04 AM
Diff btw XF86Config-4 and XF86Config BorgKing Linux - Newbie 1 06-12-2002 02:31 PM


All times are GMT -5. The time now is 06:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration