LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   gEDA Install Error (http://www.linuxquestions.org/questions/linux-software-2/geda-install-error-378777/)

secureoffice 10-31-2005 07:43 PM

gEDA Install Error
 
Hi

When I ran the install script I got this error:

::::::::::::::::::::::::::::::::::::::::::::::

gspiceui-v0.7.56/fig/Makefile
gspiceui-v0.7.56/fig/OM-Analysis.fig
gspiceui-v0.7.56/fig/OM-FrmMain.fig
gspiceui-v0.7.56/fig/OM-GSpiceUI.fig
gspiceui-v0.7.56/fig/OM-PnlValue.fig
gspiceui-v0.7.56/fig/OM-Process.fig

OK
cd gspiceui-v0.7.56
OK
/root/geda-sources/gspiceui/gspiceui-v0.7.56
make
make config
make[1]: Entering directory `/root/geda-sources/gspiceui/gspiceui-v0.7.56'
make[1]: Nothing to be done for `config'.
make[1]: Leaving directory `/root/geda-sources/gspiceui/gspiceui-v0.7.56'
cd /root/geda-sources/gspiceui/gspiceui-v0.7.56/src ; make
make[1]: Entering directory `/root/geda-sources/gspiceui/gspiceui-v0.7.56/src'
g++ -c -O -Wall -pipe
-I/usr/local/lib/wx/include/gtk2-ansi-release-2.6
-I/usr/local/include/wx-2.6 -DGTK_NO_CHECK_CASTS -D__WXGTK__
-D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1
-DNO_GCC_PRAGMA -I/usr/include -I/usr/X11R6/include -I. -Ibase
-Imain -Inetlist -Ignucap -Ingspice -Iprocess -Iutility
AppGSpiceUI.cpp -o obj/AppGSpiceUI.o
CmdLinePcr.hpp:49: error: ISO C++ forbids
declaraticeUI' with no type
CmdLinePcr.hpp:49: error: expected ';' oken
CmdLinePcr.hpp:73: error: expected
`)' oken
AppGSpiceUI.cpp: In member function 'virtual bool
AppGSpiceUI::OnAppGSpiceUI.cpp:75:
error: no matching function for call to
'CmdLinePcr::CmdLinePcr(AppGSpiceUI* const)'
CmdLinePcr.hpp:46: note: candidates are:
CmdLinePcr::CmdLinePcr()
CmdLinePcr.hpp:46: note:
CmdLinePcr::CmdLinePcr(const CmdLinePcr&)
make[1]: *** [obj/AppGSpiceUI.o] Error 1
make[1]: Leaving directory `/root/geda-sources/gspiceui/gspiceui-v0.7.56/src'
make: *** [all] Error 2

Failure executing command make, ReturnCode = 2

============== Error! ======================
I can't make gspiceui for you; check the log for the reason why.
I have experienced an error while installing this program!
Error string: I can't make gspiceui for you; check the log for the reason why.


::::::::::::::::::::::::::::::::::::::::::

Any ideas on how to rectify this?

Cheers

Mochara


All times are GMT -5. The time now is 11:44 AM.