LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-17-2003, 03:25 PM   #1
shanenin
Member
 
Registered: Aug 2003
Location: Rochester, MN, U.S.A
Distribution: Gentoo
Posts: 987

Rep: Reputation: 30
Gaim fails to load msn plugin


I think I have the plugins installed. I have in the following directory /usr/local/lib/gaim, these two bianarys libmsn.so, libmsn.la

I get this error when I run gaim
"Gaim was unable to load your plugin
the required plugin MSN failed to load"
 
Old 10-17-2003, 03:33 PM   #2
kasperhans
Member
 
Registered: Oct 2003
Location: right behind the moon
Distribution: gentoo
Posts: 466

Rep: Reputation: 30
first you have to enable the plugin by creating an msn account ...
but i think thats because msn changed to the new msn 9 protocol, you can either wait for a new gaim release supporting it or try the newest version or usw amsn or any tool like this already supporting the new protocol
 
Old 10-17-2003, 04:13 PM   #3
moojuece
Member
 
Registered: Jul 2003
Location: mpls,mn
Distribution: Slackware,SuSE OpenExchange
Posts: 41

Rep: Reputation: 15
i have heard that ver .71 has the msn connection working...
 
Old 10-17-2003, 05:27 PM   #4
shanenin
Member
 
Registered: Aug 2003
Location: Rochester, MN, U.S.A
Distribution: Gentoo
Posts: 987

Original Poster
Rep: Reputation: 30
I should have left this in my original post, I am using the newest gaim, .71.

" first you have to enable the plug-in by creating an msn account "

I have an account, it trys to load the msn plugin but fails. I don't think this is anything to do with them changing protocol. my old version of gaim gave me an error that I was using the wrong protocol(because of the change at msn) that is why I was trying to install the new one.
 
Old 10-17-2003, 06:47 PM   #5
linksocc
Member
 
Registered: Jul 2003
Location: US
Distribution: Mandrake 9.0 1st/9.1 2nd/Gentoo 1.4 now
Posts: 313

Rep: Reputation: 30
try to compile it again and see if it works. May be it wasn't compiled the way it was supposed to be.

Last edited by linksocc; 10-17-2003 at 06:48 PM.
 
Old 10-17-2003, 06:56 PM   #6
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
make sure you read the MSN info at http://gaim.sf.net currently at the very top of the page
 
Old 10-17-2003, 06:59 PM   #7
jharris
Senior Member
 
Registered: May 2001
Location: Bristol, UK
Distribution: Slackware, Fedora, RHES
Posts: 2,243

Rep: Reputation: 46
Also, if you are using Slack then the following might be useful - http://www.linuxquestions.org/questi...415#post536415

cheers

Jamie...
 
Old 10-17-2003, 07:38 PM   #8
shanenin
Member
 
Registered: Aug 2003
Location: Rochester, MN, U.S.A
Distribution: Gentoo
Posts: 987

Original Poster
Rep: Reputation: 30
Thanks guys. I must need to compile with ssl support.
 
Old 10-18-2003, 06:12 AM   #9
jharris
Senior Member
 
Registered: May 2001
Location: Bristol, UK
Distribution: Slackware, Fedora, RHES
Posts: 2,243

Rep: Reputation: 46
My problem wasn't that I was missing the SSL support, it was that at run time it wouldn't find the libraries. If you run gaim -d you'll see the file name of the module (or part of module) that failes to load. If you run ldd fileName on this then you'll be able to verify if you problem was the same as mine as you'll get messages say that some of the libraries were not found.

HTH

Jamie...
 
Old 10-18-2003, 09:46 AM   #10
ewijaya
LQ Newbie
 
Registered: Oct 2003
Posts: 2

Rep: Reputation: 0
Quote:
Originally posted by shanenin
Thanks guys. I must need to compile with ssl support.

Hi,
Can you please advice how can I compile with SSL support?

Regards
 
Old 10-18-2003, 11:22 AM   #11
shanenin
Member
 
Registered: Aug 2003
Location: Rochester, MN, U.S.A
Distribution: Gentoo
Posts: 987

Original Poster
Rep: Reputation: 30
Thank you guys, it is now working.
---------------------------------------------------------
ewijaya,

this is how jharris told me to do it, I am not sure if this is specific to slackware or not(still a lot I do not understand)


this is the link
 
Old 10-19-2003, 06:56 PM   #12
motard
LQ Newbie
 
Registered: Oct 2003
Posts: 7

Rep: Reputation: 0
my post

look up my thread reolution gaim/msn
 
Old 10-23-2003, 10:41 PM   #13
bokavitch
LQ Newbie
 
Registered: Aug 2003
Location: Salt Lake City, Utah, United States
Distribution: Slackware 9.1
Posts: 8

Rep: Reputation: 0
I was having the same problem, thanks for the advice.
 
Old 10-23-2003, 10:59 PM   #14
shanenin
Member
 
Registered: Aug 2003
Location: Rochester, MN, U.S.A
Distribution: Gentoo
Posts: 987

Original Poster
Rep: Reputation: 30
with my slackware installation I just had to add this line>>/usr/lib/mozilla-1.4 to my /etc/ld.so.conf. then ran the command /sbin/ldconfig. Then it compiled with the needed ssl support.

With redhat linux that method did not work I did it this way. During the ./configure stage you need to show the location of your libraries and includes that are nessasary for ssl. I did not have the needed includes with my redhat installation, I had to copy them over from my slackware install. if you run this command in you gaim directory you will get the needed instuctions
./configure --help
below is part of that file
---------------------------------------------------------------------
--with-nspr-includes=PREFIX Specify location of Mozilla nspr4 includes.
--with-nspr-libs=PREFIX Specify location of Mozilla nsp4 libs.
--with-nss-includes=PREFIX Specify location of Mozilla nss3 includes.
--with-nss-libs=PREFIX Specify location of Mozilla nss3 libs.
-------------------------------------------------------------------------
you will need to show where the fiels are like this
./configure --(each of the four above)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gaim/msn Boffy Linux - Software 4 02-16-2005 12:07 PM
Gaim - MSN ?!? Morpheusx00x Linux - Newbie 5 08-06-2004 03:52 PM
gaim and msn sub_slack Slackware 42 06-14-2004 04:36 PM
How do I use msn on GAIM truedlp Linux - Newbie 10 11-26-2003 02:29 AM
Gaim/MSN protocols and problems upgrading Gaim and Kopete. sergeantroach Linux - Software 5 11-01-2003 09:27 PM


All times are GMT -5. The time now is 07:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration