LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-20-2003, 06:42 PM   #1
schbond
Member
 
Registered: May 2002
Distribution: Gentoo
Posts: 54

Rep: Reputation: 15
Gaim 0.66 from source


I am trying to install Gaim v0.66 from source. I installed Gtk+-2.2.2 and deps: glib-2.2.2, atk-1.2.4, and pango-1.2.3, all from source (and all without errors). I then tried to configure gaim, but messages saying that perl, audio, NAS, and spellcheck (aspell), weren't supported. I don't know what NAS is, but I know I want support for the rest.

I installed aspell (without error) and Gtkspell (with following error):

configure: error: You must have the aspell or pspell dev libraries to build gtkspell.

I searched high and low for source and .deb packages for aspell-dev, "dev aspell" and I can't find anything resembling development package for aspell. I thought then "I can live without spellcheck," and installed the other packages (all else went fine). However, when I tried to re-configure gaim, I get:

checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.0.1, but GLIB (2.2.2)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at http://www.gtk.org/.

I don't remember installing any other version of Glib other than 2.2.2, and I didn't uninstall v2.2.2. I don't want to find out the hard way what LD_LIBRARY_PATH and PKG_CONFIG_PATH are/do, so I am asking here.

Please help me configure gaim (with spellcheck support, if possible). Thanks!

By the way, "apt-get install gaim" provides gaim 0.58, and I would prefer the new features of 0.66 (especially gtk2-based GUI).

*** Debian Woody, KDE 3.1.2, custom kernel 2.4.21 ***
 
Old 07-20-2003, 08:14 PM   #2
Half_Elf
LQ Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 45
your base system probably came with glib 2.0.1 installed. Just hide it to pkg-config in modifying LD_LIBRARY_PATH (echo $LD_LIBRARY_PATH to see it, LD_LIBRARY_PATH="whatever" to set it). editing /etc/ld.so.conf
may help too. The goal is just to make your glib 2.0.1 undected to your system and so to pkg-config.

this is a very common but annoying msg 'bout gnome/gtk things, you'll have to mess deeply inside your lib to fix it (pkg-config is stupid, really, it can be a real pain to pass trought this useless error).
 
Old 07-20-2003, 08:54 PM   #3
schbond
Member
 
Registered: May 2002
Distribution: Gentoo
Posts: 54

Original Poster
Rep: Reputation: 15
"echo $LD_LIBRARY_PATH" returns nothing:

# echo $LD_LIBRARY_PATH

#

So I tried setting it to /usr/local (didn't work), then /usr/local/lib (also didn't work), and finally /usr/local/glib-2.2.2/ (Gaim still won't configure). I even tried exporting these paths to PKG_CONFIG_PATH.

/etc/ld.so.conf says:

/usr/X11/lib
/usr/local/lib

I added /usr/local/glib-2.2.2 and it still wouldn't configure. I am really at a loss to solve this problem.
 
Old 07-21-2003, 02:10 AM   #4
Half_Elf
LQ Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 45
you misunderstood me. You don't have to add glib-2.2.2, you have to HIDE glib-2.0.1 you probably has somewhere (find it first of course!).
Just modify ld.so.conf and LD_LIBRARY_PATH to make sure your system (so pkg-config) will NOT find this useless lib, then run ld-config.

oh, btw, pkg-config is stupid enought to give you a "default" error that doesn't make sense, if you don't have ANY remaining glib-2.0.1 on your system (you have to be REALLY sure, a single forgotten links can make pkg-config to think you have it) the error is maybe something else, maybe you are missing some deps, or that something is broken?
 
Old 07-22-2003, 03:20 AM   #5
nirva
Member
 
Registered: Mar 2003
Location: RI
Distribution: Slack 9.1
Posts: 35

Rep: Reputation: 15
I finally got GTK+-2.0.9 to install by doing the combination of what everyone said. First, I editted the /etc/ld.so.conf file and added /usr/local/lib/pkgconfig at the end and saved it. For atk I had to do 'export LD_LIBRARY_PATH=/usr/local/lib' and that made it configure correctly. After setting those two variables I was able to install pango without a problem, and then GTK configured fine.

Hopefully the paths are the same for your system, but there can be come differences, just browse through all the pkg-config problem threads and you'll eventually get there.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to integrate driver source into kernel source tree zhchang Linux - Software 5 11-23-2005 01:34 AM
Compiling gaim-otr with 2 different version of Gaim Backstander Linux - Software 1 10-31-2005 01:22 AM
where is linux source build directory/kernel source tree? webazoid Linux - Software 2 07-01-2004 09:37 PM
Gaim/MSN protocols and problems upgrading Gaim and Kopete. sergeantroach Linux - Software 5 11-01-2003 09:27 PM
Problem Installing/Upgrading Gaim 0.60 or Gaim 0.71 AskMe Linux - Newbie 1 10-25-2003 09:00 PM


All times are GMT -5. The time now is 07:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration