LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-22-2003, 10:28 AM   #1
kko88
Member
 
Registered: May 2003
Location: Denver, Colorado
Distribution: Slackware 9.0
Posts: 43

Rep: Reputation: 15
GAIM 0.62 and GLib


I installed SuSE 8.1 over my MDK 9.1 yesterday and when I try to install Gaim, I end up with problems. I installed all the dependencies that was required to install GTK 2.x.x and when I try to run "rpm --install" and the gaim rpm package, it says I need some dependencies. But when I run the configure file, I end up with this as an error message.




Quote:
*** 'pkg-config --modversion glib-2.0' returned 2.2.1, but GLIB (2.0.6)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at http://www.gtk.org/.
I'm not exactly sure on how to do this... so any help would be appreciated. Thanks!
 
Old 05-22-2003, 11:31 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
ok so what version of glib IS installed?

rpm -qa | grep glib

update it.
 
Old 05-22-2003, 12:45 PM   #3
kko88
Member
 
Registered: May 2003
Location: Denver, Colorado
Distribution: Slackware 9.0
Posts: 43

Original Poster
Rep: Reputation: 15
Well, I tried deleting it with the SuSE Control Panel and the Add/Remove Program thing from there, but it says that over 100 other apps would not work because they depend on that. I also tried updating it withing the Add/Remove Programs thing from the Control Panel but it did nothing,

When I run "rpm -qa | grep glib" I get

Quote:
glibc-2.2.5-152
glib-1.2.10-305
glibc-locale-2.2.5-151
glibc-devel-2.2.5-151
glibc-html-2.2.5-151
glibc-info-2.2.5-151
glibc-profile-2.2.5-151
glibc-i18ndata-2.2.5-151
glib-devel-1.2.10-305
glib2-2.0.7-0
EDIT: I'm not sure on how to do this LD_LIBRARY_PATH thing. My attempts at iit based on the GTK Installation Instuctions have failed miserabley. I even uninstalled Glib2 and installed 2.2.5 agaqin. Gaim still didn't compile. I then installed version 2.0.7 of GLib from the SuSE site. Still not working. Any help would be appreciated. Thanks!

Last edited by kko88; 05-22-2003 at 02:49 PM.
 
Old 05-22-2003, 06:14 PM   #4
Obi Perrin
Member
 
Registered: Nov 2002
Posts: 136

Rep: Reputation: 15
Well we can rule out all of the glibc's in the above. glibc is _quite_ different from glib and glib2. You've got the old version of glib there, both the library and the dev files, but you seem to only have the library of glib2 and not the glib2-dev rpm. Suse should have an ability to check the CD's for packages available? See if you can find anything matching glib2-dev.

One of the "joys" of RPMs that end up confusing people is the breakup of packages. Considering that RPMs are supposed to be for newbies, it's anti-intuitive to expect that person to automatically know that they must have a number of different types of that rpm in order to compile programs based on the library. Sorry, just don't like RPMs

But hopefully the lack of the glib2 headers should be the source of your problem. Install those and try the gaim compile again.
 
Old 05-22-2003, 08:35 PM   #5
kko88
Member
 
Registered: May 2003
Location: Denver, Colorado
Distribution: Slackware 9.0
Posts: 43

Original Poster
Rep: Reputation: 15
I installed the glib2-dev package from the suse cd, but it was for version 2.0.6 . When I ran the rpm --install, I got

Quote:
error: failed dependencies:
libc.so.6(GLIBC_2.3) is needed by gaim-0.63-1
but I know I have this file because I've seen it in my library folders somewhere in some library folder. And if I uninstall Glib 2.0.7 then when I cconfigure, make, make install, I get an error during 'make' that I don't have Glib2 installed. How very confused I am...

EDIT: Typos

Last edited by kko88; 05-22-2003 at 08:45 PM.
 
Old 05-22-2003, 09:48 PM   #6
kko88
Member
 
Registered: May 2003
Location: Denver, Colorado
Distribution: Slackware 9.0
Posts: 43

Original Poster
Rep: Reputation: 15
I uninstalled both the not working glib2.7 and the -dev package and redid the 'confiigure' 'make' 'make install' for glib2.2.1 which is on the gtk ftp site. Sadly, when I do the '# rpm -qa | grep glib" command, I don't see GLib2 anything. Only

Quote:
glibc-2.2.5-152
glib-1.2.10-305
glibc-locale-2.2.5-151
glibc-devel-2.2.5-151
glibc-html-2.2.5-151
glibc-info-2.2.5-151
glibc-profile-2.2.5-151
glibc-i18ndata-2.2.5-151
glib-devel-1.2.10-305
I don't know what to do now. Glib doesn't even want to install now. This is so frustrating.
 
Old 05-23-2003, 01:16 PM   #7
Obi Perrin
Member
 
Registered: Nov 2002
Posts: 136

Rep: Reputation: 15
Okay, you seem to be confusing things a little. Gaim (and this is as far as I know), is not that strict in the required version of GLib. Your current version of GLib - the one you ./configure, make, make install'ed from the GTK site - should be just fine, so don't go deleting it

There are a number of different install methods in Linux, and you seem to be mixing and matching them indiscriminately. RPM packages, generally binaries, were made to be much easier for the new user. But because these packages are binaries, they're heavily tied to the type of system that the RPM was made on. Now, correct me if I'm wrong, but when you got this error: "ibc.so.6(GLIBC_2.3) is needed by gaim-0.63-1", you were attempting to install the Gaim RPM from their site? It's compiled for Mandrake 9.1 and not for Suse 8.1. Sometimes you can get lucky and an RPM for one system will work for another, but it appears that Suse 8.1 uses glibc2.2, whilst Mandrake uses glibc2.3. Don't confuse these with GLib, it's totally different. These versions of glibc are incompatible with each other. Hence when you try to install the Mandrake RPM of gaim, it's tied to glibc2.3, and your system comes with 2.2.

Now, why doesn't your version of GLib come up in the rpm -qa | grep glib command? Because it wasn't an RPM install. One of the actually useful aspects of RPM is that if you install one, each of the installed files will be registered in the RPM database, allowing you to easily ascertain the version number etc. You did a source compile, which means that GLib is compiled for your specific system. And as it was a source compile, it doesn't show up in the RPM database, which is all that command searches for.

Having never used Suse 8.1, and being bamboozled by the sheer number of GLib installs and uninstalls that you've done, I must admit to being slightly lost as to where you are currently. You can try something though. Download the Gaim bz2 source file. Maybe you already have it? *shrug*. As root, open up /etc/ld.so.conf. Is the line /usr/local/lib there? If it isn't, add it. As far as I remember, that's what GLib should default to installing to if not given a prefix in the configure stage. Now do 'ldconfig' - this will update your systems list of available libraries.

Extract the Gaim bz2 file and cd into it. Run ./configure, make and make install. What do you get now?
 
Old 05-23-2003, 02:29 PM   #8
kko88
Member
 
Registered: May 2003
Location: Denver, Colorado
Distribution: Slackware 9.0
Posts: 43

Original Poster
Rep: Reputation: 15
Ok, my /etc/ld.so.conf contains /usr/local/lib and I did get the bz2 source file from the site. I still get the error message:

Quote:
checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.2.1, but GLIB (2.0.6)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at http://www.gtk.org/.
I can't get the Glib vversion from the gtk.org site to install. I don't know how to install it. I got the source, /configue'ed it, and make and then make install'ed it and yet, when I tried to install gaim both through the rpm and the .tar source, I find out that glib isn't installed at all! So I reinstalled glib 2.0.6 from the suse cd. Now I'm back to where I started. I'm not positive as to what you meant by

Quote:
Extract the Gaim bz2 file and cd into it.
I extracted the gaim.bz2 fiile and /configured it but I'm not sure what to do with a cd.
 
Old 05-23-2003, 03:14 PM   #9
Obi Perrin
Member
 
Registered: Nov 2002
Posts: 136

Rep: Reputation: 15
I just meant 'cd' as in the command to move into the directory after the source had been fully extracted.

Now you have the SuSe default of Glib2 installed? Checking the SuSe FTP site, this should be version 2.0.6, as you've said. Directly under it is this url:

ftp://ftp.suse.com/pub/suse/i386/8.1....6-45.i586.rpm

Install this from your SuSe cd (or just download, it's only 90KB), it should match the version of your GLib now that you're back to the system default and hence resolve the ./configure problem about not being able to find the header files.

Before you go to Gaim, run "rpm -qa | grep glib" to make sure you have everything you need. As both the library glib2 and dev glib2 packages you installed are RPMs, they should be in that list. Run 'ldconfig', just to be sure that any static development libraries provided by glib2 are picked up.

Now go into the gaim directory and try ./configure again. If that doesn't do it, I don't know what will :-/.
 
Old 05-23-2003, 03:33 PM   #10
kko88
Member
 
Registered: May 2003
Location: Denver, Colorado
Distribution: Slackware 9.0
Posts: 43

Original Poster
Rep: Reputation: 15
Thanks. But when I did "ldconfig" I got:

ldconfig: /lib/libpthread.so.0 is not a symbolic link

as an error message... I think it's an error message anyways. Is that something I can disregard? Or is it a problem?

How odd. I still got the same error when running /configure for gaim. It consistently tells me that pkg-config is returning glib as version 2.2.1 but blig 2.0.6 was found. I'm not sure how to edit the LD_LIBRARY_PATH and I already tried uninstalling the old version of glib (2.0.6) and installing ver. 2.2.1 again. Does SuSE not like me?

EDIT: I'm just wondering, is there a way to ininstall Glib 2.2.1 even when only PKGConfig seems to find it?

Last edited by kko88; 05-23-2003 at 04:58 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
gaim install can't find glib dratix Linux - Software 1 06-09-2005 04:42 PM
Compiling GAIM says i need GLib 2.0, yet i have GLib 2.4 MadSkillzMan Linux - Newbie 3 07-10-2004 04:10 AM
Problem with gaim/glib Oakstaff Linux - Software 5 04-21-2004 01:27 AM
Gaim .66 glib 2.0 error p1az Linux - Software 4 08-05-2003 11:32 AM
glib 2.0.0 and gaim 0.59 GT I.N.C Linux - Newbie 2 07-10-2002 12:10 AM


All times are GMT -5. The time now is 08:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration