LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-01-2003, 02:04 PM   #16
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64

If you want, you can post up your /var/log/proftpd.log file so we can see what's going on and try to help...

Cool
 
Old 03-02-2003, 05:07 AM   #17
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Original Poster
Rep: Reputation: 30
well I think to long but never mind :] :
Dec 30 22:38:58 localhost proftpd[1620] localhost: ProFTPD 1.2.5 (built Sun Jun 9 17:24:50 PDT 2002) standalone mode STARTUP
Dec 30 22:39:12 localhost proftpd[1623] localhost (cl176-220.ktv.lt[213.226.176.220]): FTP session opened.
Dec 30 22:39:12 localhost proftpd[1623] localhost (cl176-220.ktv.lt[213.226.176.220]): no such user 'ftp'
Dec 30 22:39:12 localhost proftpd[1623] localhost (cl176-220.ktv.lt[213.226.176.220]): USER ftp: no such user found from cl176-220.ktv.lt [213.226.176.220] to 213.226.176.220:21
Dec 30 22:39:12 localhost proftpd[1623] localhost (cl176-220.ktv.lt[213.226.176.220]): FTP session closed.
Dec 30 22:44:41 localhost proftpd[134] localhost: Failed binding to 0.0.0.0, port 21: Address already in use
Dec 30 22:44:41 localhost proftpd[134] localhost: Check the ServerType directive to ensure you are configured correctly.
Dec 30 22:53:15 localhost proftpd[138] localhost: Failed binding to 0.0.0.0, port 21: Address already in use
Dec 30 22:53:15 localhost proftpd[138] localhost: Check the ServerType directive to ensure you are configured correctly.
Dec 30 22:53:23 localhost proftpd[140] localhost: Failed binding to 0.0.0.0, port 21: Address already in use
Dec 30 22:53:23 localhost proftpd[140] localhost: Check the ServerType directive to ensure you are configured correctly.
Dec 30 22:53:27 localhost proftpd[143] localhost: Failed binding to 0.0.0.0, port 21: Address already in use

That is the most important cause everything else is repeating...
 
Old 03-02-2003, 05:18 AM   #18
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
So after you created user ftp what happened?
 
Old 03-02-2003, 05:19 AM   #19
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Original Poster
Rep: Reputation: 30
Dudes here is my config... Who understands correct it plz
==============
ServerName "My personal server"
ServerType standalone

# Port 21 is the standard FTP port.
Port 21

# Set the user and group that the server normally runs at.
User nobody
Group nogroup

MaxInstances 5

# Set the maximum number of seconds a data connection is allowed
# to "stall" before being aborted.
TimeoutStalled 300

DisplayLogin welcome.msg
DisplayFirstChdir .message

# Our "basic" anonymous configuration, including a single
# upload directory ("uploads")
<Anonymous ~ftp>

# Allow logins if they are disabled above.
<Limit LOGIN>
AllowAll
</Limit>

# Maximum clients with message
MaxClients 5 "Sorry, max %m users are allowed -- try again later"

User ftp
Group ftp
# We want clients to be able to login with "anonymous" as well as "ftp"
UserAlias anonymous ftp

# Limit WRITE everywhere in the anonymous chroot
<Limit WRITE>
DenyAll
</Limit>

# An upload directory that allows storing files but not retrieving
# or creating directories.
<Directory uploads/*>
<Limit READ>
DenyAll
</Limit>

<Limit STOR>
AllowAll
</Limit>
</Directory>

# Hide all files owned by user 'root'
HideUser root

</Anonymous>
#EOF
==============
But when I start proftpd, I get:
500 Sorry, no server available to handle request on cl176-220.ktv.lt.
ftp>

???
 
Old 03-02-2003, 05:20 AM   #20
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Original Poster
Rep: Reputation: 30
U see I had it before:
ftp:*:1001:0::/home/ftp:
 
Old 03-02-2003, 05:35 AM   #21
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Check your /etc/ftpusers file, make sure you have included a # in front of a user ftp if one exists. In other words, comment out the ftp user if there is one in there.
 
Old 03-02-2003, 05:35 AM   #22
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Are you on Slack or what?
 
Old 03-02-2003, 05:46 AM   #23
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Original Poster
Rep: Reputation: 30
damn, I've go it work, but then I have read CrashedAgain tips and server doesn't works again...uhhh
Chad, I am on Slack offcourse.
When I will fix the problem I will inform U Chad and if you want you can connect to my box
 
Old 03-02-2003, 05:52 AM   #24
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Thanks. I don't see anything immediately wrong with your conf file, and if you have the user added, and owning the directory that you want your users to connect to... I don't see a defaultRoot.

Try making a default root, and then owning that directory to user/group ftp like so:
DefaultRoot ~
(Place that just under the standalone entry)
And then, look at your user "ftp" and see where the home directory lives for him. Then:
chown -R ftp:ftp /path/to/ftp/home (probably /home/ftp since that's default)

Cool
 
Old 03-02-2003, 05:55 AM   #25
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Original Poster
Rep: Reputation: 30
Ok here is what I have got...:
when I do ftp localhost I get:
[root@ ~/tmp/proftpd-1.2.7]# ftp localhost
Connected to localhost.
220 ProFTPD 1.2.7 Server (My personal server) [localhost]
Name (localhost:root): ftp
331 Anonymous login ok, send your complete email address as your password.
Password:
230-Hello, you are on My personal FTP server! Enjoy!
230 Anonymous access granted, restrictions apply.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> ls
200 PORT command successful
150 Opening ASCII mode data connection for file list
226 Transfer complete.
ftp>

When I do ftp "My IP":
[root@ ~/tmp/proftpd-1.2.7]# ftp 213.226.176.220
Connected to 213.226.176.220.
500 Sorry, no server available to handle request on cl176-220.ktv.lt.
ftp>

 
Old 03-02-2003, 06:00 AM   #26
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Original Poster
Rep: Reputation: 30
sorry such big amount of stupid questions I am in a hurry
 
Old 03-02-2003, 06:02 AM   #27
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Hmmm... I just got the same thing.

Very odd indeed. Just for fun, try switching server type to inetd:
#ServerType standalone
ServerType inetd

And adding (or modifying actually) this line to /etc/inetd.conf:
# File Transfer Protocol (FTP) server:
ftp stream tcp nowait root /usr/sbin/tcpd proftpd

If it doesn't already exist as such.

Then, follow the directions at the top of /etc/inetd.conf and type:
Code:
# If you make changes to this file, either reboot your machine or send the
# inetd a HUP signal:
# Do a "ps x" as root and look up the pid of inetd. Then do a
# "kill -HUP <pid of inetd>".
# The inetd will re-read this file whenever it gets that signal.
#
Cool
 
Old 03-02-2003, 06:04 AM   #28
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Quote:
Originally posted by nautilus_1987
Ok here is what I have got...:
when I do ftp localhost I get:
[root@ ~/tmp/proftpd-1.2.7]# ftp localhost
Connected to localhost.
220 ProFTPD 1.2.7 Server (My personal server) [localhost]
Name (localhost:root): ftp
331 Anonymous login ok, send your complete email address as your password.
Password:
230-Hello, you are on My personal FTP server! Enjoy!
230 Anonymous access granted, restrictions apply.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> ls
200 PORT command successful
150 Opening ASCII mode data connection for file list
226 Transfer complete.
ftp>

When I do ftp "My IP":
[root@ ~/tmp/proftpd-1.2.7]# ftp 213.226.176.220
Connected to 213.226.176.220.
500 Sorry, no server available to handle request on cl176-220.ktv.lt.
ftp>

This one just keeps screaming at me "port forwarding" however if you are using your actual IP I'm guessing you don't have a need to use port forwarding. But, look into any IPTables you've got setup. If you are using firewalker for your firewall script, make sure you aren't blocking port 21 traffic (from anywhere, not just iptables).

Cool
 
Old 03-02-2003, 06:07 AM   #29
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Original Poster
Rep: Reputation: 30
all firewalls are shut down...
Oh I have a question how can I enable logging in ProFTPd?
(U see I have put my config in /etc/proftpd.conf so I shrinked the default config)
 
Old 03-02-2003, 06:10 AM   #30
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Original Poster
Rep: Reputation: 30
by the way do I have to make:
ftp stream tcp nowait root /usr/sbin/tcpd proftpd OR
ftp stream tcp nowait root /usr/sbin/proftpd proftpd
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ftp(through web site access to ftp server) kelper Linux - Software 4 07-03-2015 06:14 PM
ftp server - Pure ftp - logs in OK but no files visible tp11235 Linux - Networking 2 08-30-2005 06:11 AM
FTP Server Up and running... how do I hide ftp users from local login screen? joe1031 Mandriva 2 03-18-2005 05:24 PM
How do I set my FTP server to accept passive FTP? imsam Linux - Newbie 3 12-12-2004 07:22 AM
how can I restrict ftp users listing files from a pure-ftp server adrianmak Linux - Networking 2 12-31-2002 09:23 AM


All times are GMT -5. The time now is 09:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration