LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-31-2003, 10:42 AM   #1
scottpioso
Member
 
Registered: Jan 2003
Location: United States of America and damn proud of it!
Distribution: Ubuntu
Posts: 466

Rep: Reputation: 30
FTP Login Problems


Hello,

I just completed the 2nd attempt at setting up my FTP server here. I followed the READMEs to the letter, but as an acid test, I tried to login from a separate box and got an error. I thought I should try to log in locally and this is the same error I got before:

root@ASUSA7V266-E vsftpd]# ftp
ftp> open
(to) 10.0.0.20
ftp: connect: Connection refused
ftp>

I'm at a loss to know what to do to allow me to login. I'm sure it's quite simple but I've been pulling my hair out trying to figure it out.

Thank you very much to whoever helps in advance!!
 
Old 12-31-2003, 08:35 PM   #2
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 57
1. Is the server running at all? If you have it running standalone (not from inetd or xinetd) you should be able to see it using ps -e.

2. Can you access it from the same computer that runs the FTP server?

3. Do you have a firewall (iptables, etc) running? If so, does it allow inbound connections to port 21?

I shouldn't really be posting this, it's 3.40am January 1st and I really should go to bed. But best of luck to you and a happy new year!

Håkan
 
Old 01-01-2004, 08:41 AM   #3
scottpioso
Member
 
Registered: Jan 2003
Location: United States of America and damn proud of it!
Distribution: Ubuntu
Posts: 466

Original Poster
Rep: Reputation: 30
Hi Hakan, (sorry I couldn't put the accent),

Well, I can't remember how to check the firewall settings once Linux is installed but in answer to first question, no, I can't log in from the machine in which it's installed and I can't figure out why. I know it's nothing too complicated but I spent hours yesterday trying to figure out what the problem was. If you can help, it would be greatly appreciated. Thanks and Happy New Year to you too!!
 
Old 01-01-2004, 09:56 AM   #4
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 57
After some research (I haven't been using Redhat for years): In Redhat I think you have a few graphical tools to help you along the way. Open a terminal (or console or what you want to call it) and type su and enter the password when asked to in order to become the root user. Then type redhat-config-services to get a graphical system daemon config tool. Here you can specify what services you want started on boot, like the vsftpd FTP daemon. When done, type service xinetd restart to let the changes take effect.

If you want to do it the Unix way and edit config files I believe you can change the line "disable = yes" to "disable = no" in /etc/xinetd.d/vsftpd instead. You will still have to restart xinetd.

If you haven't got the vsftpd config file the vsftpd daemon (which is the standard RH9 FTP server) isn't installed. There is an rpm for it on your installation CD's, or on your local Redhat FTP server mirror.
 
Old 01-01-2004, 12:21 PM   #5
scottpioso
Member
 
Registered: Jan 2003
Location: United States of America and damn proud of it!
Distribution: Ubuntu
Posts: 466

Original Poster
Rep: Reputation: 30
Yes, yes, thank you. I know this. I have the daemon installed. The service has been started. The problem is logging into the FTP server sitting at the Linux box (and of course remotely) I get a connection refused error from the local machine and remotely, I get a similiar problem.

Secondly, I do not even have a vsftpd file under /etc/xinted.d

However, I do have the vstfpd.conf file but it will not start and when I reboot the machine, I get an error when it tried to stop the vsftpd.

So, I hope this makes it crystal clear as to my problem. I would greatly appreciate any help from anyone.
 
Old 01-01-2004, 12:25 PM   #6
scottpioso
Member
 
Registered: Jan 2003
Location: United States of America and damn proud of it!
Distribution: Ubuntu
Posts: 466

Original Poster
Rep: Reputation: 30
In addition, I have included the vsftpd.conf file. Thank you.

--------------------------------------------------------------------------------------------------------------------------

# Example config file /etc/vsftpd.conf
#
# The default compiled in settings are very paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
#
# Allow anonymous FTP?
anonymous_enable=NO
#
# Uncomment this to allow local users to log in.
local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
write_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
local_umask=022
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
#anon_upload_enable=YES
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#anon_mkdir_write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
dirmessage_enable=YES
#
# Activate logging of uploads/downloads.
xferlog_enable=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
connect_from_port_20=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
#chown_uploads=YES
#chown_username=whoever
#
# You may override where the log file goes if you like. The default is shown
# below.
xferlog_file=/var/log/vsftpd.log

# If you want, you can have your log file in standard ftpd xferlog format
xferlog_std_format=YES
#
# You may change the default value for timing out an idle session.
idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
data_connection_timeout=120
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
#nopriv_user=ftpsecure
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that turning on ascii_download_enable enables malicious remote parties
# to consume your I/O resources, by issuing the command "SIZE /big/file" in
# ASCII mode.
# These ASCII options are split into upload and download because you may wish
# to enable ASCII uploads (to prevent uploaded scripts etc. from breaking),
# without the DoS risk of SIZE and ASCII downloads. ASCII mangling should be
# on the client anyway..
#ascii_upload_enable=YES
#ascii_download_enable=YES
#
# You may fully customise the login banner string:
#ftpd_banner=Welcome to blah FTP service.
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/etc/vsftpd.banned_emails
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
#chroot_list_enable=YES
# (default follows)
#chroot_list_file=/etc/vsftpd.chroot_list
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
#ls_recurse_enable=YES

pam_service_name=vsftpd
userlist_enable=YES

#enable for standalone mode

listen=YES
tcp_wrappers=YES
 
Old 01-01-2004, 01:17 PM   #7
g-rod
Member
 
Registered: Dec 2003
Location: Long Island, NY USA
Distribution: RedHat, SUSE
Posts: 336

Rep: Reputation: 30
That looks good. You might be firewalling the connect. Try flushing the firewall.
iptables -F;
Make sure that vsftpd is running.
/etc/init.d/vsftpd status;
Try connecting.
 
Old 01-01-2004, 01:41 PM   #8
scottpioso
Member
 
Registered: Jan 2003
Location: United States of America and damn proud of it!
Distribution: Ubuntu
Posts: 466

Original Poster
Rep: Reputation: 30
Dammit, no change. Still cannot connect and I get the error below which I think is normal. I'm getting really pissed here. I connected fine before I blew my system. I don't know what the problem is.


vsftpd dead but subsys locked
 
Old 01-01-2004, 01:44 PM   #9
scottpioso
Member
 
Registered: Jan 2003
Location: United States of America and damn proud of it!
Distribution: Ubuntu
Posts: 466

Original Poster
Rep: Reputation: 30
One other thing, how can I be sure that it's installed properly??

And if I try to stop the service, I get a FAILED message.

Last edited by scottpioso; 01-01-2004 at 01:46 PM.
 
Old 01-01-2004, 01:49 PM   #10
g-rod
Member
 
Registered: Dec 2003
Location: Long Island, NY USA
Distribution: RedHat, SUSE
Posts: 336

Rep: Reputation: 30
Relax we'll get this working.
vsftpd is not starting.
Open a terminal window and type
tail -f /var/log/messages;
Then in another window try to restart the ftp service.
Type /etc/init.d/vsftpd restart;
It will give you errors I know.
What I need to know is what appeared in the /var/log/messages that I had you tail. This should help us troubleshoot why it is not starting.
 
Old 01-01-2004, 01:52 PM   #11
scottpioso
Member
 
Registered: Jan 2003
Location: United States of America and damn proud of it!
Distribution: Ubuntu
Posts: 466

Original Poster
Rep: Reputation: 30
[root@ASUSA7V266-E root]# tail -f var/log/messages
tail: var/log/messages: No such file or directory
tail: no files remaining
[root@ASUSA7V266-E root]# /etc/init.d/vsftpd restart
Shutting down vsftpd: [FAILED]
Starting vsftpd for vsftpd: [ OK ]
[root@ASUSA7V266-E root]#
 
Old 01-01-2004, 01:55 PM   #12
g-rod
Member
 
Registered: Dec 2003
Location: Long Island, NY USA
Distribution: RedHat, SUSE
Posts: 336

Rep: Reputation: 30
You missed the leading / in
tail -f /var/log/messages;
This the kernel log file. Kinda like the event log in windows.
 
Old 01-01-2004, 01:57 PM   #13
scottpioso
Member
 
Registered: Jan 2003
Location: United States of America and damn proud of it!
Distribution: Ubuntu
Posts: 466

Original Poster
Rep: Reputation: 30
[root@ASUSA7V266-E log]# tail -f /var/log/messages
Jan 1 13:47:26 ASUSA7V266-E modprobe: modprobe: Can't locate module sound-slot-1
Jan 1 13:47:26 ASUSA7V266-E modprobe: modprobe: Can't locate module sound-service-1-0
Jan 1 13:47:26 ASUSA7V266-E modprobe: modprobe: Can't locate module sound-slot-1
Jan 1 13:47:26 ASUSA7V266-E modprobe: modprobe: Can't locate module sound-service-1-0
Jan 1 13:47:29 ASUSA7V266-E gconfd (root-6384): starting (version 2.2.0), pid 6384 user 'root'
Jan 1 13:47:29 ASUSA7V266-E gconfd (root-6384): Resolved address "xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only config source at position 0
Jan 1 13:47:29 ASUSA7V266-E gconfd (root-6384): Resolved address "xml:readwrite:/root/.gconf" to a writable config source at position 1
Jan 1 13:47:29 ASUSA7V266-E gconfd (root-6384): Resolved address "xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only config source at position 2
Jan 1 13:48:59 ASUSA7V266-E vsftpd: vsftpd shutdown failed
Jan 1 13:48:59 ASUSA7V266-E vsftpd: true startup succeeded
 
Old 01-01-2004, 02:05 PM   #14
g-rod
Member
 
Registered: Dec 2003
Location: Long Island, NY USA
Distribution: RedHat, SUSE
Posts: 336

Rep: Reputation: 30
It saying it started up ok, but its not running?
I want to see if there is anything listening on the ftp ports, and where your configuration files for vsftp are located.
What is the output of
netstat -pan;
find /etc/ -name "vsftpd.*";
 
Old 01-01-2004, 02:10 PM   #15
scottpioso
Member
 
Registered: Jan 2003
Location: United States of America and damn proud of it!
Distribution: Ubuntu
Posts: 466

Original Poster
Rep: Reputation: 30
[root@ASUSA7V266-E root]# netstat -pan
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:32768 0.0.0.0:* LISTEN 3394/rpc.statd
tcp 0 0 0.0.0.0:9098 0.0.0.0:* LISTEN 6059/xinetd
tcp 0 0 127.0.0.1:33260 0.0.0.0:* LISTEN 6059/xinetd
tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN 3375/portmap
tcp 0 0 0.0.0.0:6000 0.0.0.0:* LISTEN 6205/X
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 3498/sshd
tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN 3584/cupsd
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 3545/sendmail: acce
tcp 0 0 10.0.0.20:33329 204.221.192.231:80 ESTABLISHED 6430/mozilla-bin
tcp 0 0 10.0.0.20:33322 204.221.192.231:80 ESTABLISHED
430/mozilla-bin
tcp 0 0 10.0.0.20:33306 207.46.106.18:1863 ESTABLISHED 6386/gaim
tcp 0 0 10.0.0.20:33375 64.157.107.103:80 ESTABLISHED 6430/mozilla-bin
tcp 0 0 10.0.0.20:33374 64.157.107.103:80 ESTABLISHED 6430/mozilla-bin
tcp 0 0 10.0.0.20:33372 64.157.107.87:80 ESTABLISHED 6430/mozilla-bin
tcp 0 0 10.0.0.20:33305 216.136.226.208:5050 ESTABLISHED 6386/gaim
tcp 0 0 127.0.0.1:34611 127.0.0.1:631 TIME_WAIT -
tcp 0 0 127.0.0.1:34614 127.0.0.1:631 TIME_WAIT -
tcp 0 0 127.0.0.1:34615 127.0.0.1:631 TIME_WAIT -
tcp 0 0 127.0.0.1:34612 127.0.0.1:631 TIME_WAIT -
tcp 0 0 127.0.0.1:34613 127.0.0.1:631 TIME_WAIT -
tcp 0 0 127.0.0.1:34618 127.0.0.1:631 TIME_WAIT -
tcp 0 0 127.0.0.1:34619 127.0.0.1:631 TIME_WAIT -
tcp 0 0 127.0.0.1:34616 127.0.0.1:631 TIME_WAIT -
tcp 0 0 127.0.0.1:34617 127.0.0.1:631 TIME_WAIT -
tcp 0 0 127.0.0.1:34622 127.0.0.1:631 TIME_WAIT -
tcp 0 0 127.0.0.1:34620 127.0.0.1:631 TIME_WAIT -
tcp 0 0 127.0.0.1:34621 127.0.0.1:631 TIME_WAIT -
udp 0 0 0.0.0.0:32768 0.0.0.0:* 3394/rpc.statd

-----------------------------------------------------------------------------------------------------------------------
[root@ASUSA7V266-E root]# find /etc/ -name "vstfpd.*"
[root@ASUSA7V266-E root]#
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FTP Server Up and running... how do I hide ftp users from local login screen? joe1031 Mandriva 2 03-18-2005 04:24 PM
FTP won't login ne21 Slackware 1 12-10-2004 05:48 AM
suddenly having ftp login problems since i downgraded libsafe so i could add sites Amaris4GOW Linux - General 2 04-09-2004 01:07 PM
ftp login only tuxguy Linux - General 3 03-19-2004 09:37 PM
ftp login -- ssh no login waffe Linux - General 4 12-27-2003 12:42 AM


All times are GMT -5. The time now is 07:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration