LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 02-15-2012, 02:51 AM   #1
dannynjust
LQ Newbie
 
Registered: Jan 2012
Posts: 2

Rep: Reputation: Disabled
ftp command hangs with:227 Entering Passive Mode (10,119,98,125,4,12).


i just install vaftpd on a AWS instance,below is my config, and i also opened the port 21 20 1024-1048, when i connect with filezilla, everything is fine, but when i am using the ftp command , it just hangs after the dir command with:227 Entering Passive Mode (10,119,98,125,4,12).
pasv_enable=YES
pasv_min_port=1024
pasv_max_port=1048
port_enable=YES
pasv_address=10.119.98.125


Edit: i do get an message when using fielzilla :
Quote:
Server sent passive reply with unroutable address. Using server address instead.

Last edited by dannynjust; 02-15-2012 at 03:44 AM.
 
Old 02-15-2012, 04:32 AM   #2
lithos
Senior Member
 
Registered: Jan 2010
Location: SI : 45.9531, 15.4894
Distribution: CentOS, OpenNA/Trustix, testing desktop openSuse 12.1 /Cinnamon/KDE4.8
Posts: 1,144

Rep: Reputation: 217Reputation: 217Reputation: 217
Quote:
Originally Posted by dannynjust View Post

... and i also opened the port 21 20 1024-1048 ...

Entering Passive Mode (10,119,98,125,4,12)


# pasv_address=10.119.98.125
This is fine, as your pasv port is designated to 10.119.98.125 port 1036 (...4,12 = 4x256 + 12)

Try to # comment the marked line to disable it in vsftpd (the Address will be taken from vsftpd running daemon)
and try to temporarily disable the firewall when you're testing the connection, to see if it's hanging because of it.

Last edited by lithos; 02-15-2012 at 04:36 AM.
 
Old 02-15-2012, 10:06 AM   #3
MCD555
Member
 
Registered: May 2009
Location: Milan, Italy
Distribution: Ubuntu, Debian, Fedora, Oracle Linux
Posts: 106

Rep: Reputation: 9
Also, are you pointing the 10.119.95.125 also for data connection (i.e. that is the server IP you are pointing to)?
You could also try, from command line, to use the EPSV command instead of PASV (the server just give you the port to use to set up the data connection).

Last, did you also try the connection directly from the server (loopback)?

Hope this helps!
 
  


Reply

Tags
vsftpd


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ProFTPD hangs on "227 Entering Passive Mode" VirusHater Linux - Newbie 4 06-30-2010 06:26 PM
FTP hangs after displaying message: 229 Extended Passive mode OK (|||30029|) texasboy96 Linux - Networking 1 01-03-2010 11:52 AM
Vsftpd Entering passive mode pramka Suse/Novell 1 07-18-2008 08:20 PM
227 Entering Passive Mode mxtinker Linux - Networking 1 02-25-2004 09:58 AM
ftp connection problem. It hangs on "entering passive mode" lynchmob09 Linux - Newbie 3 10-31-2003 12:09 PM


All times are GMT -5. The time now is 09:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration