LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 08-30-2005, 07:02 AM   #1
sohmc
Member
 
Registered: Aug 2002
Location: Alexandria
Distribution: ubuntu 12.04.2
Posts: 217

Rep: Reputation: 30
fstab-sync conflicts with autofs?


related to my previous thread, i've made some progress in narrowing down the problem.

It seems that fstab-sync attempts to create a directory within /media/, which is an automount directory. This is confusing to me since it seems that the HAL should only be reporting hardware that is added. I've attempted to freeze /etc/fstab a la man fstab-sync

It didn't work.

when I turn autofs off, fstab-sync actually creates a directory in /media named KODAK when I insert a SD card into the drive:
Code:
Aug 30 07:01:23 bart kernel: SCSI device sdc: 125440 512-byte hdwr sectors (64 MB)
Aug 30 07:01:23 bart kernel: sdc: Write Protect is off
Aug 30 07:01:23 bart kernel: sdc: assuming drive cache: write through
Aug 30 07:01:23 bart kernel: SCSI device sdc: 125440 512-byte hdwr sectors (64 MB)
Aug 30 07:01:23 bart kernel: sdc: Write Protect is off
Aug 30 07:01:23 bart kernel: sdc: assuming drive cache: write through
Aug 30 07:01:23 bart kernel:  sdc: sdc1
Aug 30 07:01:23 bart fstab-sync[28094]: added mount point /media/KODAK for /dev/sdc1
My question is, should this be happening at all? Everything I've read about automount says that the directories are created via autofs, not fstab-sync. It seems that fstab-sync is not required for automount.

Any thoughts?
 
Old 08-31-2005, 04:51 PM   #2
AdaHacker
Member
 
Registered: Oct 2001
Location: Brockport, NY
Distribution: Kubuntu
Posts: 384

Rep: Reputation: 31
Automount and autofs are completely unrelated to fstab-sync. It sounds like your problem is just that your automount configuration is attempting to use /media, which is the same directory used by fstab-sync. I'm not sure how to turn off fstab-sync, but the easy solution would be to simply use a different directory for automount, e.g. /var/autofs/media or /auto or something.
 
Old 09-03-2005, 08:16 AM   #3
sohmc
Member
 
Registered: Aug 2002
Location: Alexandria
Distribution: ubuntu 12.04.2
Posts: 217

Original Poster
Rep: Reputation: 30
sorry for the delayed reply. I hadn't gotten a chance to work on it until now.

So I changed the mount point for autofs from /media to /mnt/media in auto.master.

I restarted autofs.

It still doesn't work. autofs makes the appropriate directories on the new mount mount points, and fstab-sync continues to create the the /media/KODAK mount point.

Here's what I get in /var/log/messages:
Code:
Sep  3 08:12:03 bart kernel: SCSI device sdc: 125440 512-byte hdwr sectors (64 MB)
Sep  3 08:12:03 bart kernel: sdc: Write Protect is off
Sep  3 08:12:03 bart kernel: sdc: assuming drive cache: write through
Sep  3 08:12:03 bart kernel: SCSI device sdc: 125440 512-byte hdwr sectors (64 MB)
Sep  3 08:12:03 bart kernel: sdc: Write Protect is off
Sep  3 08:12:03 bart kernel: sdc: assuming drive cache: write through
Sep  3 08:12:03 bart kernel:  sdc: sdc1
Sep  3 08:12:04 bart fstab-sync[7740]: added mount point /media/KODAK1 for /dev/sdc1
Does it matter that I have autofs4 module running?
 
Old 09-03-2005, 08:43 AM   #4
AdaHacker
Member
 
Registered: Oct 2001
Location: Brockport, NY
Distribution: Kubuntu
Posts: 384

Rep: Reputation: 31
Yes, that's exactly what is supposed to happen. Autofs and fstab-sync both do their thing regardless of what the other is doing. I guess I don't understand what you're looking for.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Troubles disabling autofs / What keeps editing /etc/fstab?? powermonkey Fedora 0 04-30-2005 01:32 PM
Using fstab-sync ?? mickeyboa Fedora 0 12-05-2004 09:17 AM
how to mount fstab vs autofs rrich100 Red Hat 1 11-14-2003 12:46 AM
nfs mount with fstab vs autofs rrich100 Linux - Networking 2 11-13-2003 11:21 PM
Mounting NFS filesystem fstab vs autofs rrich100 Linux - Networking 0 11-13-2003 02:38 PM


All times are GMT -5. The time now is 10:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration