LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-23-2005, 03:19 AM   #1
sdave1284
LQ Newbie
 
Registered: Feb 2004
Posts: 9

Rep: Reputation: 0
Force sendmail to send mail on a certain ip address


I have been using sendmail for our mail server for quite some time. When the server sends email, it sends it from the base ip address for eth1. I want the mail server to send on a virtual interface ip address. How do I configure sendmail to do this?

Last edited by sdave1284; 11-23-2005 at 03:20 AM.
 
Old 11-23-2005, 12:11 PM   #2
Finlay
Senior Member
 
Registered: Mar 2003
Location: Seattle
Distribution: Slackware ?-14.1
Posts: 1,029

Rep: Reputation: 47
what distro you using?
 
Old 11-23-2005, 12:17 PM   #3
Finlay
Senior Member
 
Registered: Mar 2003
Location: Seattle
Distribution: Slackware ?-14.1
Posts: 1,029

Rep: Reputation: 47
you will need to find the sendmail.mc file that was used to configure sendmail to begin with.
then you edit it to have:
DAEMON_OPTIONS(`Port=smtp,Addr=xxx.xxx.xxx.xxx, Name=MTA')
DAEMON_OPTIONS(`Port=smtps,Addr=xxx.xxx.xxx.xxx, Name=MSA-SSL, M=E')

the smtps is if you are using sasl or some other kind of secure connection
after it is edited then you need to create the sendmail.cf file, copy it over the current one, for slackware that is in /etc/mail

then restart sendmail
make sure you have the virtual IPs set to be created in a script that runs before sendmail starts, otherwise sendmail will fail because the IP doesn't exist
 
Old 11-23-2005, 02:03 PM   #4
sdave1284
LQ Newbie
 
Registered: Feb 2004
Posts: 9

Original Poster
Rep: Reputation: 0
I added that to the configuration. Now it only allows mail clients to use that ip address for their outgoing mail server, but header information in emails I send still show up as coming from eth1's main ip address and not the virtual ip address I put in the daemon options. Any other ideas to force it to send the emails via eth1:0 instead?

BTW, i'm using Sendmail 8.13.1/8.13.1 and Slackware 10.0

Last edited by sdave1284; 11-23-2005 at 02:08 PM.
 
Old 11-23-2005, 02:32 PM   #5
Finlay
Senior Member
 
Registered: Mar 2003
Location: Seattle
Distribution: Slackware ?-14.1
Posts: 1,029

Rep: Reputation: 47
good question, i just noticed my server is doing the same thing.
i will have to research this, and if anyone has the answer...

i tried adding:
define(`confDOMAIN_NAME', `mail.mydomain.tld')dnl
and recompiling the sendmail.cf but no change
 
Old 11-23-2005, 02:44 PM   #6
sdave1284
LQ Newbie
 
Registered: Feb 2004
Posts: 9

Original Poster
Rep: Reputation: 0
Yeah I did the same. No change too. Its very frustrating. There are no answer to this online. I guess the only solution is to make the IP address of the mail server the main ip for eth1 and make the other address the virtual address. I just didnt want to do this because our T3 provider wants our server (router) to have that main address setup on eth1. Ahh frustrating.
 
Old 11-23-2005, 05:17 PM   #7
Finlay
Senior Member
 
Registered: Mar 2003
Location: Seattle
Distribution: Slackware ?-14.1
Posts: 1,029

Rep: Reputation: 47
i'm going to post this issue in the networking section, maybe someone has a fix
 
Old 11-23-2005, 05:27 PM   #8
Finlay
Senior Member
 
Registered: Mar 2003
Location: Seattle
Distribution: Slackware ?-14.1
Posts: 1,029

Rep: Reputation: 47
Here is what i posted:
http://www.linuxquestions.org/questi...hreadid=385941
 
Old 11-23-2005, 11:26 PM   #9
sdave1284
LQ Newbie
 
Registered: Feb 2004
Posts: 9

Original Poster
Rep: Reputation: 0
Wow your post has so much more info than mine. Thanks for helping.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Send root mail to email address GUIPenguin Linux - General 1 03-01-2005 07:16 PM
send mail to external email address hamish Linux - Networking 8 12-10-2004 09:17 AM
Can't send mail with Sendmail familyman Linux - Software 3 09-15-2004 10:30 AM
Send mail listening address? bradyc Linux - Newbie 4 02-06-2004 08:49 AM
security breach: send mail to unknown address? graffitici Linux - Security 4 01-29-2004 05:27 PM


All times are GMT -5. The time now is 08:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration