LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-28-2006, 07:39 AM   #1
humbletech99
Member
 
Registered: Jun 2005
Posts: 374

Rep: Reputation: 30
Fluxbox windows don't go the left edge of the screen


I'm running fluxbox and would like to change the fact that windows don't go the the left edge of the screen when maximized. They are several pixels off, but I can move any window over those pixels manually, it's just the next time I maximum the window, it goes back to the same offset of several pixels away from the left edge of the screen. The top, right and bottom of the screen are all filled to the edges of the screen.

The machine is a laptop (tft screen), the fluxbox version is fluxbox-0.9.14-r. This left offset happens with all windows equally. The desktop background which is set via fbsetbg does goes to all corners of the screen and the area to the left has the background applied to it. The pixels on the left side of the screen do work, it's just that there is a strip of perhaps 10 pixels running the entire length of the left screen border that is unused by maximized windows. If the windows are not maximized then they can use it normally by being dragged or enlarged manually over it.

Has anybody else noticed this?

Perhaps there is some configuration option or something that is telling it offset the left edge of the window by x pixels?
 
Old 05-28-2006, 08:48 AM   #2
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,790
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
I'm going to bet that you have the slit set up to be on the left side of the screen and by default, apps don't maximize over the slit. In the menu, go to Fluxbox Menu>Configure>Slit and select Maximize Over. Hopefully that will take care of the problem.
 
Old 05-28-2006, 02:26 PM   #3
humbletech99
Member
 
Registered: Jun 2005
Posts: 374

Original Poster
Rep: Reputation: 30
yeah this was it exactly. Shame I can't Maximize Over though cos it causes the window to go underneath the taskbar and then I can't click on the desktop to get the fluxbox menu. But at least I know what the problem is and can work around it, moving the slit to top center stops this behaviour so Maximize Over is not needed and I still get a little desktop space by the taskbar to use.

Last edited by humbletech99; 05-28-2006 at 02:28 PM.
 
Old 05-28-2006, 02:39 PM   #4
robbbert
Member
 
Registered: Oct 2005
Location: Hannover, Germany
Distribution: Let there be Ubuntu... :o)
Posts: 573

Rep: Reputation: 32
OT: Wow, that's what technical questions should be like!
Compliment
 
Old 05-29-2006, 07:05 AM   #5
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,790
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
Originally Posted by humbletech99
yeah this was it exactly. Shame I can't Maximize Over though cos it causes the window to go underneath the taskbar and then I can't click on the desktop to get the fluxbox menu. But at least I know what the problem is and can work around it, moving the slit to top center stops this behaviour so Maximize Over is not needed and I still get a little desktop space by the taskbar to use.
If you turn off Full Maximization (Fluxbox Menu > configure > Full Maximization) that should keep the apps from maximizing behind the taskbar and give you a little space on either side of the taskbar to pull up the menu. And don't forget that you can always move to a new desktop with Alt-F1 through Alt-F4, even if you have apps maximized.
 
Old 05-29-2006, 07:26 AM   #6
humbletech99
Member
 
Registered: Jun 2005
Posts: 374

Original Poster
Rep: Reputation: 30
yes this is what I did, and I found that not having the slit on the corner stopped it from having that space down the left side of the screen, so it's at the top center and all is well, it jsut won't look as nice if I start opening dockapps which I don't do that much since they'll start in the top center of the screen.
 
Old 05-29-2006, 07:48 AM   #7
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,790
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
I may not have been entirely clear so just to be sure, I'll toss this out a slightly different way....

There are two configuration settings that I've suggested looking at:

1)fluxbox menu > configuration > Slit > Maximize Over
2)fluxbox menu > configuration > Full Maximization

#1 controls whether or not the slit is covered when you maximize.
#2 controls whether or not the task bar is covered when you maximize.

On my system I've got #1 enabled, but #2 disabled so when I maximize, the slit is covered but the taskbar (and a strip of desktop on either side) is not covered and I can pull up the menu from there.
 
Old 05-29-2006, 07:57 AM   #8
humbletech99
Member
 
Registered: Jun 2005
Posts: 374

Original Poster
Rep: Reputation: 30
oh, thanks a lot, yes I was only looking at the second, the first the the proper solution to this question.

thanks again.
 
Old 12-17-2006, 12:51 AM   #9
twelvenine
Member
 
Registered: Sep 2006
Posts: 72

Rep: Reputation: 16
i have the same problem and i'm sure it's caused by the slit, but i don't have a "full maximization" option in fluxbox menu>configure>slit. setting the slit to a lower layer doesn't do anything, changing it's placement just makes it so the window doesn't maximize correctly on the side that i move the slit to. anybody know why i don't have this option? i'm using fluxbox rc1.0rc2.
 
Old 12-17-2006, 05:55 AM   #10
humbletech99
Member
 
Registered: Jun 2005
Posts: 374

Original Poster
Rep: Reputation: 30
i'm using 1.0rc2 and the option you want is "fluxbox menu -> Configure -> Slit -> Maximize Over" which exists for me and is selected and works.
 
Old 12-17-2006, 10:32 PM   #11
twelvenine
Member
 
Registered: Sep 2006
Posts: 72

Rep: Reputation: 16
yeah, but it's not there for some reason. check it out: http://img524.imageshack.us/img524/2592/badslit1fi5.jpg
 
Old 12-19-2006, 01:35 AM   #12
twelvenine
Member
 
Registered: Sep 2006
Posts: 72

Rep: Reputation: 16
is it there and i'm just missing it somehow? is there a way to add that option to my menu if it's not there? bump
 
Old 12-19-2006, 06:47 AM   #13
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,790
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
I'm wondering if something is goofy about your overall fluxbox install. As far as I know (and I may very well be wrong) the whole fluxbox configure menu should be the same and the fact that your's isn't suggests a bad compile. How did you install fluxbox?
 
Old 12-19-2006, 07:14 AM   #14
humbletech99
Member
 
Registered: Jun 2005
Posts: 374

Original Poster
Rep: Reputation: 30
either that or you're using a custom menu which doesn't have it.

have you tried running
Code:
fluxbox-generate_menu
this will regenerate the menu, then you can try again.

The whole menu section is given by the following so I'm not sure how to rewrite that
Code:
[config] (Configure)
It's possible that either your flux was funnily compiled or whatever the above pulls is somehow broken.

What distro are you using, perhaps you can reinstall the package?

Last edited by humbletech99; 12-19-2006 at 07:17 AM.
 
Old 12-19-2006, 06:39 PM   #15
twelvenine
Member
 
Registered: Sep 2006
Posts: 72

Rep: Reputation: 16
well, i'm running fluxbox and i originally had .913 or something but then i went out to the fluxbox site and downloaded the 1.0rc2 tgz package and upgraded using installpkg.

doing fluxbox-generate_menu does create a new menu file for me, but 'maximize over' still isn't there in the slit section.

i guess i could try uninstalling and reinstalling fluxbox.

Last edited by twelvenine; 12-19-2006 at 06:42 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
What does the left button in a fluxbox winow do? ntubski Linux - General 2 12-06-2005 04:04 PM
xfce: Howto popup autohided windows when on screen edge? andreas.jonsson Linux - Software 1 10-20-2005 02:50 PM
Fluxbox slit positioning problem: always in top left beefsprocket Linux - Software 4 09-27-2004 10:35 AM
Fluxbox and left handed mouse. asklepios Linux - General 4 02-14-2004 02:55 AM
Part of desktop not there, hanging off edge of screen. Guru3 Linux - General 1 01-03-2004 11:24 AM


All times are GMT -5. The time now is 12:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration