LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-13-2003, 07:09 AM   #1
moneyshotz
Member
 
Registered: Jun 2003
Posts: 75

Rep: Reputation: 15
Unhappy fluxbox startup


Hi guys,
I've been trying to get a few programs to startup with fluxbox.
I was reading that you had to create on of these files:
.xsession
.xinitrc
I've tried both of them and none of the programs still load up at startup. I also changed the permissions to make it executabe.
This is what's inside...
/usr/bin/gotmail &
/usr/bin/evolution &
/usr/bin/gaim &

What exactly am I doing wrong?
 
Old 07-13-2003, 07:32 AM   #2
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
Try ~/.fluxbox/startup
 
Old 07-13-2003, 02:03 PM   #3
moneyshotz
Member
 
Registered: Jun 2003
Posts: 75

Original Poster
Rep: Reputation: 15
So I just create a file ~/.fluxbox/startup ?
I've tried that also but it still doesnt work. I made it executable too. Anyone else got any ideas?

Last edited by moneyshotz; 07-13-2003 at 02:18 PM.
 
Old 07-13-2003, 02:27 PM   #4
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
You should already have ~/.fluxbox/startup. The syntax is slightly different. Mine reads:
Quote:
# fluxbox startup-script:
#
# Lines starting with a `#' are ignored.

# You can set your favourite wallpaper here if you don't want
# to do it from your style.
#
# bsetbg -f ~/pictures/wallpaper.png
#
# This sets a black background

bsetbg -solid black


# Other examples. Check man xset for details.
#
# Turn off beeps:
# xset -b
#
# Increase the keyboard repeat-rate:
# xset r rate 195 35
#
# Your own fonts-dir:
# xset +fp $HOME/.font
#
# Your favourite mouse cursor:
# xsetroot -cursor_name right_ptr


# Applications you want to run with fluxbox.
# MAKE SURE THAT APPS THAT KEEP RUNNING HAVE AN ``&'' AT THE END.
#
# unclutter -idle 2 &
# wmnd &
# wmsmixer -w &
# idesk &
gkrellm &
klipper &

# And last but not least we start fluxbox.
# Because it is the last app you have to run it with ``exec'' before it.

exec fluxbox -log .fluxbox/log
#exec fluxbox
 
Old 07-13-2003, 02:35 PM   #5
moneyshotz
Member
 
Registered: Jun 2003
Posts: 75

Original Poster
Rep: Reputation: 15
I do not have a ~/.fluxbox/startup so I just created it. I'm running version 0.7.14 on a debian system, not sure if that makes a difference though.
 
Old 07-13-2003, 03:14 PM   #6
dav1x
Member
 
Registered: Sep 2002
Posts: 50

Rep: Reputation: 15
Did you try adding the file or script to /etc/X11/xinit/xinitrc.d?

for example I added.. for my xscreensaver daemon a file called screensaver that runs

#!/bin/sh
xscreensaver -nos &

Mine works fine.
the startup file with fluxbox (~.fluxbox/startup) will ONLY work if you have the remember patch installed..

Which if you rolled the source off of fluxbox for is NOT installed be default in 0.1.14

Good Luck
 
Old 07-13-2003, 03:21 PM   #7
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
Sorry, I've been using the development releases of Fluxbox which have had the Remember feature nestled in the code for some time now.
It's getting very good
 
Old 07-13-2003, 03:28 PM   #8
dav1x
Member
 
Registered: Sep 2002
Posts: 50

Rep: Reputation: 15
='(

See what happens when you dont keep up...

*sniff*

Any other big changes? I adore fluxbox, unfortunately I havent been by their site in ages...
 
Old 07-13-2003, 03:30 PM   #9
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
Pixmap themes kick ass. Blueflux looks sweet, so I think I'll work on my own. I love the Axios one for Enlightenment, so I may port it.
Check the link in my sig to see the additions for each 0.9.x release, and to get 0.9.4
 
Old 07-13-2003, 03:37 PM   #10
moneyshotz
Member
 
Registered: Jun 2003
Posts: 75

Original Poster
Rep: Reputation: 15
Dav1x: I've tried that also and it still doesn't seem like it wants to boot up. I've entered the same values that I had entered in the files I mentioned above.

btw, I'm not trying to log into fluxbox through the console by typing 'startx'
The gnome manger pops up and I just select fluxbox and just enter my log in information. Does that make a difference?
 
Old 07-13-2003, 03:41 PM   #11
dav1x
Member
 
Registered: Sep 2002
Posts: 50

Rep: Reputation: 15
go ahead and do a
# fluxbox -version

runlevel 3 will allow you to modify the /home/$user/.xinitrc to start up applications when you type startx

the path i gave you allows applications to start up in a run level 5 environment with like gdm as you described...

I can walk you through compiling the remember patch if need be... A good indication if you have it installed, is to right click on a box open in flux, and remember should be an option...
 
Old 07-13-2003, 03:46 PM   #12
moneyshotz
Member
 
Registered: Jun 2003
Posts: 75

Original Poster
Rep: Reputation: 15
Ok. I have version 0.1.14
So that path you originally gave me should allow me to run level 5 environments? I wonder why its not working. I dont think I have a patch installed. Can you help me out?
 
Old 07-13-2003, 03:50 PM   #13
XPediTioN
Member
 
Registered: Jun 2003
Location: Illinois
Distribution: Slackware 9.1
Posts: 305

Rep: Reputation: 30
How do I get and install FluxBox?
 
Old 07-13-2003, 03:52 PM   #14
moneyshotz
Member
 
Registered: Jun 2003
Posts: 75

Original Poster
Rep: Reputation: 15
i downloaded the debian package and just installed it that way, with the dpkg -i file.deb
 
Old 07-13-2003, 03:54 PM   #15
moneyshotz
Member
 
Registered: Jun 2003
Posts: 75

Original Poster
Rep: Reputation: 15
by the way i didnt have a xinitrc.d, I had to create it. I did have a 'xinitrc' tho
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
numlock on fluxbox startup alamuru420123 Linux - General 17 04-22-2005 07:54 AM
fluxbox programs as startup jojack Linux - Software 6 01-03-2005 10:28 PM
fluxbox startup sound ! Paxmaster Slackware 3 12-11-2004 07:46 PM
Daemons upon Fluxbox Startup Chu Linux - Newbie 3 03-17-2004 04:28 PM
Eterm startup in Fluxbox BroX Slackware 1 03-05-2004 09:53 AM


All times are GMT -5. The time now is 11:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration