LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-26-2003, 11:34 PM   #1
lasalsademuerte
Member
 
Registered: Jan 2003
Distribution: Slackware 9.1
Posts: 54

Rep: Reputation: 15
fluxbox help


I've installed fluxbox and I can run it fine if I set inittab to reunlevel 3, login and type xinit and then type fluxbox in the xterm. However I would like to have it added to the sessions menu at the login gui in redhat 9, I tried creating a fluxbox file containing exec /usr/local/bin/fluxbox in the /etc/X11/gdm/Sessions/ directory and this allowed me to select fluxbox in the sessions options but when fluxbox loaded I got a messege saying that I had been logged in for less than 10 second(that may not be exactly it but that was about what it said) and that it may be a result of a lack of disk space. However since I can load fluxbox from text this is obviously a bogus error message. Does anyone have any idea what I may be doing wrong. Also is there anyway that after I load fluxbox I can clse the xterm without exiting out of fluxbox? thanks for any help you can give me.
 
Old 10-27-2003, 12:24 AM   #2
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
This isn't directed at you especially, in that lots of people do it - just a broadcast message:

This is not a fluxbox problem!

People would probably get better and faster help if they'd correctly identify the issue. Flux may be what prompts awareness of the problem, but you need 'gdm help'.

Now, I don't know anything about gdm or redhat - I clicked on your thread because it said 'fluxbox'. If you can execute from runlevel 3 like that, though, you should be able to create or modify an ~/.xinitrc whose *last* line is 'exec fluxbox' and then do 'startx'. That way flux will be controlling the session rather than the terminal emulator. Then you can close the term without closing the session.

xterm &
exec fluxbox

See if you have an xinitrc anywhere on the system you can copy and modify if you don't already have the dotfile in your home directory. And I hear there's a thing called 'switchdesk' on RH - some people seem to have trouble - for some people it works. I don't know. As far as adding to a graphical login prompt, though, I really don't know - completely forgotten those, though I did use one on my first install and had to disable one on Debian not long ago.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fluxbox: Enabling KDE using package install of fluxbox underline Linux - Software 0 12-27-2003 11:11 AM
fluxbox??? yenonn Linux - Newbie 3 10-02-2003 11:33 AM
FLuxbox help please!!! Devboy Linux - Newbie 9 07-31-2003 09:02 PM
Fluxbox alitrix Linux - Software 1 06-29-2003 01:36 PM
Fluxbox Astro44 Linux - Newbie 4 04-09-2003 05:48 PM


All times are GMT -5. The time now is 03:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration