LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 03-17-2004, 10:23 AM   #1
rgriffin
LQ Newbie
 
Registered: Oct 2003
Posts: 19

Rep: Reputation: 0
Fluxbox background problem


I've got a fresh install of Fedora Core1 which I updated with YUM. Everything went fine and so I then did a yum install of fluxbox. Installed fine but I'm unable to use the fbsetbg command to change my background in fluxbox. It's the 0.9.8 version which I've used before without a problem. No commands will change the background and I'm confursed because I've had this exact same setup before and it worked perfectly. I'm no Linux expert by any means and this is got me stumped. Other than the background not changing things work perfectly. Any help would be appreciated.
 
Old 03-17-2004, 10:29 AM   #2
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 54
Are you logged in as root? Fluxbox by default prevents you running certain commands as root.
 
Old 03-17-2004, 10:34 AM   #3
rgriffin
LQ Newbie
 
Registered: Oct 2003
Posts: 19

Original Poster
Rep: Reputation: 0
I've tried it as root and as user and the commands just won't work. I'm quite the newbie at Linux and so when I get a system issue I can't fix I usually just do a complete reinstall and try again. I'm getting tired of doing that and want to buckle down and learn how to fix things an easier way......
 
Old 03-17-2004, 11:24 AM   #4
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 54
The command is bsetbg, not fbsetbg, it uses the blackbox background set script.
Run bsetbg and it'll configure some stuff (it'll see what display tools you have, e.g. xv, display...) then you can either edit your .fluxbox/init file and change the line rootcommand to use bsetbg or you can use it manually.
 
Old 03-17-2004, 04:17 PM   #5
rgriffin
LQ Newbie
 
Registered: Oct 2003
Posts: 19

Original Poster
Rep: Reputation: 0
Nope....the command does nothing for me.....
 
Old 03-17-2004, 06:26 PM   #6
mikshaw
LQ Addict
 
Registered: Dec 2003
Location: Maine, USA
Distribution: Slackware/SuSE/DSL
Posts: 1,320

Rep: Reputation: 45
You need to have something installed that will set the background. fbsetbg is merely a wrapper, and won't work unless you have something like bsetroot or bsetbg or Esetroot.
 
Old 03-17-2004, 06:50 PM   #7
Genesee
Member
 
Registered: Dec 2002
Distribution: Slackware
Posts: 927

Rep: Reputation: 30
did you try wmsetbg ?

(I'm going from memory here... but I seem to remember having the same prob. at some point )

here's a good reference that may help:

http://reviewed.homelinux.org/man/fluxbox/
 
Old 03-21-2004, 12:53 AM   #8
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Re: Fluxbox background problem

Quote:
Originally posted by rgriffin
I've got a fresh install of Fedora Core1 which I updated with YUM. Everything went fine and so I then did a yum install of fluxbox. Installed fine but I'm unable to use the fbsetbg command to change my background in fluxbox. It's the 0.9.8 version which I've used before without a problem. No commands will change the background and I'm confursed because I've had this exact same setup before and it worked perfectly. I'm no Linux expert by any means and this is got me stumped. Other than the background not changing things work perfectly. Any help would be appreciated.
Try this - it works for me:

Just edit the style-file ...
<favourite editor> `grep styleFile ~/.fluxbox/init | cut -f 2`
replace what it has for rootCommand with your line.

For example, this is what I did ->

bash-2.05b# pico /usr/X11R6/share/fluxbox/styles/Spiff
<snip, snip>
rootCommand: bsetbg -f ~/slack1.png

You can use that command ->
bsetbg -f ~/slack1.png
to set a background from wherever your file is located. Mine
is in my home directory. But the background will not be there
is you restart the x-server unless you edit the style file.

Thanks to Tinkster for telling me how to do this! :}
 
Old 03-21-2004, 02:35 AM   #9
Pwnz3r
Member
 
Registered: Jan 2004
Location: Lancaster, OH
Distribution: Gentoo
Posts: 393

Rep: Reputation: 30
Try xsetbg and then the filename. It works for me just fine.
 
Old 03-25-2004, 08:05 AM   #10
ambelos
Member
 
Registered: Nov 2003
Location: npr, fl, usa
Distribution: suse 9.3 / xp pro sp2
Posts: 226

Rep: Reputation: 30
nope, i don't think any of those things is the problem. i had the same exact thing going on. i had to edit the bsetbg config file. it should be in your .flubox folder.

# /home/politisj/.fluxbox/bsetbg
#
# automagically generated with loving care by bsetbg 1.12 on Wed Feb 18 09:59:59 EST 2004
#
# uncomment the set below that corresponds to your favorite root-image
# application, or mix and match to suit your pleasure.
#
# xli misbehaves under larger screen resolutions when using the -fillscreen
# option. use -fullscreen if your resolution is higher than 1024x768.
#

### xsri
FULL="xsri --scale-width=100 --scale-height=100"
TILE="xsri --tile"
CENTER="xsri --center-x --center-y"
DEFAULT="xsri --center-x --center-y"

### display
# FULL="display -geometry 1024x768 -window root"
# TILE="display -window root"
# CENTER="display -backdrop -window root"
# DEFAULT="display -backdrop -window root"


display will work too, but for some reason wouldn't work with transparency. so, just use xsri. works fine now. if THIS don't work, THEN try what everyone else is saying.
 
Old 03-25-2004, 08:16 AM   #11
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Re: Fluxbox background problem

Quote:
Originally posted by rgriffin
No commands will change the background and I'm confursed because I've had this exact same setup before and it worked perfectly.
We didn't ask. What commands have you tired?
Where do you stand with this issue now?
 
Old 03-25-2004, 09:14 AM   #12
rgriffin
LQ Newbie
 
Registered: Oct 2003
Posts: 19

Original Poster
Rep: Reputation: 0
I reinstalled fluxbox with the fedora RPM and fbsetbg works....but it still stumps me because it was working perfectly when I installed it with the source file....go figger
 
Old 03-25-2004, 10:20 AM   #13
ambelos
Member
 
Registered: Nov 2003
Location: npr, fl, usa
Distribution: suse 9.3 / xp pro sp2
Posts: 226

Rep: Reputation: 30
this must be one of those super odd cases where the rpm works better than compileing from source.

acctualy, i just remembered. fbsetbg is a small package specificly for flux, ithink, and isn't included if u compile from source. they may have added it to the rpm package, so, that just might be the reason.
 
Old 03-25-2004, 04:22 PM   #14
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Quote:
Originally posted by ambelos
this must be one of those super odd cases where the rpm works better than compileing from source.
That would be one for "Ripley's Believe It or Not" -- I'd choose not.
 
Old 03-25-2004, 05:28 PM   #15
Pwnz3r
Member
 
Registered: Jan 2004
Location: Lancaster, OH
Distribution: Gentoo
Posts: 393

Rep: Reputation: 30
It's too doubtful... just way too doubtful. lol
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fluxbox background is always brown DAChristen29 Linux - Software 2 12-12-2005 11:54 PM
Fluxbox Background Problems tavilach Linux - General 3 07-05-2004 06:43 PM
fluxbox background ambelos Linux - Software 16 02-26-2004 02:11 AM
fluxbox background again! nxny Linux - Software 2 08-12-2002 02:19 PM
fluxbox background yaker Linux - General 3 03-31-2002 05:11 PM


All times are GMT -5. The time now is 04:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration