LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   fluxbox background (http://www.linuxquestions.org/questions/linux-software-2/fluxbox-background-149797/)

ambelos 02-23-2004 11:29 PM

fluxbox background
 
i don't want anyone thinking i'm double posting, cause, i didn't post about this before, but it was in a thread of a dif subject.

i'm having trouble getting a background image when in fluxbox. i want to have a different image for each dif style. thnx

jay

Sebboh 02-24-2004 12:24 AM

Modify each styles cfg file and add:

rootCommand: fbsetbg -f ~/path/to/pic.jpg

Styles are in ~/.fluxbox/styles if you added any custom ones. If you are trying to mod te ones that came w/ it try as root:

updatedb
locate Cthulhain

Thats just one style name, but it will reveal where they are installed on your system. Mine on the CVS version are in /usr/local/share/fluxbox/styles/.

:)

ambelos 02-24-2004 07:40 AM

but that's the thing. someone once told me to do that. and i did. i put it in several different styles, and neither of them did anything. now, i don't think i mentioned this, but i installed fluxbox from src. i'm using RH8. so, i'm thinking, is there something else, mabe a background manager, or something else that needs to be installed or running when flux is running? i'll try what u told me to try one more time, when i get to school
, and i'll see what happens. thnx

jay

Satriani 02-24-2004 08:04 AM

see what background utility you use in the flux installation directory. (something like bgsetroot, fbsetroot... then type that command with the --help parameter to see how you should format the command.

ambelos 02-24-2004 10:32 AM

hemmmmmmmmmmmmmmmmm....

[politisj@localhost backgrounds]$ bsetbg lambo.jpg

bsetbg: error: tried to run 'wmsetbg -backdrop -window root' for default argument,
bsetbg: but couldnt find 'wmsetbg' in the path! please fix the following
bsetbg: line in /home/politisj/.fluxbox/bsetbg to point to an existing application:
bsetbg: DEFAULT="wmsetbg -backdrop -window root"
[politisj@localhost backgrounds]$ wmsetbg
bash: wmsetbg: command not found
[politisj@localhost backgrounds]$ wmsetbg --help
bash: wmsetbg: command not found
[politisj@localhost backgrounds]$

i ran this at prompt to see what msgs it would give me. so basicly, i am missing wmsetbg? or is this completely irrevelant to what we are doing? thnx

jay

ambelos 02-24-2004 10:46 AM

srry, ignore last post. i was looking trhough my bsetbg file and realized that whole wmsetbg portion was what was entered in by me. i commented it out, and started using the display portion. thnx guys, sorry to bother u like this

jay

ambelos 02-24-2004 09:28 PM

ok...i'm realy confused now. it worked for one of the styles...and put the same exact line in a few other styles, and those didn't work...i'm realy confused. not only that, but with the one that DID work, the transparency in my terms didn't show the background, but instead used the original color of the style i'm using...grrrrrrrrrrrr, this is so fustraing.

i also noticed this. In a style I created from scratch, in info it says, type: application/x-executable

the rest are all type, text/plain

i'm sorry, i just realy don't know what to think of this. i just keep testing things, changing things, and can't seem to manage to make things happen.

Sebboh 02-24-2004 09:37 PM

Ok..

#1. Run 'fbsetbg -i' and paste results. Its just a wrapper that chooses the best app to set the root background that you have installed. It goes down a list looking for the best way it can find. The website linked has info on that.

#2. Your home dir has a .fluxbox folder. Inside is 'init'. This file says where everything you use is such as your 'key' file (storing keybinds), 'menu' file storing your menu, and others are. Whether your using the system versions, or ones in your ~/.fluxbox dir. Make sure in your HOME dir's init that it points to the proper locations your expecting them to. And make sure your changing the right files as well.

ambelos 02-24-2004 11:27 PM

[politisj@localhost politisj]$ fbsetbg -i
bash: fbsetbg: command not found
[politisj@localhost politisj]$ bsetbg -i
bsetbg 1.12 configuration:

bsetroot: /usr/X11R6/bin/bsetroot

reading configuration from: /home/politisj/.fluxbox/bsetbg

configuration values:

fullscreen (FULL): display -geometry 1024x768 -window root

tiled (TILE): display -window root

centered (CENTER): display -backdrop -window root

default (DEFAULT): display -backdrop -window root

summary: looks good
[politisj@localhost politisj]$

i had to change the geometry, cause it was set to 800x600, and it looked tiled instead of fullscreen. but, ofcourse, now it's not displaying anything again.

ambelos 02-25-2004 12:10 AM

aha...i should have paid attention the first time to realise that fbsetbg was a link to more instructions. i will get to that as soon as possible. but right now, i found out why the background command wasn't working....i was entering it at the top of the files....if i would have gone all the way to the bottom, i would have seen the original command for the background color, DUH!!!

so, i guess now i just need to understand why my terms aren't showing my background image when they are transparent, instead of the background color. is there another setting besides bsetbg -f that i need to use? thnx
jay

Sebboh 02-25-2004 12:11 AM

What version are you running? It must be 0.1.14..

Do 'fluxbox -version'..

You can get the newest fluxbox from CVS which includes MANY updates and features. I would also recommend installing feh or chbg. Fbsetbg is a wrapper for these programs and will choose the best one you have installed, and will tell you any probs you may have if you DONT use feh/chbg/etc. If you do this you WILL have success installing flux. So to review:

1. Remove your current install and download the CVS version.

2. Install it (if make fails try ./configure --disable-nls and re-make).

3. Install 'chbg', or 'feh'. These programs will not be directly used. You will use the wrapper program Fbsetbg that is automatically installed when you use the 'dev' CVS version of Fluxbox.

4. Do 'fbsetbg -i' and make sure it shows a valid background setter. Mine, for instance is:

Quote:

calvin@bravo:~$ fbsetbg -i

chbg supports all features but it doesn't report errors. I reported this bug to the chbg developers.
If you use another method such as 'feh', then you will see a statement to that effect.

5. a. Modify ~/.fluxbox/init to make a GLOBAL wallpaper that ignores any style-set backgrounds...

OR

5. b. Modify the style config to make per-style wallpapers.

6. Check the files in "~/.fluxbox" (such as 'init', 'keys', etc) and make sure the paths are right etc.

You do not use 'chbg' or 'feh' directly. And you do not use 'bsetbg' anymore ever. :)

GL!


EDIT: Remember, you should be able to do this at command line, such as:

"fbsetbg -f /backup/wallpapers/roxor.png"

ambelos 02-25-2004 12:28 AM

i have the version u are talking about. but, is it absolutly necessary that i recompile it? is there a way i can upgrade it? i'm just afraid that i'll lose most of my settings. and how about my session manager? will it still allow me to start flux, or will i have to re-edit that too? thnx

jay

Sebboh 02-25-2004 12:33 AM

The problem is where is fbsetbg? You would have it...

fluxbox -version

also..

updatedb
locate fbsetbg

Do those.

ambelos 02-25-2004 07:02 AM

[root@localhost politisj]# fluxbox -version
Fluxbox 0.1.14 : (c) 2001-2002 Henrik Kinnunen

[root@localhost politisj]# updatedb
[root@localhost politisj]# locate fbsetbg
[root@localhost politisj]#


i can install fbsetbg all by itself, right?

Sebboh 02-25-2004 11:07 AM

See? Your NOT runninig the development version. I would do as I instructed and upgrade by the directions. Just dont delete the files in your home dir and you won't lose any data.


All times are GMT -5. The time now is 01:00 PM.