LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-03-2005, 10:42 AM   #1
darkleaf
Senior Member
 
Registered: Jun 2004
Location: the Netherlands
Distribution: debian SID
Posts: 2,170

Rep: Reputation: 45
fluxbox and .xinitrc Eterm, Esetroot at 1280*1024 res


I just switched my resolution up to 1280*1024. I have some trouble with Esetroot and fluxbox now. I used Esetroot -f to set the background. This didn't work anymore so I changed it to Esetroot -s which works correctly from a terminal. However if I change this in the style or in the .xinitrc file the background loads first. After that the taskbar thing loads and it makes the background smaller. So I have some black at the top and some black at the bottom of the screen. The toolbar is in the black part at the bottom. Can I change it so that Esetroot will load this correctly at once.

Also if I put the Esetroot command in my .xinitrc file and I load Eterm (for the transparency) loading the background goes a lot slower and Eterm loads before the background no matter where I put it in the .xinitrc file. So I don't get the transparency. Can anyone help me with a solution to this?
 
Old 03-04-2005, 10:58 PM   #2
Feminista
Member
 
Registered: Sep 2004
Distribution: Gentoo, OS X
Posts: 37

Rep: Reputation: 15
What version of fluxbox? The "release" version (which came with my distro), doesn't handle backgrounds very well, whereas the latest stable developer version fixes a lot of those problems. Also, try setting your background with fbsetbg (if you don't have it, definitely update your fluxbox).

I had a lot of trouble with setting backgrounds until I updated my version of fluxbox, and they all went away (of course, I didn't check dependencies and accidentally killed it first. =P).
 
Old 03-05-2005, 07:07 AM   #3
darkleaf
Senior Member
 
Registered: Jun 2004
Location: the Netherlands
Distribution: debian SID
Posts: 2,170

Original Poster
Rep: Reputation: 45
It's verion 0.9.11. I don't know of if it's a special thing I just use the packages. I have fbsetbg but I think I had to use Esetroot to get the transparency thing that I wanted. That's what's still not working, I can't get a transparent Eterm on the start of X. The background always loads first but if I put Eterm in my .xinitrc it starts Eterm first.
 
Old 03-05-2005, 10:42 AM   #4
95se
Member
 
Registered: Apr 2002
Location: Windsor, ON, CA
Distribution: Ubuntu
Posts: 740

Rep: Reputation: 32
Esetroot ... &
Esetrootpid = $!
wait $Esetrootpid && Eterm &
 
Old 03-05-2005, 11:51 AM   #5
darkleaf
Senior Member
 
Registered: Jun 2004
Location: the Netherlands
Distribution: debian SID
Posts: 2,170

Original Poster
Rep: Reputation: 45
That didn't work 95se . Eterm still loaded before the background did. BTW what does the ! mean in there?

Feminista why would running fbsetbg be different from Esetroot. fbsetbg is a wrapper for those programs, isn't it?

From which files does fluxbox read the background at start? I commented out the Esetroot in my xinitrc, the style file in my home directory and the style file in my systemwide directory, but it still knows which wallpaper to load and so it does.
 
Old 03-05-2005, 11:54 AM   #6
darkleaf
Senior Member
 
Registered: Jun 2004
Location: the Netherlands
Distribution: debian SID
Posts: 2,170

Original Poster
Rep: Reputation: 45
Good thing is your script gave me an idea which was a lot easier and worked. Esetroot && Eterm &

Now I only hope something changes so my background will load properly and fullscreen. Maybe a downgrade will work. Going to try that now

edit: unstable and testing is the same version Oh well maybe playing around will get it to work.

Last edited by darkleaf; 03-05-2005 at 12:20 PM.
 
Old 03-05-2005, 12:57 PM   #7
darkleaf
Senior Member
 
Registered: Jun 2004
Location: the Netherlands
Distribution: debian SID
Posts: 2,170

Original Poster
Rep: Reputation: 45
Is there a file I can edit to run the Esetroot when the .xinitrc file is finished?
 
Old 03-05-2005, 01:12 PM   #8
Hammett
Senior Member
 
Registered: Aug 2003
Location: Barcelona, Catalunya
Distribution: Gentoo
Posts: 1,037

Rep: Reputation: 54
You can try fbsetbg command instead of Esetroot
 
Old 03-05-2005, 03:52 PM   #9
Feminista
Member
 
Registered: Sep 2004
Distribution: Gentoo, OS X
Posts: 37

Rep: Reputation: 15
fluxbox will read your background from rootCommand either in your .fluxbox/init or in the style file for your theme, but in my experience, that location doesn't matter with the specific problem you are having.

Worth a try though. I haven't heard of this problem occuring with 0.9.*, only with the "stable release".
 
Old 03-05-2005, 07:50 PM   #10
95se
Member
 
Registered: Apr 2002
Location: Windsor, ON, CA
Distribution: Ubuntu
Posts: 740

Rep: Reputation: 32
It didn't? The $! gives you the Process ID of the last program put into the background. wait will then wait for the process to finish before it returns. Your solution is a lot easier, lol. Brain fart I guess
 
Old 03-06-2005, 06:43 AM   #11
darkleaf
Senior Member
 
Registered: Jun 2004
Location: the Netherlands
Distribution: debian SID
Posts: 2,170

Original Poster
Rep: Reputation: 45
I have compiled version 0.9.12 and it still has the problem. The only thing that works is setting my resolution at 1024*768 but that's not something I want to do. The strange thing is that it doesn't set the background right when it starts fluxbox but it does work when I manually run the command afterwards.
 
Old 03-06-2005, 06:55 AM   #12
darkleaf
Senior Member
 
Registered: Jun 2004
Location: the Netherlands
Distribution: debian SID
Posts: 2,170

Original Poster
Rep: Reputation: 45
I fixed it. The behaviour comes from "Esetroot -f" that won't fill up the complete background at this resolution for me (maybe the picture has the wrong dimensions or something). "Esetroot -s" does work. The problem was that I mixed two styles. My background picture makes me think about the name of the style I don't use so I was changing Esetroot -f to Esetroot -s in the wronf style files

Thanks for the help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Esetroot (Eterm) error - starting Eterm in transparent mode? nimcha Linux - Software 2 07-14-2007 06:58 AM
suse 10 and lcd 1280*1024@60Hz jamlc Linux - Hardware 2 11-15-2005 10:26 AM
KDE allows 1280 and 1024, but not 1152 Seiken Linux - Newbie 11 09-29-2004 09:25 AM
Esetroot, Eterm, and other library issues libranikki Fedora 1 07-06-2004 07:31 AM


All times are GMT -5. The time now is 10:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration