LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 02-01-2006, 09:26 AM   #1
TruongAn
Member
 
Registered: Dec 2004
Location: Vietnam (Việt Nam)
Distribution: Gentoo (desktop), Arch linux (laptop)
Posts: 725

Rep: Reputation: 33
Flood of trouble rise while solving anjuta 2.0.1 's dependency.


Hello everyone

Recently, I have tried to install anjuta IDE.
I choose to install the latest version 2.0.1
But I was fed by trouble, why try to do so.
Firstly, I install anjuta using source code, since I don't found any rpm for FC4.
The configure said that it required gdl.
So, I download gdl
When I install gdl, rpm said that in require 3 more packages.
Being tired, I use
Code:
yum install gdl
Then, 4 package was install to my PC.
When plplot (one of gdl dependency) was being installed, the console said:
Code:
/sbin/ldconfig: /usr/lib/libwx_base-2.6.so.0 is not a symbolic link

/sbin/ldconfig: /usr/lib/libwx_gtk2_media-2.6.so.0 is not a symbolic link

/sbin/ldconfig: /usr/lib/libwx_gtk2_adv-2.6.so.0 is not a symbolic link

/sbin/ldconfig: /usr/lib/libwx_base_net-2.6.so.0 is not a symbolic link

/sbin/ldconfig: /usr/lib/libwx_gtk2_html-2.6.so.0 is not a symbolic link

/sbin/ldconfig: /usr/lib/libwx_base_xml-2.6.so.0 is not a symbolic link

/sbin/ldconfig: /usr/lib/libwx_gtk2_core-2.6.so.0 is not a symbolic link
I have no idea, however, it is no an error, moreover, those was not a symbolic link, it was a file, I think it is not a problem, I ignored it.


When I came back to compile anjuta, It still said that I don't have gdl (rpm had finished install it).
It suggest me adding the file gdl-1.0.pc 's path to one of its environments variable.

What the hell is it.
I don't have the file gdl-1.0.pc on my disk, and the latest version of gdl is 0.8.11, what does anjuta want.


On the last effort, I download gdl0.8.11 source code.
I hope that the soucre installion will provide me a .pc file. And the result went against me. gdl source code require plplot (which was installed via rpm).


My god, I am at the end of my tether now, Please help me out

Last edited by TruongAn; 02-01-2006 at 09:30 AM.
 
Old 02-02-2006, 02:14 AM   #2
bosewicht
Senior Member
 
Registered: Aug 2003
Location: Honolulu, HI
Distribution: Arch
Posts: 1,380

Rep: Reputation: 47
did you try installing anjuta with yum?
 
Old 02-02-2006, 02:20 AM   #3
TruongAn
Member
 
Registered: Dec 2004
Location: Vietnam (Việt Nam)
Distribution: Gentoo (desktop), Arch linux (laptop)
Posts: 725

Original Poster
Rep: Reputation: 33
Yum give me the 1.2.3 version only.
 
Old 02-03-2006, 06:30 AM   #4
TruongAn
Member
 
Registered: Dec 2004
Location: Vietnam (Việt Nam)
Distribution: Gentoo (desktop), Arch linux (laptop)
Posts: 725

Original Poster
Rep: Reputation: 33
More info guys.
I have tried installed plplot by source, hoping that it will be recognized by gdl source code.
And that is some last lines I got while I type make in plplot source dir:
Code:
gcw.c: In function 'proc_str':
gcw.c:1023: error: 'FontLookup' undeclared (first use in this function)
gcw.c:1023: error: (Each undeclared identifier is reported only once
gcw.c:1023: error: for each function it appears in.)
gcw.c:1023: error: 'N_TrueTypeLookup' undeclared (first use in this function)
gcw.c:1023: warning: pointer targets in assignment differ in signedness
gcw.c:1047: warning: pointer targets in assignment differ in signedness
make[2]: *** [gcw_la-gcw.lo] Error 1
make[2]: Leaving directory `/mnt/data/downloaded/library/plplot-5.5.3/drivers'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/mnt/data/downloaded/library/plplot-5.5.3'
make: *** [all] Error 2
Is it code bug?
What should I do?
Please help me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Qt dependency trouble ALInux Linux - Software 4 08-14-2005 06:02 PM
solving dependency problems on Suse 9.1 prosh0t Linux - Software 16 03-01-2005 11:09 AM
how to solve failed dependency when dependency exists dwcramer Linux - Newbie 2 08-24-2004 09:03 PM
Solving my Headache Sophic Linux - Wireless Networking 6 03-29-2004 11:27 AM
Solving problems with Linux jamaso Linux - General 3 02-08-2002 06:36 PM


All times are GMT -5. The time now is 01:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration