LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Flash Player doesn't support 64-bit? (http://www.linuxquestions.org/questions/linux-software-2/flash-player-doesn%27t-support-64-bit-828199/)

Vi3GameHkr 08-24-2010 10:51 AM

Flash Player doesn't support 64-bit?
 
So after a little while of trying to get flash player to work in firefox on Slackware, I finally figured something out.

It took me a little bit to figure out where the firefox plugins folder was, because everything I read said in "/usr/lib/mozilla/plugins/" Well in "/usr/lib/" there was about 6 or 7 folders, nothing else. I finally realized everything was in /usr/lib64.

Now my second problem, the flash player plugin I downloaded directly from Adobe didn't work. Well a few searches fixed this, and I found a link to the 64-bit plugin at SlackBuild (http://slackbuilds.org/repository/13...player-plugin/) Now I have a couple of questions. First off, Is there any resource that would help me find out exactly what the security risks that SlackBuild claims exist in the x86_64 edition of flashplayer are, so that I can take proper precautions?

Adobe says that they don't currently support 64-bit and they say you can just use a 32-bit browser. I am a bit of a newbie when it comes to 64-bit and 32-bit architectures, so I would just like to read about the advantages of using a 64-bit browser over a 32-bit, and it would help me if anyone could direct me to a website or resource all about the 64-bit and 32-bit architecture stuff.

And in conclusion: The point in me posting this is I would like to decide whether I should continue using the 64-bit firefox or switch to a 32-bit version so I can use the official version of flashplayer. I have a habit of generally preferring the default installed applications because I feel they are typically chosen for the best compatibility, and otherwise I don't feel like asking what application I should use for each and every field of applications.

For now I'll install the 32-bit version and see if I notice any differences.

Thanks for any help in this matter,
Vi3

camorri 08-24-2010 03:12 PM

Sorry I can not answer your questions directly. I will offer another solution though.

I'm running Mandriva 2010.1 64 bit system. I deleted the old flashplayer plugin file, and downloaded the latest 32 bit file from Adobe. I installed two packages, the names are :

nspluginwrapper.5mdv2010.1 and nspluginwrapper-i386.5mdv2010.1. Both are for a 64 bit arch. The wrapper allows you to use the 32 bit Adobe plugin on a 64 bit system. It works well enough for me. I have read some users seeing some minor problems, however believe the security risks are not there.

I do not know if there are any nspluginwrappers available for Slackware though.

Hope this helps.

craigevil 08-24-2010 04:36 PM

http://wiki.linuxquestions.org/wiki/...I_run_Flash.3F

Quote:

The 64-bit version of Flash has been discontinued. The best workaround is to run the 32-bit version of Flash inside a 32-bit browser. To set this up with Chrome, do the following:

1. install the multilib packages (see the previous question)
2. replace Seamonkey with the 32-bit version (that's the 32-bit version, not the 32-bit compatibility version)
3. install ORBit2 and GConf. You can install the 32-bit versions, or the 64-bit versions plus the 32-bit compatibility versions.
4. install the 32-bit versions of Flash and Chrome

Vi3GameHkr 08-24-2010 10:52 PM

craigevil, I had looked at that briefly (and I think it's funny that it says discontinued while Adobe just says the labs are temporarily closed) and I would rather see some information on the differences between 32-bit and 64-bit, and whether or not it will affect my browsing experience (which includes quite a bit of flash and java apps, but I use the NoScript plugin so hopefully I'm safe from most untrusted flash apps that might get through whatever security holes are in the old 64-bit version of flash player)

camorri, I'll definitely do a couple searches on that later and possibly let you know what I find here.

Thank you


All times are GMT -5. The time now is 05:48 AM.