LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Firefox using QT Filechooser Dialog (http://www.linuxquestions.org/questions/linux-software-2/firefox-using-qt-filechooser-dialog-924541/)

sadarax 01-19-2012 01:35 AM

Firefox using QT Filechooser Dialog
 
I am having a Firefox issue. I want to know, how do I enable the QT file chooser (saving a file, or opening a file) for Firefox? I was not even aware it could be done until it happened accidentally to me. Below is an image of what my Firefox with the QT file chooser looks like.

http://img5.imagetwist.com/th/00887/hxtp68djbf0n.jpg

I think it is related to some Ubuntu package I have installed but I don't know what.

I have two computers, each running Kubuntu 11.04, On both I am running the latest stable version of Firefox (version 9.0.1), which I downloaded from the Ubuntu Mozilla Security PPA (https://launchpad.net/~ubuntu-mozill...y/+archive/ppa).

However on one computer, when I save or open anything, the dialog is a QT style window. On the other computer, it is in GTK. I want to know, how do I enable the QT file chooser for both?

I have tried this with blank profiles, and the results are still different between each computer. It is not a Firefox profile configuration issue (at least something I have done).

I am guessing maybe it is some library or extra package I have installed but I don't know what.

craigevil 01-19-2012 02:24 PM

Add this to your user.js

/* Get rid of the ugly gtk file picker */
user_pref("ui.allow_platform_file_picker", false);

or open about:config in firefox and change ui.allow_platform_file_picker to false

sadarax 01-19-2012 02:54 PM

Quote:

Originally Posted by craigevil (Post 4579098)
Add this to your user.js

/* Get rid of the ugly gtk file picker */
user_pref("ui.allow_platform_file_picker", false);

or open about:config in firefox and change ui.allow_platform_file_picker to false

Thank you but this is not what I am looking for. That just turns on an internal file-picker provided by Mozilla. I am looking to have the QT4 file selector for Firefox, and I know there must be a reason and a way to set it up (because it is working on one of my systems here right now).

sadarax 01-20-2012 03:28 AM

I found the solution. I needed to install the package 'firefox-kde-support'. Everything now is wonderful.


All times are GMT -5. The time now is 08:00 PM.