LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 04-18-2011, 02:36 PM   #1
comcastuser
Member
 
Registered: May 2004
Posts: 140

Rep: Reputation: 22
Firefox not opening ODT files in Libreoffice


I can't get Firefox to open Opendoc files in the correct program.

I'm using Gnome 2.32 (or 1.4.2? I'm not sure) and KDE 4.6.1 and in both instances whenever I download an ODT and right-click to "Open" it in the Downloads window, Firefox opens up "python /usr/bin/ebook-viewer (filename)".

I already went into mimeTypes.rdf and deleted the entire reference to odt, and I also went into dolphin, konqueror and nautilus to make sure it opens into Libre Office.

What else do I need to do to make Firefox open ODT files in the application I desire?

Thanks!
 
Old 04-18-2011, 02:46 PM   #2
Thor_2.0
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,168
Blog Entries: 23

Rep: Reputation: 275Reputation: 275Reputation: 275
Hi,

I'd try (in FireFox, of course) Edit-Preferences-Applications. There you'd select the ODT extention and choose the required program from the drop-down. You may (MAY, I dont know) have to look into the file system for the Writer...

Luck!

Thor
By the way :

Quote:
I'm using Gnome 2.32 (or 1.4.2? I'm not sure)
You need to click System-About Gnome for the correct info...and the version of Gnome/KDE does not matter, as far as I can tell...

Last edited by Thor_2.0; 04-18-2011 at 02:47 PM.
 
Old 04-18-2011, 03:40 PM   #3
comcastuser
Member
 
Registered: May 2004
Posts: 140

Original Poster
Rep: Reputation: 22
Quote:
Originally Posted by Thor_2.0 View Post
Hi,

I'd try (in FireFox, of course) Edit-Preferences-Applications. There you'd select the ODT extention and choose the required program from the drop-down. You may (MAY, I dont know) have to look into the file system for the Writer...
I tried that and it didn't work, which is why I completely removed odt from the mimeTypes file.
 
Old 04-18-2011, 04:13 PM   #4
MTK358
LQ 5k Club
 
Registered: Sep 2009
Posts: 6,443
Blog Entries: 3

Rep: Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713
I'd try "xdg-mime default <application> <mimetype>", but I don't know the command to start OpenOffice writer, nor do I know ODT's mimetype.
 
Old 04-19-2011, 02:20 AM   #5
comcastuser
Member
 
Registered: May 2004
Posts: 140

Original Poster
Rep: Reputation: 22
Quote:
Originally Posted by MTK358 View Post
I'd try "xdg-mime default <application> <mimetype>", but I don't know the command to start OpenOffice writer, nor do I know ODT's mimetype.
Me neither... this'll take a whole lot of research...
 
Old 04-19-2011, 10:14 PM   #6
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,732
Blog Entries: 12

Rep: Reputation: 454Reputation: 454Reputation: 454Reputation: 454Reputation: 454
Try installing mozilla-libreoffice depending on your distro and how you installed Libreoffice it can be a separate package.


mozilla-libreoffice - office productivity suite -- Mozilla plugin
Quote:
This package contains a Mozilla/Netscape compatible plugin which can handle
all OOo documents.
 
Old 04-22-2011, 01:39 AM   #7
comcastuser
Member
 
Registered: May 2004
Posts: 140

Original Poster
Rep: Reputation: 22
Quote:
Originally Posted by craigevil View Post
Try installing mozilla-libreoffice depending on your distro and how you installed Libreoffice it can be a separate package.


mozilla-libreoffice - office productivity suite -- Mozilla plugin
Crap, that doesn't exist for Fedora. Only Debian/Ubuntu.
 
Old 04-23-2011, 04:06 AM   #8
comcastuser
Member
 
Registered: May 2004
Posts: 140

Original Poster
Rep: Reputation: 22
Okay well how do I find out why Firefox calls "python /usr/bin/ebook-viewer"? Is there a setting inside Firefox that I can investigate?

mozilla-libreoffice doesn't exist for Fedora. My only other option is to uninstall libreoffice but apparently Fedora 15 is using Libreoffice which means I'll never be able to open ODT files through Firefox. (Which means I gotta download, hunt for them and open them manually.)
 
Old 04-24-2011, 12:17 AM   #9
comcastuser
Member
 
Registered: May 2004
Posts: 140

Original Poster
Rep: Reputation: 22
Ok in Firefox "Use Ebook reader (Default)" is set. How in the world do I get rid of that default?

I know someone here is an expert on Firefox...?
 
Old 04-25-2011, 08:34 PM   #10
comcastuser
Member
 
Registered: May 2004
Posts: 140

Original Poster
Rep: Reputation: 22
Hey does anyone know about changing FireFox default settings?

I keep going into Firefox Preferences / Applications and asking it to use LibreOffice but it never sets LibreOffice as (Default). I really need help here... someone who knows firefox please give me a few tips, thanks!
 
Old 04-25-2011, 09:03 PM   #11
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, Mint
Posts: 6,891

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
I just pointed my Firefox at a *.odt file on my hard drive, double-clicked, and Firefox presented me with an "open with" dialog.

It was set to Open Office, but it gave me an option to point to another program and check an "Always use . . ." check box.

I browsed to /usr/bin/ and selected libreoffice, checked the checkbox, and the file opened in LO. I then selected another *.odt file and now LO was the default.

You would probably have to do this for each OO file type.

For the life of me, I can't find where that is in the Firefox Edit-->Preferences dialog or even in about:config. It may be buried in some file in home dot mozilla somewhere but I'm too lazy to look.
 
Old 04-27-2011, 09:33 PM   #12
comcastuser
Member
 
Registered: May 2004
Posts: 140

Original Poster
Rep: Reputation: 22
Quote:
Originally Posted by frankbell View Post
I just pointed my Firefox at a *.odt file on my hard drive, double-clicked, and Firefox presented me with an "open with" dialog.

It was set to Open Office, but it gave me an option to point to another program and check an "Always use . . ." check box.

I browsed to /usr/bin/ and selected libreoffice, checked the checkbox, and the file opened in LO. I then selected another *.odt file and now LO was the default.

You would probably have to do this for each OO file type.

For the life of me, I can't find where that is in the Firefox Edit-->Preferences dialog or even in about:config. It may be buried in some file in home dot mozilla somewhere but I'm too lazy to look.
Ok I tried this today. It works this way when you open the file through the file menu, but when you download the file and open it from the "Downloads" window it still opens in the E-book viewer instead of libreoffice.

Argh!!! I wish I knew what this e-book reader package is so I could "yum remove" it!!!
 
Old 04-27-2011, 09:54 PM   #13
comcastuser
Member
 
Registered: May 2004
Posts: 140

Original Poster
Rep: Reputation: 22
Okay the problem is Calibre. When I removed Calibre from my system this entire problem goes away.

But when I reinstalled Calibre it supercedes my settings - so when I try to open a downloaded .ODT file in Firefox's Downloads window it fires up /usr/bin/ebook-viewer again.

Now I can't find the setting in Calibre to make it ignore .ODT. ARGH. WTF.
 
Old 04-27-2011, 10:04 PM   #14
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, Mint
Posts: 6,891

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Are you using Fedora?

It's a stab in the dark, but let Firefox (try to) open a document in the ebook reader thingee. Maybe you can get the program name from the title bar; that might help you in your search.

Then try "yum provides [program name]" to see what package it's from.

I have CentOS in VirtualBox (I know it's not the same as Fedora) and when I searched the Add/Remove Software for "ebook reader," it turned up stuff like gedit, for heaven's sake.
 
Old 04-27-2011, 10:33 PM   #15
5149.5
LQ Newbie
 
Registered: Apr 2011
Location: Oceanside
Distribution: Ubuntu
Posts: 15

Rep: Reputation: 0
Quote:
Originally Posted by comcastuser View Post
Okay the problem is Calibre. When I removed Calibre from my system this entire problem goes away.

But when I reinstalled Calibre it supercedes my settings - so when I try to open a downloaded .ODT file in Firefox's Downloads window it fires up /usr/bin/ebook-viewer again.

Now I can't find the setting in Calibre to make it ignore .ODT. ARGH. WTF.
It sounds like Calibre is working as designed. Since one of the formats it understands is .ODT, it assigns itself as the default app for that format. Is there an option during the Calibre install where you can disallow that by chance?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
What program in Windows to convert ODT files? ToothlessRebel General 13 10-06-2009 11:54 PM
opening .url files in Firefox millertime Linux - Software 5 04-11-2009 03:22 AM
Opening rmvb files within Firefox? andrew.46 Linux - Software 2 01-15-2009 11:21 PM
Why doesn't cat work with odt files? Ryzol Linux - General 6 10-03-2007 07:43 PM
How do I link to odt/docx files in a webpage? matthewhardwick Programming 5 12-09-2006 06:41 PM


All times are GMT -5. The time now is 09:22 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration