LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-09-2008, 09:37 PM   #1
Rockgod1969
Member
 
Registered: Jan 2007
Posts: 54

Rep: Reputation: 15
Firefox no borders under compiz. Not able to move, maximize.


I'm running an HP DV900 with nvidia vid card and ubuntu 8. I installed fusion, but whenever I open up firefox, it has no borders, particularly the title bar- hence no maximize or minimize button or ablity to move the screen around. I can get borders, but I have to switch to metacity and then back to compiz everytime, talk about annoying! I tried uninstalling and reinstalling nvidia drivers, no no effect. Is there a fix to this or is it a bug?
 
Old 07-10-2008, 12:05 AM   #2
paulpc
LQ Newbie
 
Registered: Mar 2007
Location: Oklahoma City
Distribution: openSUSE 10.3, 11.0, DSL
Posts: 13

Rep: Reputation: 0
is it only the firefox window?
 
Old 02-16-2009, 11:15 PM   #3
Pauly Psychotic
LQ Newbie
 
Registered: Feb 2009
Location: Kingston, Ontario
Distribution: Ubuntu
Posts: 3

Rep: Reputation: 0
Thumbs up

you must have compiz settings manager installed open program, go to general then general options uncheck unredirect fullscreen windows.

then restart firefox.
 
Old 02-17-2009, 12:06 AM   #4
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,658
Blog Entries: 3

Rep: Reputation: 224Reputation: 224Reputation: 224
Quote:
Option "AddARGBGLXVisuals" "True"
add that to your xorg.conf file under device section like mine.
Quote:
Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce2 MX/MX 400"
Option "AddARGBGLXVisuals" "True"
Option "DamageEvents" "True"
this always fixes mine I have 3 systems running 3d desktop. same thing as your does mine would to. This option loads the setting in the nvida-kernel.

Last edited by Drakeo; 02-17-2009 at 12:09 AM.
 
Old 02-17-2009, 03:40 PM   #5
anurag_bhd
Member
 
Registered: Nov 2006
Location: Jalandhar, India
Distribution: openSuSE 11.0, Granular 1.0, Mandriva One 2009, Fedora 11
Posts: 60

Rep: Reputation: 18
You can also try one more trick. Right-click on the Compiz icon in the system try (when running) and select to change the window manager to Emerald, if that is not already selected.
 
Old 02-17-2009, 04:05 PM   #6
Ranguvar
Member
 
Registered: Oct 2008
Location: Upstate NY
Distribution: Arch Linux
Posts: 99

Rep: Reputation: 17
Just Firefox?

The part of the Compiz package that draws window borders is called Emerald. If you started Compiz through the Fusion icon (as you should, it's in the repos), use the icon in the systray to choose the window decorator and see if you can get it to work. Make sure you're using a 3D-enabled driver, too - in this case, the proprietary, non-free NVIDIA drivers.
 
Old 02-18-2009, 08:07 AM   #7
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,658
Blog Entries: 3

Rep: Reputation: 224Reputation: 224Reputation: 224
Quote:
Originally Posted by Ranguvar View Post
Just Firefox?

The part of the Compiz package that draws window borders is called Emerald. If you started Compiz through the Fusion icon (as you should, it's in the repos), use the icon in the systray to choose the window decorator and see if you can get it to work. Make sure you're using a 3D-enabled driver, too - in this case, the proprietary, non-free NVIDIA drivers.
I have to disagree with you on this emerald is just a windows them manager . I never download emerald with all my systems it is not needed. it would be if you were running exfce may be. but meta city gnome and kde all have back end for compiz-fusion and compiz. the border problem a rendering problem. so far pclinux 2007 and 2008 Slackware 12.2 and Mandriva 2009 never needed emerald it was an option.
 
Old 02-18-2009, 08:15 AM   #8
SkinnerC
Member
 
Registered: Dec 2007
Location: New England, USA
Distribution: Ubuntu 8.04 LTS, Slackware 12.2
Posts: 138
Blog Entries: 1

Rep: Reputation: 20
I had this problem with FF before and I had to go into the config for FF and remove the setting window='maximize' This allowed me to gain control of the window sizing again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compiz Window borders/titlebar nardz Linux - Desktop 5 11-22-2013 02:25 AM
Compiz-fusion has no borders oldsko0l Linux - Software 4 08-01-2011 12:51 PM
No borders on firefox with compiz Rockgod1969 Linux - Software 2 07-07-2008 12:06 AM
No borders when using compiz..... budword Linux - Software 2 01-20-2008 10:43 AM
compiz, window borders??? liaty Suse/Novell 6 06-19-2006 05:52 AM


All times are GMT -5. The time now is 07:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration