Register a domain and help support LQ
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 02-17-2007, 06:05 PM   #1
Registered: Sep 2006
Posts: 36

Rep: Reputation: 15
Firefox and KDE 3.5.6....

I am running slackware 10.2 with kernel 2.4.31. I was running KDE 3.5.5 and everything was working great. I installed KDE 3.5.6 by utilizing something called "konstruct" and now when I launch firefox it won't start up. So I try starting from the shell (so I can see the error messages) and get this:

kmm@mojave:~> firefox
/usr/lib/firefox/firefox-bin: Symbol `g_thread_functions_for_glib_use' has different size in shared object, consider re-linking

/usr/lib/firefox/ line 131: 22694 Segmentation fault "$prog" ${1+"$@"}

Is there an easy way to fix this? Thank you for your
assistance and time.
Old 02-17-2007, 06:25 PM   #2
Registered: Sep 2006
Posts: 36

Original Poster
Rep: Reputation: 15
Also, for what it's worth, I get the same problem now
if I use a different window manager....
KDE 3.5.6
all do the same thing.....
Thanks again for your time and assistance
Old 03-26-2007, 10:55 PM   #3
LQ Newbie
Registered: Mar 2007
Posts: 1

Rep: Reputation: 0
Quick and dirty fix

The problem is related to the LD_LIBRARY_PATH variable. So, a quick and dirty solution for this problem is:
1) Locate the installation path for firefox
2) Open the firefox file script (It is a sh script), with vi or any text editor.
3) At top of the file put the following line (just after the first comments and before the begin of the functions):
4) Save the file and start firefox

It's all.

Last edited by camarti; 03-26-2007 at 11:06 PM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Kde, Firefox, and Sudo Murdock1979 Linux - General 6 10-04-2006 08:36 PM
Firefox in KDE nerzack Linux - Software 1 06-12-2006 10:04 PM
Emailing from Firefox in KDE dARkHunTEr Linux - Software 1 12-04-2004 09:26 AM
firefox + kde alaios Linux - Software 11 11-09-2004 11:27 PM
Firefox KDE issue camberiu Linux - Newbie 4 08-05-2004 10:51 PM

All times are GMT -5. The time now is 08:48 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration