LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-18-2009, 03:13 AM   #16
ashok.g
Member
 
Registered: Dec 2009
Location: Hyderabad,India
Distribution: RHEl AS 4
Posts: 215

Rep: Reputation: 32

bathory,

You missed my point. During this process I changed my default browser to mozilla(not firefox)and I amn't able to see such option there....

Last edited by ashok.g; 12-18-2009 at 03:21 AM.
 
Old 12-18-2009, 04:41 AM   #17
TheIndependentAquarius
Senior Member
 
Registered: Dec 2008
Posts: 4,622
Blog Entries: 29

Original Poster
Rep: Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896
Oh I just now checked the Help menu and found the option "Check for updates" disabled in firefox 3.5.6???

It was not disabled before !

In Preferences->Advanced->Update,
Automatically check for updates : firefox is also disabled !!

Help once again !!
 
Old 12-18-2009, 07:20 AM   #18
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,907

Rep: Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326
@ashok.g
I didn't missed your point. Start firefox from CLI and by default it will tell you it's not the default browser. If it doesn't then do what I told you in the previous post

@anishakaul
This is most likely a permissions problem. Take a look at this for details.
 
1 members found this post helpful.
Old 12-19-2009, 02:24 AM   #19
TheIndependentAquarius
Senior Member
 
Registered: Dec 2008
Posts: 4,622
Blog Entries: 29

Original Poster
Rep: Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896
Quote:
Originally Posted by bathory
@anishakaul
This is most likely a permissions problem. Take a look at this for details.
Thanks for the reply !

The link u posted has the following statements:
Quote:
To get Firefox updated, log in to your computer as a user with sufficient permissions, for example an administrative account. Check for Updates... should then be enabled.

To make Check for Updates... enabled permanently, change the permissions on the Firefox installation directory.
I executed firefox from the root login, but still the "Check for updates..." is disabled !

I changed the permissions of the directory where I had untared the firefox tar ball:
Code:
chmod 777 /home/anisha/linuxSoftwares/firefox/*
but still the "Check for updates..." is disabled !
 
Old 12-19-2009, 03:20 AM   #20
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,907

Rep: Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326
You should not run the browser as root for security reasons.
Anyway use:
Code:
chmod -R 777 /home/anisha/linuxSoftwares/firefox
to change permissions recursively.
 
0 members found this post helpful.
Old 12-19-2009, 03:27 AM   #21
TheIndependentAquarius
Senior Member
 
Registered: Dec 2008
Posts: 4,622
Blog Entries: 29

Original Poster
Rep: Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896
Quote:
Originally Posted by bathory
You should not run the browser as root for security reasons.
Anyway use:
Code:

chmod -R 777 /home/anisha/linuxSoftwares/firefox

to change permissions recursively.
Thanks for answering, I tried what u said, but it didn't change the update condition !
 
Old 12-19-2009, 03:49 AM   #22
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,907

Rep: Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326
Try changing the owner/group of the whole firefox dir:
Code:
chown -R anisha:users /home/anisha/linuxSoftwares/firefox
and see if it helps.
 
Old 12-19-2009, 03:55 AM   #23
TheIndependentAquarius
Senior Member
 
Registered: Dec 2008
Posts: 4,622
Blog Entries: 29

Original Poster
Rep: Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896
Quote:
Originally Posted by bathory
Try changing the owner/group of the whole firefox dir:
Code:

chown -R anisha:users /home/anisha/linuxSoftwares/firefox

and see if it helps.
No it didnt help
 
Old 12-19-2009, 04:04 AM   #24
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,907

Rep: Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326
what happens if you run it from an xterm like:
Code:
$/home/anisha/linuxSoftwares/firefox/firefox
What distro are you running? Could be a security problem of your distro, like SElinux.
 
Old 12-19-2009, 04:11 AM   #25
TheIndependentAquarius
Senior Member
 
Registered: Dec 2008
Posts: 4,622
Blog Entries: 29

Original Poster
Rep: Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896
Quote:
Originally Posted by bathory
what happens if you run it from an xterm like:
Code:

$/home/anisha/linuxSoftwares/firefox/firefox

What distro are you running? Could be a security problem of your distro, like SElinux.
Thanks for answering, I tried what u said from xterm, but it didn't change the update condition !

opensuse 11.1

How should i check what security problem it is having ?
 
Old 12-19-2009, 08:38 AM   #26
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,907

Rep: Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326Reputation: 1326
Suse uses apparmor for enhancing security. I have never use it, so I don't know how it works, but you can try to disable it to see if that's the real problem. Or you can delete the firefox profile if it exists.

FYI, on a friend's box running OpenSuse 10.3 with firefox installed in his homedir, the update function works as expected (no apparmor firefox profile exists)
 
Old 12-24-2009, 04:49 AM   #27
TheIndependentAquarius
Senior Member
 
Registered: Dec 2008
Posts: 4,622
Blog Entries: 29

Original Poster
Rep: Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896
Quote:
Originally Posted by bathory
Suse uses apparmor for enhancing security. I have never use it, so I don't know how it works, but you can try to disable it to see if that's the real problem. Or you can delete the firefox profile if it exists.

FYI, on a friend's box running OpenSuse 10.3 with firefox installed in his homedir, the update function works as expected (no apparmor firefox profile exists)
Thanks for answering..

Now I have installed opensuse 11.2

I uninstalled the default firefox completely through yast

Then issued the following commands:

cd /usr/bin/
rm firefox
ln -s /home/downloads/firefox/firefox /usr/bin/


Now when i started firefox it resulted in the following error message :

Code:
(firefox-bin:4567): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64                                                             

(firefox-bin:4567): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64                                                             

(firefox-bin:4567): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64

(firefox-bin:4567): Gtk-WARNING **: /usr/lib64/gtk-2.0/2.10.0/engines/libclearlooks.so: wrong ELF class: ELFCLASS64
New firefox started but again the "Check for updates..." option was disabled !

Is it really related to app-armour or something else ?

Actually http://www.unix-tutorials.com/go.php?id=3965 website is blocked on my computer !!

Last edited by TheIndependentAquarius; 12-24-2009 at 04:50 AM.
 
Old 12-24-2009, 05:02 AM   #28
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Rep: Reputation: 129Reputation: 129
Quote:
New firefox started but again the "Check for updates..." option was disabled !

Is it really related to app-armour or something else ?
Launch firefox as root.
Btw, that is not the way to update firefox, proper way is to upgrade using the repositories. openSUSE has a separate Mozilla repo, subscribe to that and you can update your firefox when a new version arrives.

Last edited by ~sHyLoCk~; 12-24-2009 at 05:03 AM.
 
Old 12-24-2009, 05:35 AM   #29
TheIndependentAquarius
Senior Member
 
Registered: Dec 2008
Posts: 4,622
Blog Entries: 29

Original Poster
Rep: Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896
Thanks for replying !

Quote:
Originally Posted by ~sHyLoCk~
Launch firefox as root.
I did run firefox from root and same thing happens !

Quote:
Originally Posted by ~sHyLoCk~
Btw, that is not the way to update firefox, proper way is to upgrade using the repositories. openSUSE has a separate Mozilla repo, subscribe to that and you can update your firefox when a new version arrives.
I don't have internet connection at home! Thats why I did it this way ! Is there any other way to do it when u don't have an internet connection ?
 
Old 12-24-2009, 05:49 AM   #30
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Rep: Reputation: 129Reputation: 129
Quote:
Originally Posted by anishakaul View Post
I don't have internet connection at home! Thats why I did it this way ! Is there any other way to do it when u don't have an internet connection ?
If you don't have an internet connection how is "Check for updates" option going to help you? Well there's a way. You can download the rpm packages alongwith xulrunner and other dependencies like cairo,etc. when a new version comes out and install them later in your system.
Btw, launching firefox as root or even as sudo enables "check for updates" option for me and I'm pretty sure it's not distro-specific.
 
  


Reply

Tags
firefox, update


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
echo $PATH = /home/g3rc4n/bin:/usr/local/bin:/usr/bin:/bin:/usr/games ? i_heart_pandas Linux - Software 7 09-18-2009 08:33 AM
Failed to chck remot comnd executin using shells /usr/bin/ssh and /usr/bin/rsh farnaw4u Linux - Software 2 04-06-2009 12:08 AM
Ubuntu 5.10 -> 6.06: diversion of /usr/bin/ldd to /usr/bin/ldd.amd64 by ia32-libs HellSpawn Linux - Software 2 06-04-2006 09:18 PM
/usr/bin/firefox? xbill311x Linux - Software 2 05-06-2006 02:20 AM
path in services wrong for clamav updated frm 0.75 to 0.80 usr/bin vs usr/local/bin Emmanuel_uk Linux - Newbie 3 04-22-2005 01:02 AM


All times are GMT -5. The time now is 08:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration