LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-11-2008, 02:09 AM   #1
harry2006
Member
 
Registered: Aug 2006
Location: /hawaii/honolulu/downtown
Distribution: Fedora 10[Cambridge] and Ubuntu 9.04[Jaunty]
Posts: 201

Rep: Reputation: 30
Question Firefox 3.0.2 not starting up, Error[Couldn't load XPCOM]


hi all. till yesterday evening everything was fine including firefox. today in the morning when i started firefox it dint come up then i tried running it from command line and got the following error message
Code:
Couldn't load XPCOM.
after googling for some time got some links in some other forums[surprisingly i dint get any @LQ, seems nobody faced similar prob?]
http://ubuntuforums.org/showthread.php?t=951615

but i'm afraid , even after doing what is mentioned there, firefox is stil down and it gives me the same error, has anyone come accross similar issues with firefox , BTW i'm using fedora 2.6.26 and firefox 3.0.2. please help me out as i use firefox most of the time, currently i'm trying to somehow manage with opera . thank you very much.
 
Old 11-11-2008, 07:09 AM   #2
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Here is a place to start..
https://developer.mozilla.org/en/Tro...s_registration
 
Old 11-13-2008, 03:04 AM   #3
harry2006
Member
 
Registered: Aug 2006
Location: /hawaii/honolulu/downtown
Distribution: Fedora 10[Cambridge] and Ubuntu 9.04[Jaunty]
Posts: 201

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by farslayer View Post
Thanks for providing this link. I went thru that and finally the section "Linux specific hints" and tried to do what's been asked there. Did run the first part to make sure that there are no "not found" dependencies. BTW i checked this for libmozjs.so. I got the following list and didnot get any "not found" types,
Code:
[home@harrys]./run-mozilla.sh `which ldd` -r /usr/lib/xulrunner-1.9/libmozjs.so
        linux-gate.so.1 =>  (0x00110000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x0067b000)
        libm.so.6 => /lib/libm.so.6 (0x00649000)
        libdl.so.2 => /lib/libdl.so.2 (0x00674000)
        libplds4.so => /lib/libplds4.so (0x04078000)
        libplc4.so => /lib/libplc4.so (0x0407d000)
        libnspr4.so => /lib/libnspr4.so (0x04084000)
        libc.so.6 => /lib/libc.so.6 (0x004de000)
        /lib/ld-linux.so.2 (0x004be000)
could not figure out properly what they are trying to make us do @the_mozilla_page you mentioned, can you please help me what to check next? or what is the next step? Thank you very much.
 
Old 11-13-2008, 09:58 PM   #4
mogrady
Member
 
Registered: Feb 2005
Location: Lakeland, Florida
Distribution: Ubuntu, Xbuntu, Puppy, XP Pro
Posts: 104

Rep: Reputation: 15
Firefox Fix, Maybe

I downloaded the latest FF build, 3.0.4 from instructions on the site below. Maybe trying the same method with FF 3.x might help solve the problem. Might have to completely uninstall the current version you have.

https://help.ubuntu.com/community/FirefoxNewVersion

Good luck, MIchael
 
Old 11-16-2008, 10:57 PM   #5
harry2006
Member
 
Registered: Aug 2006
Location: /hawaii/honolulu/downtown
Distribution: Fedora 10[Cambridge] and Ubuntu 9.04[Jaunty]
Posts: 201

Original Poster
Rep: Reputation: 30
my special thanks to all you guys! all of you helped me a lot.
i updated my system and voila FF is working fine, BTW still i dont know whatz the issue,
@mogrady, thank you, i went thru that tutorial , a nice step by step explanation of installing FF.Thank you.
 
Old 02-28-2009, 04:52 PM   #6
alisson.gomesc
LQ Newbie
 
Registered: Feb 2009
Posts: 1

Rep: Reputation: 0
Thumbs up solution for update fedora 10

I have same problem after update fedora 9 to fedora 10.

The solution was:

# yum search mozilla
...
xulrunner.i386 : XUL Runtime for Gecko Applications
xulrunner.x86_64 : XUL Runtime for Gecko Applications
xulrunner-devel.i386 : Development files for Gecko
...

# yum install xulrunner.x86_64

Read!
 
Old 04-06-2011, 02:49 PM   #7
seven9
LQ Newbie
 
Registered: Apr 2011
Posts: 2

Rep: Reputation: 0
I know that this post is more than 6 months old, but "Couldn't load XPCOM" error have made me crazy! I have found the solution and I want to share with you. The error was in the LD_LIBRARY_PATH environment variable. It lacks the path to /usr/lib. Add this path to the variable and everything should work.

I have found the solution on this site http://discovolante.altervista.org/e...ad-xpcomq.html

Hope this will help someone else
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
IceWeasel fails to start after upgrade because XPCOM doesn't load (workaround) jlinkels Debian 0 08-12-2008 07:14 AM
gtk_threads_lock error when starting Firefox under OpenSuSE 10.3 pwabrahams Linux - Software 1 10-23-2007 10:54 AM
radeon module fails to load when starting X manlydan Linux - General 9 02-11-2007 02:18 PM
Cant load KDEinit at starting! math_1048 Linux - Desktop 0 01-09-2007 08:00 AM
starting firefox nimrod04 Linux - Software 4 02-17-2004 02:36 PM


All times are GMT -5. The time now is 09:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration