LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Firefox 2.0.0.5 and JRE 6.0.2 (http://www.linuxquestions.org/questions/linux-software-2/firefox-2-0-0-5-and-jre-6-0-2-a-575794/)

andymck 08-09-2007 01:24 AM

Firefox 2.0.0.5 and JRE 6.0.2
 
I've looked at every thread I can find regarding Firefox and JRE 6 and nothing seems to offer a solution to my problem. I tried to install JRE 6.0 from the RPM file and came up with several screens' worth of unsatisfied dependencies. I then tried installing from the .bin file, created the symbolic link to libjavaplugin_oji.so in the /usr/lib/mozilla/plugins/ directory, and it appeared to be happy until I tried to run an applet -- the output from the applet was just a plain white area. It doesn't bomb off Firefox, it doesn't tell me I need to install the JRE -- nothing.

I tried the Sun "Verify Installation" page; it did nothing for a minute or so, then reloaded the page, waited another minute or so, and finally went to the page with the "Test your JVM" applet on it. The space for the Java configuration display is blank white, including the area below it where the dancing Duke logo should be. All of the HTML shows up just fine; it's just the applet display that doesn't do squat.

This is getting very, very frustrating...

bathory 08-09-2007 03:03 AM

You can write
Code:

about:plugins
in the address bar of firefox to verify that it sees the java plugin.

andymck 08-18-2007 09:39 PM

Quote:

Originally Posted by bathory (Post 2852996)
You can write
Code:

about:plugins
in the address bar of firefox to verify that it sees the java plugin.

Sorry it took so long for me to reply; I've been out of town without a PC.

OK, did that. It reports using "Java(TM) Plug-in 1.6.0_02-b05". And, the page I just tested it on still presents no prompt to download Java, but also no useful image -- or, indeed, image of any kind.

I realize this is probably a dumb mistake of some kind in downloading and/or configuring Java/Firefox/X11/whatever; I've had problems before that turned out to have embarrassingly simple causes and solutions both. But, so far, I don't have a clue what that mistake might be.

bathory 08-20-2007 03:09 AM

Did you use this page to verify your plugin installation?
Which one of the two libjavaplugin_oji.so di you use to symlink in the plugins directory? You should use the one under the subdirectory plugin/i386/ns7 and not the one under plugin/i386/ns7-gcc29.

andymck 08-20-2007 05:00 PM

Quote:

Originally Posted by bathory (Post 2864308)
Did you use this page to verify your plugin installation?
Which one of the two libjavaplugin_oji.so di you use to symlink in the plugins directory? You should use the one under the subdirectory plugin/i386/ns7 and not the one under plugin/i386/ns7-gcc29.

Yes, that's the page I used. When I clicked the green "VERIFY INSTALLATION" bar, it showed the "rotating circle of circles" for about 30 seconds, refreshed and stayed for another 30 seconds, then redirected to this page -- with a blank white space between the "Test your JVM" line and the paragraph beginning "This page tests to see ...".

I linked to the libjavaplugin_oji.so under plugin/i386/ns7. (Actually, I tried both; I forget what the other one did, but it also wasn't right; I stayed with this one because it was the one cited as correct.)

Addendum: FWIW, I posted this reply (without this addendum), then relinked to the plugin/i386/ns7-gcc29 version, restarted Firefox, and tried again. It bombed off Firefox immediately, just as I remember reading that it would. I've now linked back to the plugin/i386/ns7 version, with the same results I described above.

bathory 08-21-2007 02:50 AM

You should check if java is enabled in your browser. Go to: Edit-->Preferences-->Content and make sure the "Enable Java" option is checked.

andymck 08-22-2007 08:32 PM

Quote:

Originally Posted by bathory (Post 2865465)
You should check if java is enabled in your browser. Go to: Edit-->Preferences-->Content and make sure the "Enable Java" option is checked.

Yup -- JavaScript as well (in case that matters, and it almost certainly shouldn't).

BTW, lest I forget later: Thanks for taking the time to work with me on this. I really, really appreciate the help.

bathory 08-23-2007 03:15 AM

Perhaps you should read this and maybe downgrade your java to 1.5.

Regards

andymck 08-24-2007 09:30 PM

Quote:

Originally Posted by bathory (Post 2867707)
Perhaps you should read this and maybe downgrade your java to 1.5.

Regards

OK, did all of that on the link; "about:plugins" now shows

Java(TM) Plug-in 1.6.0_02-b05

File name: libjavaplugin_oji.so
Java(TM) Plug-in 1.6.0_02

(which, unless I missed a minor detail, is what I already had). My results are unchanged, i.e., running a java applet results in a blank white field where the output of the applet should be.

You may be right about downgrading to 1.5 -- but, dammit (not aimed at you, but at the java world in general), many of the applets I find insist they need 1.6. Maybe I'm being unreasonable, but this looks to me like it's Sun's fault, not mine. Believe me, there's nothing all that exotic about my hardware, and I'm not aware of any installation mistakes that I've made and not corrected -- in fact, that kind of mistake is exactly what I was hoping someone could help me find.

jay73 08-24-2007 09:59 PM

Put

export JRE_HOME=/path/to/java

at the bottom of your /etc/profile.

gr8scot 08-25-2007 06:19 PM

similar problem, /etc/profile edit doesn't fix it
 
Quote:

Originally Posted by jay73 (Post 2869789)
Put

export JRE_HOME=/path/to/java

at the bottom of your /etc/profile.

I added the line
export JRE_HOME=/usr/lib/java/jre1.6.0_02/bin/
but Java Applets still don't load. Followed these instructions,
http://java.sun.com/j2se/1.5.0/manua...all_linux.html
Using Debian 4.0 i386

Here's the punch line ...
address bar = about: plugins

Installed plug-ins
Find more information about browser plug-ins at mozilla.org.
Help for installing plug-ins is available from plugindoc.mozdev.org.
Java(TM) Plug-in 1.6.0_02-b05

File name: libjavaplugin_oji.so
Java(TM) Plug-in 1.6.0_02
application/x-java-vm Java Yes
application/x-java-applet Java Yes
application/x-java-applet;version=1.1 Java Yes
application/x-java-applet;version=1.1.1 Java Yes
application/x-java-applet;version=1.1.2 Java Yes
application/x-java-applet;version=1.1.3 Java Yes
application/x-java-applet;version=1.2 Java Yes
application/x-java-applet;version=1.2.1 Java Yes
application/x-java-applet;version=1.2.2 Java Yes
application/x-java-applet;version=1.3 Java Yes
application/x-java-applet;version=1.3.1 Java Yes
application/x-java-applet;version=1.4 Java Yes
application/x-java-applet;version=1.4.1 Java Yes
application/x-java-applet;version=1.4.2 Java Yes
application/x-java-applet;version=1.5 Java Yes
application/x-java-applet;version=1.6 Java Yes
application/x-java-applet;jpi-version=1.6.0_02 Java Yes
application/x-java-bean Java Yes
application/x-java-bean;version=1.1 Java Yes

etc.
(It also detects java-beans up to the current version.)
I'm going to try Konqueror.

gr8scot 08-25-2007 06:44 PM

Quote:

Originally Posted by gr8scot (Post 2870559)
I'm going to try Konqueror.

Works like a charm!

gr8scot 08-25-2007 07:17 PM

I found this thread helpful
 
Quote:

Originally Posted by andymck (Post 2852928)
I've looked at every thread I can find regarding Firefox and JRE 6 and nothing seems to offer a solution to my problem.

...

This is getting very, very frustrating...

I recently solved a similar experience.
http://www.linuxquestions.org/questi...d.php?t=576793

andymck 08-25-2007 10:11 PM

Quote:

Originally Posted by gr8scot (Post 2870621)
I recently solved a similar experience.
http://www.linuxquestions.org/questi...d.php?t=576793

If by this you mean that you set the correct link to libjavaplugin_oji.so in your plugins directory, then I already did that; if not, then I'm not seeing what part of your fix I'm still missing.

andymck 08-25-2007 10:21 PM

Quote:

Originally Posted by jay73 (Post 2869789)
Put

export JRE_HOME=/path/to/java

at the bottom of your /etc/profile.

Ah-HAH! This sounds like what I've been looking for. What should "/path/to/java" be -- the path to the java binary (/usr/bin/java), the path to the JRE directory, or what? Also, can you point me to a link to where JRE_HOME is documented?

Finally, a side note: Wouldn't it be more in "flavor" to put the above line in a file named something like "/etc/profile.d/jre.sh"? (Or am I being too "linux-geeky"?)


All times are GMT -5. The time now is 09:24 AM.