LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-12-2005, 09:17 PM   #1
springshades
Member
 
Registered: Nov 2004
Location: Near Lansing, MI , USA
Distribution: Mainly just Mandriva these days.
Posts: 304

Rep: Reputation: 30
Filesystem Check Every Boot


I believe Linux should be doing a full file system check every 20-30 boots. Recently (and most likely due to an update I've done), I'm having a full file system check EVERY boot. That's a very unwelcome 3-5 minutes addition to my boot up times which is quite annoying for a laptop that's supposed to be mobile.

Anyone know what config file might control this? From my searches I've found information on FSCK and e2fsck, but neither of these seems to actually control the boot process. I tried editing the sixth field of my fstab in hopes that I could simply turn off file system checks for everything but my root partition. No effect at boot. Saw something about /etc/boot.conf, but my distro doesn't have one of those.
 
Old 08-12-2005, 09:34 PM   #2
tuxdev
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 2,011

Rep: Reputation: 110Reputation: 110
tune2fs controls that, but there might be other problems that is causing the computer to think that there is a high risk for error, like improperly shutting down the computer. It is normal for a fsck to happen at around 25 boots, depending on the size of the partition, I think.
 
Old 08-12-2005, 09:36 PM   #3
puffinman
Member
 
Registered: Jan 2005
Location: Atlanta, GA
Distribution: Gentoo, Slackware
Posts: 217

Rep: Reputation: 30
That should be controlled in your system init scripts. In gentoo, they are in /etc/init.d, in slackware they are in /etc/rc.d. You didn't come out and say what distro you were using, unless it is Mandrake 10.1 as it says in your profile, in which case I don't know where you init scripts are. In any case, I would recommend running something like "grep fsck *" in your init script directory to find out precisely which file is doing the checks.
 
Old 08-14-2005, 09:15 PM   #4
springshades
Member
 
Registered: Nov 2004
Location: Near Lansing, MI , USA
Distribution: Mainly just Mandriva these days.
Posts: 304

Original Poster
Rep: Reputation: 30
Well, tune2fs appears like it's SUPPOSED to control this issue. However, I've now played with it, and it doesn't appear to be changing anything. If this were an issue with bad shutdowns, I'd probably be getting error message during start up which haven't been happening (I've had bad shutdowns before, and I normally get some sort of message about it my next boot.).

I am using Mandrake on this computer though I've since moved to 10.2... the structure of everything is still the same though. I have both an rc.d and init.d folder. The rcx.d folders (x=run level) just contains symlinks to init.d to make sure the scripts are run in the right order. Running grep fsck * in init.d, doesn't give me much. I have a reference in the functions file and after checking it I'm pretty sure that isn't the culprit. The rest of the references are in the halt script, which definitely isn't called in startup.

Does anyone know much about the /proc/mounts or /proc/self/mounts file? It seems like there may be something to that file. However, I haven't been able to find any information about the syntax of that file in searches or any documentation that I've found.
 
Old 08-16-2005, 12:25 PM   #5
springshades
Member
 
Registered: Nov 2004
Location: Near Lansing, MI , USA
Distribution: Mainly just Mandriva these days.
Posts: 304

Original Poster
Rep: Reputation: 30
Well, I didn't find this out right away, but the issue was in a file called rc.sysinit. I didn't find this right away because it was one of the few scripts not in init.d. So, what I can figure is the only way to turn this off is to get the fastboot variable set to off? I've done this by adding a line to rc.local because I can't find the config file that's actually SUPPOSED to do it.

_RUN_QUOTACHECK=0
# Check filesystems
# (pixel) do not check loopback files, will be done later (aren't available yet)
if [ -z "$fastboot" ]; then
gprintf "Checking filesystems\n"
Fsck -T -R -A -a -t noopts=loop $fsckoptions
fi

Only thing is that this seems to disable root system file check at every boot as well (as well as some other checks). These might actually be necessary checks, not sure. I really wish that I'd found some way to do this besides manually "cheating" because someone with my amount of experience is very likely to break stuff. On the other hand though, boot up times in the range of 5-7 minutes (normal boot up time plus the nearly 5 minutes for file checks) are just unforgivable for a laptop.

Also, I'm not quite sure if I know how to use tune2fs. I read somewhere that it should not be used while the filesystem is mounted write. Does that mean that settings won't be saved if I run this from a normal run level? Perhaps I have to run it from run level 1 or something?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
filesystem check fails during boot quinnk Linux - Software 1 08-01-2004 09:27 AM
Filesystem check at bootime firestomper41 Mandriva 5 03-20-2004 11:07 AM
Boot disk; check. CD in drive; check. Doesn't work; check. Hal DamnSmallLinux 7 02-04-2004 02:10 AM
Filesystem check error during boot macisaac Red Hat 1 12-05-2003 02:44 AM
Check filesystem twantrd Linux - Newbie 4 03-26-2003 12:37 AM


All times are GMT -5. The time now is 05:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration