LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-26-2006, 03:41 PM   #1
verdeboy2k
Member
 
Registered: Jan 2004
Location: /dev/random
Distribution: Gentoo amd64, CrunchBang amd64
Posts: 350

Rep: Reputation: 32
fglrx driver error: failed to initlialize ASIC in kernel [Solved]


I recently installed the 8.25.18 ATI driver for my Radeon x1800 card sucessfully. I however, was using Xorg 6.8, and since I wanted to use Xvideo, I attempted to upgrade to Xorg 7.0, which failed to work. I reinstalled X.org 6.8, which worked fine with the VESA drivers, but when I tried to use the fglrx driver again I get this error:

[EE][fglrx] Failed to initialize ASIC in kernel.
and various unresolved symbols in fglrx_drv.o which I can't remember, posting this in Windows boot of same box.
...
Caught signal 11, aborting...

I have removed every trace of fglrx, Xorg, and all the config files, reinstalled from scratch, and it still doesn't work. Is there anything that I might have broken that I can't find?

EDIT: dmesg reported no errors, just the sucessful loading and unloading of fglrx.ko
System Specs:
Linux 2.6.16-gentoo-r7 (custom)
AMD Athlon 64 x2 2.4Ghz
2 GiB RAM
ATI Radeon x1800 xt 512MB (PCI-X)
LanParty UT nF4 Ultra-D
SoundBlaster Audigy 2 ZS

Last edited by verdeboy2k; 05-27-2006 at 06:46 PM.
 
Old 05-27-2006, 07:36 AM   #2
verdeboy2k
Member
 
Registered: Jan 2004
Location: /dev/random
Distribution: Gentoo amd64, CrunchBang amd64
Posts: 350

Original Poster
Rep: Reputation: 32
UPDATE: After more tries to get this working, X will not start at all, even from a fresh install unless its run as root.
 
Old 05-27-2006, 06:47 PM   #3
verdeboy2k
Member
 
Registered: Jan 2004
Location: /dev/random
Distribution: Gentoo amd64, CrunchBang amd64
Posts: 350

Original Poster
Rep: Reputation: 32
Finally got X11R7 to install, so no longer an issue
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
checking for ati fglrx kernel module...........failed MicahCarrick Linux - Hardware 1 05-06-2005 01:50 PM
kernel: APIC error on CPU1: 02(02) Cronjob Linux - Hardware 1 03-22-2005 09:24 PM
Kernel: APIC error on CPU - What to do? robberttheman Linux - Hardware 6 01-26-2005 02:03 PM
APIC error on CPU0: 00(02) on a dual athlon running SMP kernel asalford Linux - Hardware 0 08-30-2004 11:23 PM
Kernel compile error/system hangs, APIC/ACPI taids Linux - Hardware 14 08-23-2003 06:11 AM


All times are GMT -5. The time now is 03:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration