LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-21-2009, 06:25 PM   #1
yourweb
LQ Newbie
 
Registered: Jun 2009
Posts: 3

Rep: Reputation: 0
ffmpeg thumbnail problem


I have installed FFmpeg and videos are converted like it should be, but the problem is when I want to create a thumbnail I get always something as this: http://pic.filehostserver.eu/view/1305/

When I use mplayer I get this:
Error opening/initializing the selected video_out (-vo) device.

With this command: mplayer /home/vid.avi -ss 1 -nosound -vo jpegutdir=thumbs -frames 3

The command mplayer -vo help returns this:
MPlayer SVN-r29543-4.1.2 (C) 2000-2009 MPlayer Team
Available video output drivers:
fbdev Framebuffer Device
fbdev2 Framebuffer Device
cvidix console VIDIX
null Null video output
mpegpes MPEG-PES to DVB card
yuv4mpeg yuv4mpeg output for mjpegtools
tga Targa output
pnm PPM/PGM/PGMYUV file
md5sum md5sum of each frame


So the Jpeg is not installed, but how can I install this? Or how can I make it work to create thumbnails with ffmpeg?
 
Old 08-23-2009, 02:38 PM   #2
John VV
Guru
 
Registered: Aug 2005
Posts: 12,920

Rep: Reputation: 1716Reputation: 1716Reputation: 1716Reputation: 1716Reputation: 1716Reputation: 1716Reputation: 1716Reputation: 1716Reputation: 1716Reputation: 1716Reputation: 1716
letting us KNOW what distro you are using would help
jpg support IS INSTALLED no matter what distro you are using

also informing us adout your hardware will help , as in what is your 3d card -- if you have one -- ?
 
Old 08-23-2009, 02:50 PM   #3
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
what command did you use for ffmpeg ?

This should work:

Code:
 ffmpeg -i movie.avi test.jpg
you can also try '-f image2 -vcodec mjpeg' as options if the above doesn't work.
 
  


Reply

Tags
ffmpeg, thumbnail


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help me in installing ffmpeg, ffmpeg-PHP, Mplayer, Mencoder, flv2tool, LAME MP3 Encod mitesh.ever Red Hat 5 05-16-2009 12:14 PM
ffmpeg problem mkhan919 Linux - Newbie 5 09-24-2008 04:03 PM
Does the latest version of ffmpeg not work with ffmpeg-php? whitey4900 Linux - Software 0 08-04-2008 05:16 PM
Digikam-0.80 thumbnail display problem ssenuta Linux - Software 0 04-12-2007 10:19 PM


All times are GMT -5. The time now is 12:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration