LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Fedora Distro Upgrade broke ALSA (http://www.linuxquestions.org/questions/linux-software-2/fedora-distro-upgrade-broke-alsa-873216/)

newton21989 04-05-2011 06:54 PM

Fedora Distro Upgrade broke ALSA
 
Getting sound to work in Linux has been nearly impossible since I upgraded from Ubuntu Jaunty to Karmic. I finally had it working for about 6 months in Fedora 12, then I upgraded to 14. </rant>

When I install pulse, I can hear the login sound on KDE, and the KDE error sounds, and that's it. I can't even hear sounds from the test button in the Phonon settings. With ALSA alone, I get absolutely nothing. I've already been through this which was minimal help.

I'm out of gas. Help, please?

Here's the output from alsa-info:
http://www.alsa-project.org/db/?f=3c...c659f2338f5541

newton21989 04-05-2011 07:56 PM

Okay, I think I got it fixed now. For one, the alsa-drivers package was not installed (Why? IDFK), so I did that.
Code:

yum install alsa-drivers
Then I got rid of pulse (again).
Code:

rpm -e --nodeps pulseaudio
(I've got things that say they need pulse, but work just fine without it, ex. MythTV)

Then, copy-pasta'd from http://fedoraunity.org/Members/fenri...nd-workarounds (See under "To Completely Remove PulseAudio") into ~/.asoundrc
Code:

# For details, see http://www.alsa-project.org/main/index.php/Asoundrc
pcm.!default {
        type plug
        slave.pcm "dmixer"
}

# cat /proc/asound/cards to see which hardware device
pcm.dmixer  {
        type dmix
        ipc_key 1024
        slave {
                pcm "hw:0,0"
                period_time 0
                period_size 1024
                buffer_size 4096
                rate 44100
        }
        bindings {
                0 0
                1 1
        }
}

ctl.dmixer {
        type hw
        card 0
}

Finally, Ctrl + Alt + Backspace and...

Success!

EDIT: Also, go into Phonon settings and make GStreamer the default backend, and "default" and the default device for everything.


All times are GMT -5. The time now is 01:31 AM.