LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   fedora 11 choppy audio (http://www.linuxquestions.org/questions/linux-software-2/fedora-11-choppy-audio-734023/)

Akheron 06-18-2009 06:41 PM

fedora 11 choppy audio
 
hey everyone, just installed fedora and updated it and ive run into a problem. whenever i play music, if i do absolutely anything such as close/open a window, launch an app, move focus away from a window etc. my audio skips. im pretty certian it has to do with pulseaudio because when i disable it (pulseaudio -k) everythings fine but id like to keep it running because i need the mixer that goes with it.

lsmod output:

Code:

snd_hda_codec_conexant    33312  1
snd_hda_intel          29000  1
snd_hda_codec          65376  2 snd_hda_codec_conexant,snd_hda_intel
snd_hwdep              8600  1 snd_hda_codec
snd_pcm                79960  2 snd_hda_intel,snd_hda_codec
snd_timer              22496  1 snd_pcm
snd                    65096  8 snd_hda_codec_conexant,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
soundcore              7024  1 snd
snd_page_alloc          9216  2 snd_hda_intel,snd_pcm

pulseaudio conf dump output:
Code:

/etc/pulse/daemon.conf ###
daemonize = no
fail = yes
high-priority = no
nice-level = -11
realtime-scheduling = no
realtime-priority = 5
disallow-module-loading = no
disallow-exit = no
use-pid-file = yes
system-instance = no
no-cpu-limit = no
disable-shm = no
flat-volumes = yes
exit-idle-time = 20
scache-idle-time = 20
dl-search-path = /usr/lib64/pulse-0.9.15/modules/
default-script-file = /etc/pulse/default.pa
load-default-script-file = yes
log-target = auto
log-level = notice
resample-method = auto
disable-remixing = no
disable-lfe-remixing = yes
default-sample-format = s16le
default-sample-rate = 44100
default-sample-channels = 2
default-channel-map = front-left,front-right
default-fragments = 4
default-fragment-size-msec = 25
shm-size-bytes = 0
log-meta = no
log-time = no
log-backtrace = 0
rlimit-fsize = -1
rlimit-data = -1
rlimit-stack = -1
rlimit-core = -1
rlimit-rss = -1
rlimit-as = -1
rlimit-nproc = -1
rlimit-nofile = 256
rlimit-memlock = -1
rlimit-locks = -1
rlimit-sigpending = -1
rlimit-msgqueue = -1
rlimit-nice = 31
rlimit-rtprio = 9
rlimit-rttime = 1000000

any help would be greatly appreciated! you guys have been awesome helping me in my other posts. I thank you very much!

amani 06-19-2009 11:37 AM

high-priority=yes


check with system monitor... do you have very limited RAM?


Kmixer

Akheron 06-19-2009 04:05 PM

I have 2gb which should be enough, especially for linux.

allele 06-24-2009 03:51 PM

I have exactly the same problem.

R3353 06-25-2009 03:28 AM

written for FC10, but worked for me in 11.

http://forums.fedoraforum.org/showth...problems+sound

allele 06-25-2009 01:39 PM

I think that method fixed it. In my case I had to keep the tsched=0 line, but that doesn't seem to have caused me any problems yet.


All times are GMT -5. The time now is 06:14 PM.