LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-08-2005, 11:52 AM   #1
whencat
Member
 
Registered: Aug 2003
Location: Pondicherry,India
Distribution: Fedora Core 3, RedHat 9.0, SUSE 8.1 Personal,
Posts: 49

Rep: Reputation: 15
FC3:Sound stopped working in all installed kernels after compiling 2.6.13-ck2 kernel


Hi,

In the pursuit of tweaking my machine to the extreme i patched my already "bleeding edge kernel" [as everyone says!!] with Con Kolivas patches.



vanilla kernel version = 2.6.13

patched version = 2.6.13-ck2

Distro = FC3







Yes the system response was VERY discernable.The system flies like a breeze.....but it introduced a big trouble.



Sound has stopped dead.



1.None of the applications play sound [xmms,noatun,mplayer....]

2.The 'system-config-soundcard' fails to play any sound although it detects my sound card.

3.All the alsa/soundcore modules have loaded properly.

4.alsamixer works fine and all the req channels are unmuted.

5.Sound plays fine in Windows.....

6.****Sound has stopped working in all other working kernels i had before****,namely,



the default distro kernel = 2.6.9-1.667

another vanilla kernel i compiled sometime back = 2.6.12



Sound played fine in the above 2 before the ck patched kernel played havoc.....



Please help me on wat cud be wrong :-



1. Has the newly installed kernel corrupted alsa sound system ? [it seemingly works fine except that it does'nt produce sound ??!!!]



2. Or has the alsa modules been corrupted ? [But all req. modules do load correctly]



3.Am I missing something very basic ??



lsmod output
-------------------
Module Size Used by
autofs4 19204 1
sunrpc 138308 1
ipt_REJECT 5760 1
ipt_state 1920 1
ip_conntrack 41784 1 ipt_state
iptable_filter 2944 1
ip_tables 21504 3 ipt_REJECT,ipt_state,iptable_filter
nls_utf8 2176 4
dm_mod 52540 0
video 15492 0
button 6672 0
i2c_i801 8716 0
i2c_core 20624 1 i2c_i801
snd_intel8x0 31552 0
snd_ac97_codec 76284 1 snd_intel8x0
snd_pcm 85128 2 snd_intel8x0,snd_ac97_codec
snd_timer 24196 1 snd_pcm
snd 46264 4 snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
soundcore 9696 1 snd
snd_page_alloc 10248 2 snd_intel8x0,snd_pcm
floppy 57044 0
.................................................................................................... ...............................................................
Any help is greatly appreciated..........
 
Old 09-09-2005, 03:22 AM   #2
whencat
Member
 
Registered: Aug 2003
Location: Pondicherry,India
Distribution: Fedora Core 3, RedHat 9.0, SUSE 8.1 Personal,
Posts: 49

Original Poster
Rep: Reputation: 15
Yahooooooooooo
I just got out of this frustrating problem after doing painstaking (re)search. The solution is amazingly simple.Anyone who is experiencing such a problem plz make a note :-
Just mute [or switch off] the following two in alsamixer [or any other mixer you use]:

1.Headphone Jack Sense [plz switch off ]
2.Line Jack Sense. [plz switch off]

It seems ALSA implementation of Jack Sensing technology is not complete. Or atleast it has problems with intel audio controllers. I don't know if this is the real reason.......but it seems very probable.

I'm so happy now.........
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
some appz and sound card stopped working when did upgrade on the kernel golpemortal Fedora 9 05-07-2005 11:04 PM
Installed USB2.0 card - sound stopped working DJOtaku Linux - Hardware 0 02-18-2005 01:23 AM
Sound randomly stopped working- FC3 Yakolev Linux - Software 2 01-21-2005 03:44 PM
Sound stopped working, FC3 onepapership Linux - Hardware 1 11-30-2004 01:29 PM
Sound on A7V880 stopped working after reboot of FC3 Coda Fedora 4 11-17-2004 05:47 PM


All times are GMT -5. The time now is 01:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration