LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-29-2011, 07:30 AM   #1
gkasica
Member
 
Registered: Jan 2011
Location: Jackson WI
Distribution: Fedora Core/Generic
Posts: 54

Rep: Reputation: 0
FC 15 will not boot after upgrade kernel panic?


Finished a successful preupgrade from FC 14 to FC15 but now the system fails to boot the new FC15 kernel 2.6.38.6-27.fc15.i686 and leave me with a flashing Caps and Scroll Lock key lights. Hitting any key on te keyborad causes the entire system to freeze and needs a power off and on to restart it.

How do I resolve this issue? Screen photo of the boot up error attached.

grub.conf below:

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/hda3
# initrd /initrd-version.img
#boot=/dev/hda
#
timeout=15
default 0
#fallback 1
fallback 2
#
splashimage=(hd0,0)/grub/splash.xpm.gz
# hiddenmenu
#
title Fedora (2.6.38.6-27.fc15.i686)
root (hd0,0)
kernel /vmlinuz-2.6.38.6-27.fc15.i686 ro root=LABEL=/root rhgb quiet resume=/dev/sda2 SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8 KEYTABLE=us rootfstype=ext4
title Fedora (2.6.35.13-91.fc14.i686)
root (hd0,0)
kernel /vmlinuz-2.6.35.13-91.fc14.i686 ro root=LABEL=/root rhgb quiet resume=/dev/sda2 SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8 KEYTABLE=us rootfstype=ext4
initrd /initramfs-2.6.35.13-91.fc14.i686.img
title Fedora (2.6.35.12-90.fc14.i686)
root (hd0,0)
kernel /vmlinuz-2.6.35.12-90.fc14.i686 ro root=LABEL=/root rhgb quiet resume=/dev/sda2 SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8 KEYTABLE=us rootfstype=ext4
initrd /initramfs-2.6.35.12-90.fc14.i686.img


Thanks,
George
Attached Images
File Type: jpg FC15 error.jpg (97.5 KB, 10 views)

Last edited by gkasica; 05-29-2011 at 08:35 AM.
 
Old 05-29-2011, 01:46 PM   #2
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Looks like you need to create an initrd for the new kernel... Boot into one of the older kernels and create the initrd.

Adam
 
Old 05-29-2011, 01:54 PM   #3
gkasica
Member
 
Registered: Jan 2011
Location: Jackson WI
Distribution: Fedora Core/Generic
Posts: 54

Original Poster
Rep: Reputation: 0
The other kernels will not boot any longer. The server hangs while it's booting. I CAN boot the FC15 live cd though can I do it from that and can you detail the process as I've never done this before and also there is an initrd-plymouth.img there. Is that usable?
 
Old 05-29-2011, 02:22 PM   #4
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
I doubt that it is, but I'm really not sure whether initrd-plymouth.img will work. I have my doubts. I know that you can't use root=UUID in grub withot an initrd, and I'm guessing the same is true for root=LABEL either.
 
Old 05-29-2011, 02:26 PM   #5
gkasica
Member
 
Registered: Jan 2011
Location: Jackson WI
Distribution: Fedora Core/Generic
Posts: 54

Original Poster
Rep: Reputation: 0
So what would be the steps to do this when booting from the liveCD?
 
Old 05-29-2011, 02:27 PM   #6
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Not really sure when it comes to Fedora. Boot off the LiveCD, mount your local Fedora installation, chroot into it, and then check out the man page for mkinitrd :-)

Adam
 
Old 05-29-2011, 02:51 PM   #7
gkasica
Member
 
Registered: Jan 2011
Location: Jackson WI
Distribution: Fedora Core/Generic
Posts: 54

Original Poster
Rep: Reputation: 0
The man page mentions many options - what type or set of options am I going to need here?
 
Old 05-29-2011, 02:52 PM   #8
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Again, I'm not sure when it comes to Fedora. I use Slackware, and I know that mkinitrd on Slackware is very different from Fedora.

EDIT: Well, I do have F15 installed, but I'm not booted into it at the moment, have only used it briefly, and never had to use mkinitrd on it.

Adam

Last edited by adamk75; 05-29-2011 at 03:03 PM.
 
Old 05-29-2011, 03:15 PM   #9
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, Ubuntu, SLES, CentOS
Posts: 1,790

Rep: Reputation: 324Reputation: 324Reputation: 324Reputation: 324
@ Reply

1. Use the live CD to boot Fedora15.
2. Go into boot directory
3. Before creating image file I would like you to check whether any image file already in use. To check that run following command:

mkinitrd --version

If nothing comes up. Go ahead with step 4. Else let us know the output.

4. Run the following command:

mkinitrd --fstab=/etc/fstab --image-version

Last edited by T3RM1NVT0R; 05-29-2011 at 03:16 PM.
 
Old 05-29-2011, 03:36 PM   #10
gkasica
Member
 
Registered: Jan 2011
Location: Jackson WI
Distribution: Fedora Core/Generic
Posts: 54

Original Poster
Rep: Reputation: 0
The hard disk boot directory is mounted under /media/_boot when booting from the CD. do you want those commands run in that location or sinewhere else? There is a file there called initrd-plymouth.img

The command run from there gives
mkinitrd: dracut compatibility wrapper
 
Old 05-29-2011, 03:45 PM   #11
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, Ubuntu, SLES, CentOS
Posts: 1,790

Rep: Reputation: 324Reputation: 324Reputation: 324Reputation: 324
@ Reply

The one that you are looking at is for the live CD.

Here is the step by step procedure:

1. Boot using live CD.
2. Open up console.
3. df -h and see if you see your system's boot directory there. If yes then cd /boot
4. Check if you see any image file in there. If yes let us know which image file you see there.
5. If not then continue with the creation of one using the command mentioned before.
6. After creation of image file, add the following line in /boot/grub/grub.conf:

Code:
title Fedora (2.6.38.6-27.fc15.i686) will be there already
root (hd0,0) will be there already
kernel /vmlinuz-2.6.38.6-27.fc15.i686 ro root=LABEL=/root rhgb quiet resume=/dev/sda2 SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8 KEYTABLE=us rootfstype=ext4 will be there already
initrd /name_of_the_newly_create_image_file Add this one.
You can check the syntax with the initrd given for Fedora 14 in the same file. Just check your first post in which you mentioned that.

Edit: You can also create initial RAMFS for your kernel using this command: mkinitrd vmlinuz-2.6.38.6-27.fc15.i686

Last edited by T3RM1NVT0R; 05-29-2011 at 03:50 PM.
 
Old 05-29-2011, 04:07 PM   #12
gkasica
Member
 
Registered: Jan 2011
Location: Jackson WI
Distribution: Fedora Core/Generic
Posts: 54

Original Poster
Rep: Reputation: 0
As root now - I do not see a /boot directory only the /media/_boot one. But I can cd into /boot
and there is no image file there. Running
mkinitrd --fstab=/etc/fstab --image-version.
From there gives me the syntax usage output but no img file
Similar results from /media/_boot when substituting /media/_root/etc/fstab

Last edited by gkasica; 05-29-2011 at 04:08 PM.
 
Old 05-29-2011, 04:08 PM   #13
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, Ubuntu, SLES, CentOS
Posts: 1,790

Rep: Reputation: 324Reputation: 324Reputation: 324Reputation: 324
@ Reply

cd into /boot

and

Run this: mkinitrd vmlinuz-2.6.38.6-27.fc15.i686

Make sure that you edit /boot/grub/grub.conf to reflect the changes.
 
Old 05-29-2011, 04:10 PM   #14
gkasica
Member
 
Registered: Jan 2011
Location: Jackson WI
Distribution: Fedora Core/Generic
Posts: 54

Original Poster
Rep: Reputation: 0
Still gives the usage output as before

also there is not /boot/grub/grub.conf to edit just the one in /media/_boot/grub/grub.conf

Last edited by gkasica; 05-29-2011 at 04:13 PM.
 
Old 05-29-2011, 04:28 PM   #15
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, Ubuntu, SLES, CentOS
Posts: 1,790

Rep: Reputation: 324Reputation: 324Reputation: 324Reputation: 324
@ Reply

From where did you get the grub.conf file which you pasted above?

Are you able to boot any of the OS F14 or F15 in single user mode? If yes, then don't boot it from boot CD instead try these commands from single user mode.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
upgrade > kernel panic solly Arch 5 12-24-2008 12:00 PM
Kernel panic after upgrade jaristr Linux - Kernel 7 11-28-2006 05:43 AM
Dist-Upgrade = Kernel Panic carlosinfl Debian 4 10-18-2006 02:39 PM
pacman -Su, kernel upgrade, kernel panic, change distro? jkh Arch 35 03-10-2006 01:14 AM


All times are GMT -5. The time now is 07:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration