LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   FC 15 will not boot after upgrade kernel panic? (http://www.linuxquestions.org/questions/linux-software-2/fc-15-will-not-boot-after-upgrade-kernel-panic-883329/)

gkasica 05-29-2011 08:30 AM

FC 15 will not boot after upgrade kernel panic?
 
1 Attachment(s)
Finished a successful preupgrade from FC 14 to FC15 but now the system fails to boot the new FC15 kernel 2.6.38.6-27.fc15.i686 and leave me with a flashing Caps and Scroll Lock key lights. Hitting any key on te keyborad causes the entire system to freeze and needs a power off and on to restart it.

How do I resolve this issue? Screen photo of the boot up error attached.

grub.conf below:

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/hda3
# initrd /initrd-version.img
#boot=/dev/hda
#
timeout=15
default 0
#fallback 1
fallback 2
#
splashimage=(hd0,0)/grub/splash.xpm.gz
# hiddenmenu
#
title Fedora (2.6.38.6-27.fc15.i686)
root (hd0,0)
kernel /vmlinuz-2.6.38.6-27.fc15.i686 ro root=LABEL=/root rhgb quiet resume=/dev/sda2 SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8 KEYTABLE=us rootfstype=ext4
title Fedora (2.6.35.13-91.fc14.i686)
root (hd0,0)
kernel /vmlinuz-2.6.35.13-91.fc14.i686 ro root=LABEL=/root rhgb quiet resume=/dev/sda2 SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8 KEYTABLE=us rootfstype=ext4
initrd /initramfs-2.6.35.13-91.fc14.i686.img
title Fedora (2.6.35.12-90.fc14.i686)
root (hd0,0)
kernel /vmlinuz-2.6.35.12-90.fc14.i686 ro root=LABEL=/root rhgb quiet resume=/dev/sda2 SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8 KEYTABLE=us rootfstype=ext4
initrd /initramfs-2.6.35.12-90.fc14.i686.img


Thanks,
George

adamk75 05-29-2011 02:46 PM

Looks like you need to create an initrd for the new kernel... Boot into one of the older kernels and create the initrd.

Adam

gkasica 05-29-2011 02:54 PM

The other kernels will not boot any longer. The server hangs while it's booting. I CAN boot the FC15 live cd though can I do it from that and can you detail the process as I've never done this before and also there is an initrd-plymouth.img there. Is that usable?

adamk75 05-29-2011 03:22 PM

I doubt that it is, but I'm really not sure whether initrd-plymouth.img will work. I have my doubts. I know that you can't use root=UUID in grub withot an initrd, and I'm guessing the same is true for root=LABEL either.

gkasica 05-29-2011 03:26 PM

So what would be the steps to do this when booting from the liveCD?

adamk75 05-29-2011 03:27 PM

Not really sure when it comes to Fedora. Boot off the LiveCD, mount your local Fedora installation, chroot into it, and then check out the man page for mkinitrd :-)

Adam

gkasica 05-29-2011 03:51 PM

The man page mentions many options - what type or set of options am I going to need here?

adamk75 05-29-2011 03:52 PM

Again, I'm not sure when it comes to Fedora. I use Slackware, and I know that mkinitrd on Slackware is very different from Fedora.

EDIT: Well, I do have F15 installed, but I'm not booted into it at the moment, have only used it briefly, and never had to use mkinitrd on it.

Adam

T3RM1NVT0R 05-29-2011 04:15 PM

@ Reply
 
1. Use the live CD to boot Fedora15.
2. Go into boot directory
3. Before creating image file I would like you to check whether any image file already in use. To check that run following command:

mkinitrd --version

If nothing comes up. Go ahead with step 4. Else let us know the output.

4. Run the following command:

mkinitrd --fstab=/etc/fstab --image-version

gkasica 05-29-2011 04:36 PM

The hard disk boot directory is mounted under /media/_boot when booting from the CD. do you want those commands run in that location or sinewhere else? There is a file there called initrd-plymouth.img

The command run from there gives
mkinitrd: dracut compatibility wrapper

T3RM1NVT0R 05-29-2011 04:45 PM

@ Reply
 
The one that you are looking at is for the live CD.

Here is the step by step procedure:

1. Boot using live CD.
2. Open up console.
3. df -h and see if you see your system's boot directory there. If yes then cd /boot
4. Check if you see any image file in there. If yes let us know which image file you see there.
5. If not then continue with the creation of one using the command mentioned before.
6. After creation of image file, add the following line in /boot/grub/grub.conf:

Code:

title Fedora (2.6.38.6-27.fc15.i686) will be there already
root (hd0,0) will be there already
kernel /vmlinuz-2.6.38.6-27.fc15.i686 ro root=LABEL=/root rhgb quiet resume=/dev/sda2 SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8 KEYTABLE=us rootfstype=ext4 will be there already
initrd /name_of_the_newly_create_image_file Add this one.

You can check the syntax with the initrd given for Fedora 14 in the same file. Just check your first post in which you mentioned that.

Edit: You can also create initial RAMFS for your kernel using this command: mkinitrd vmlinuz-2.6.38.6-27.fc15.i686

gkasica 05-29-2011 05:07 PM

As root now - I do not see a /boot directory only the /media/_boot one. But I can cd into /boot
and there is no image file there. Running
mkinitrd --fstab=/etc/fstab --image-version.
From there gives me the syntax usage output but no img file
Similar results from /media/_boot when substituting /media/_root/etc/fstab

T3RM1NVT0R 05-29-2011 05:08 PM

@ Reply
 
cd into /boot

and

Run this: mkinitrd vmlinuz-2.6.38.6-27.fc15.i686

Make sure that you edit /boot/grub/grub.conf to reflect the changes.

gkasica 05-29-2011 05:10 PM

Still gives the usage output as before

also there is not /boot/grub/grub.conf to edit just the one in /media/_boot/grub/grub.conf

T3RM1NVT0R 05-29-2011 05:28 PM

@ Reply
 
From where did you get the grub.conf file which you pasted above?

Are you able to boot any of the OS F14 or F15 in single user mode? If yes, then don't boot it from boot CD instead try these commands from single user mode.


All times are GMT -5. The time now is 09:55 AM.