LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-10-2003, 06:02 PM   #1
InsaneBob
Member
 
Registered: Mar 2003
Posts: 105

Rep: Reputation: 15
fat32 partition


I am trying to mount a fat32 partition and here is the line I put in fstab "/dev/hda4 /fat32 vfat auto,umask=777". The problem is when I log in as just a normal user and try to access /fat32 I get the following error "bash: cd: /fat32: Permisssion denied". Also I have noticed that the other entries have two numbers on the end and I was wonder what they were for. One more question that is slightly off topic. With vim I know you push i to inserted characters before the highlighted character but how do you inserted afterward.
 
Old 08-10-2003, 06:08 PM   #2
Riley
Member
 
Registered: Feb 2003
Location: SC, USA
Distribution: Mandrake 10.0 Powerpack
Posts: 178

Rep: Reputation: 30
you need to chmod the /fat32 dir so that others can open it. If you're using a gui you can probably change the permissions with a file manager.

For your second question post the lines you're talking about and we'll explain them to you.

I know in vi you just press i and then you can move the cursor to insert characters after the highlighted character. I'm pretty sure it's going to be the same in vim also unless I'm misunderstanding your question.
 
Old 08-10-2003, 06:10 PM   #3
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
well seeing as umask=777 means that noone is allowed to access the files at all... try 022, or 002 instead
 
Old 08-10-2003, 06:55 PM   #4
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Acid's right.

chmod and umask values work in an "opposite" way

chmod 777

Will give you rwx permissions for owner, group and other

umask 000 is "equivalent" - you use umask in an /etc/fstab entry -
So umask=000 would be sufficient.

The last two fields in a typical /etc/fstab entry mean :

The 5th field indicates whether the filesystem should be included in a back-up.

The 6th Field indicates how the filesystem should be checked on boot up.

Use 0 0 for a Windows entry.

Last edited by Skyline; 08-10-2003 at 06:59 PM.
 
Old 08-10-2003, 08:20 PM   #5
InsaneBob
Member
 
Registered: Mar 2003
Posts: 105

Original Poster
Rep: Reputation: 15
Ya that work just right. I wonder why it would be opposite like that?
 
Old 08-10-2003, 08:24 PM   #6
InsaneBob
Member
 
Registered: Mar 2003
Posts: 105

Original Poster
Rep: Reputation: 15
One more thing if I wanted read only for my xp partition I could use the option ro or umask=333 right?
 
Old 08-10-2003, 08:53 PM   #7
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Correct - umask=333 gives read only for owner,group,other
 
Old 08-10-2003, 09:40 PM   #8
InsaneBob
Member
 
Registered: Mar 2003
Posts: 105

Original Poster
Rep: Reputation: 15
This is what I put into fstab for my xp partition:
/dev/hda1 /xp ntfs auto,umask=333 0 0
When I try to access it as a normal user I get the same error as before:
bash: cd: /xp: Permission denied
I want /xp to be read only because last I heard ntfs was still experimental with writing.
 
Old 08-10-2003, 11:36 PM   #9
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
Just an idea - but why not create a mount point in /mnt using mkdir

ie say

mkdir /mnt/winxp

then use this - substituting the various fields in

ie your Partition, Mount point and User ID Number ( uid ) in place of my example ones

/dev/hda1 /mnt/winxp ntfs auto,ro,umask=222,uid=501 0 0

You can get your User ID Number by getting to the command line and typing:

id username (substitute username with Aaron or Sofie or whatever your username is)

look for the

uid=xxx - thats your user id number

Last edited by Skyline; 08-10-2003 at 11:51 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to format to FAT32, and how to mount my FAT32 partition. bonniehandi Linux - Newbie 16 03-05-2006 08:54 PM
accessing a linux partition from a fat32 partition? abtimoteo Ubuntu 4 09-19-2005 11:41 PM
Fat32 Partition notregistered Linux - General 4 08-12-2005 03:48 PM
Partition mounting/KDE errors after creating Fat32 Partition BertBert Linux - General 1 07-07-2004 11:59 AM
Formating a FAT32 partition, putting the partition correctly into FSTAB, and more. squall14716 Linux - General 14 10-27-2003 11:16 PM


All times are GMT -5. The time now is 07:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration