LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-02-2004, 06:54 PM   #1
doralsoral
Member
 
Registered: Aug 2003
Location: raleigh
Distribution: Gentoo 2005.1 x86_64
Posts: 931

Rep: Reputation: 31
Fat partition permissions


ok ive got a fat partition mounted on my slackbox and i can access it when im root but when i switch to a regular user there is a lock icon over the directory and it wont even let me change thepermissions as root. i can only read it. any idea how i can make it so i can read write and execute for a regular user?
 
Old 02-02-2004, 06:59 PM   #2
snacky
Member
 
Registered: Feb 2004
Distribution: Debian
Posts: 286

Rep: Reputation: 30
This will let all regular users read it:

As root, unmount the filesystem. Edit /etc/fstab and add "user" as one of the options for the entry for your fat partition. Then remount it. Permanently fixed.
 
Old 02-02-2004, 07:30 PM   #3
doralsoral
Member
 
Registered: Aug 2003
Location: raleigh
Distribution: Gentoo 2005.1 x86_64
Posts: 931

Original Poster
Rep: Reputation: 31
ok what exactly should the entry look like, i still cant get it to work, i want them to be able to write and execute it too. right now i can read it but i cant execute any of the directories within it
 
Old 02-02-2004, 07:37 PM   #4
snacky
Member
 
Registered: Feb 2004
Distribution: Debian
Posts: 286

Rep: Reputation: 30
Well, this works fine for me:

Code:
/dev/hda1       /mnt/stuff        vfat               0       0
But you can also add options - which would appear after vfat - if that doesn't work.

mode=0655 as one of the options would guarantee everyone can get in.

man mount for more options.
 
Old 02-02-2004, 07:42 PM   #5
doralsoral
Member
 
Registered: Aug 2003
Location: raleigh
Distribution: Gentoo 2005.1 x86_64
Posts: 931

Original Poster
Rep: Reputation: 31
well i had this to begin with

/dev/hda5 /home/frenchy/winblows vfat defaults 0 0

i tried putting user instead of defaults and even user,rw but i still get nothing.
 
Old 02-02-2004, 07:48 PM   #6
snacky
Member
 
Registered: Feb 2004
Distribution: Debian
Posts: 286

Rep: Reputation: 30
Take out the options and make it mode=0655 and every user can read it.
 
Old 02-02-2004, 07:52 PM   #7
doralsoral
Member
 
Registered: Aug 2003
Location: raleigh
Distribution: Gentoo 2005.1 x86_64
Posts: 931

Original Poster
Rep: Reputation: 31
i did that, do i need to reboot
 
Old 02-02-2004, 07:55 PM   #8
snacky
Member
 
Registered: Feb 2004
Distribution: Debian
Posts: 286

Rep: Reputation: 30
No. Remount: umount then mount the partition. It should work immediately.
 
Old 02-02-2004, 07:57 PM   #9
r_jensen11
Senior Member
 
Registered: Apr 2003
Location: Minnesota, USA
Distribution: Slack 10.0 w/2.4.26
Posts: 1,032

Rep: Reputation: 45
did you umount and then remount?
 
Old 02-02-2004, 08:02 PM   #10
doralsoral
Member
 
Registered: Aug 2003
Location: raleigh
Distribution: Gentoo 2005.1 x86_64
Posts: 931

Original Poster
Rep: Reputation: 31
yes i did
 
Old 02-02-2004, 08:13 PM   #11
doralsoral
Member
 
Registered: Aug 2003
Location: raleigh
Distribution: Gentoo 2005.1 x86_64
Posts: 931

Original Poster
Rep: Reputation: 31
hey if youd like you can IM on gaim if you have it my screen name is Don Frenchiano id be your best friend forever
 
Old 02-04-2004, 11:50 AM   #12
doralsoral
Member
 
Registered: Aug 2003
Location: raleigh
Distribution: Gentoo 2005.1 x86_64
Posts: 931

Original Poster
Rep: Reputation: 31
hey this is for snacky i think, i talked to you on gaim, just wanted to let you know that i got it working, all i had to do was add umask=000 as an option in fstab and thats all.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
FAT 32 access permissions problem gilbertt Linux - Hardware 8 11-10-2005 02:01 PM
/fat-c permissions Hectic Slackware 3 10-18-2004 09:39 PM
folder permissions /fat-c Hectic Linux - Newbie 2 10-17-2004 02:08 AM
/fat-c permissions in fstab Ops Slackware 2 07-08-2004 11:43 AM
fat drive permissions problem llimllib Linux - General 2 07-18-2003 08:51 PM


All times are GMT -5. The time now is 03:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration