LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-17-2003, 08:13 PM   #1
GT_Onizuka
Member
 
Registered: Aug 2003
Location: Atlanta
Distribution: Debian, OS X
Posts: 711

Rep: Reputation: 30
Unhappy FakeNES won't install


I downloaded an older version of FakeNES on accident and installed it. I was able to run it sortof okay but whenever I closed it, the program would have a segmentation fault and all my settings would get erased. When i found out i had an old version I downloaded the latest 0.3.0. I downloaded it and everything and then did ./configure and all went well. It then said do "make install" rather then make && make install, so i typed make install and this is the error it gives me.

Quote:
[root@localhost fakenes-0.3.0]# make install
cd src && /usr/bin/make install
make[1]: Entering directory `/home/ynadji/fakenes-0.3.0/src'
gcc -c gui.c -o gui.o `allegro-config --cflags` -Iinclude/ -Isupport/ -g -O2 -DUSE_ZLIB -DUSE_HAWKNL -DLSB_FIRST -DPOSIX -DNO_C_CORE
gui.c: In function `update_menus':
gui.c:721: `GFX_SVGALIB' undeclared (first use in this function)
gui.c:721: (Each undeclared identifier is reported only once
gui.c:721: for each function it appears in.)
gui.c: In function `options_video_driver_linux_menu_svgalib':
gui.c:3243: `GFX_SVGALIB' undeclared (first use in this function)
make[1]: *** [gui.o] Error 1
make[1]: Leaving directory `/home/ynadji/fakenes-0.3.0/src'
make: *** [install] Error 2
the only thing i can guess is it can't find allegro (the gaming program library FakeNES uses) i KNOW i installed it (i downloaded the newest tar.gz file the .rpm's are too old to work with FakeNES according to the FakeNES FAQ) and there wasn't a single problem with the installation of allegro. Could it be that FakeNES can't find allegro or something like that? I'm really confused and I'm sick of not being able to play NES games since the switch from Windoze (although my other emus work fine, but I need my Double Dragon 2 )
 
Old 10-18-2003, 11:00 AM   #2
GT_Onizuka
Member
 
Registered: Aug 2003
Location: Atlanta
Distribution: Debian, OS X
Posts: 711

Original Poster
Rep: Reputation: 30
anyone?
 
Old 10-18-2003, 11:03 AM   #3
wuck
Member
 
Registered: Sep 2003
Location: barneveld.nl
Distribution: Slackware
Posts: 170

Rep: Reputation: 30
Looks like either some bad coding, or maybe the absence of svgalib?
I like the idea of a NES emu, /me go get file.

Last edited by wuck; 10-18-2003 at 11:06 AM.
 
Old 10-18-2003, 11:30 AM   #4
GT_Onizuka
Member
 
Registered: Aug 2003
Location: Atlanta
Distribution: Debian, OS X
Posts: 711

Original Poster
Rep: Reputation: 30
gah still doesn't work after installing svgalib. also i tried 0.2.0 and it has the same error 0.1.5 did, i keep getting segfaults at the end and it doesn't save my preferences and i need to change a lot everytime since my sound card blows and i wanna play with mah joysticks ^_^
 
Old 10-18-2003, 12:12 PM   #5
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
I'm a linux newbie and I downloaded the tar.gz file. I extracted it then I sat there for a couple minutes and deleted the folder.

I don't know how to compile. lol
 
Old 10-18-2003, 12:48 PM   #6
GT_Onizuka
Member
 
Registered: Aug 2003
Location: Atlanta
Distribution: Debian, OS X
Posts: 711

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by Micro420
I'm a linux newbie and I downloaded the tar.gz file. I extracted it then I sat there for a couple minutes and deleted the folder.

I don't know how to compile. lol
well i can help you with that. after you extract the .tar.gz file, you will get a folder with the same name (minus the .tar.gz part that is). bust out a terminal and cd into that directory. for some reason, the people who made this prog didn't make the configure file with executable rights so you hafta do that yourself, no worries just do this.

$ chmod a+x configure

that makes it executable, now:

$ ./configure

this will configure it to your system, then (for this app most have you do 'make' first) do:

$ su
(to become root)
then:

$ make install

and that should do it for ya! tell me if it works for you, i can't get mine to install :P
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fc3 install doesnt install grub properly onto sata drive sabo Linux - Newbie 4 02-03-2007 04:04 PM
make install does not install daemons (clamd snortd). Is this a feature of tarball? Emmanuel_uk Linux - Newbie 3 11-15-2005 01:29 AM
Error: Unable to boot /install/2.6/linux when starting Etch Install BuckRogers01 Debian 4 08-06-2005 06:40 PM
Compiling Fakenes Kilahchris Linux - Software 3 06-27-2005 11:59 PM
How do I re-install an operatingsystem? Corrupted install. Yast wont load. URGENT.thx CrewXp Suse/Novell 5 05-09-2005 12:07 AM


All times are GMT -5. The time now is 09:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration