LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-12-2002, 12:34 PM   #1
tarballedtux
Member
 
Registered: Aug 2001
Location: Off the coast of Madadascar
Posts: 498

Rep: Reputation: 30
Failed to boot my box!


After trying building a new kernel I wasn't able to boot my new box. Below is an excerpt from the boot sequence. Just tell me what other information is needed to solve this problem.

Here's the error I get after the message
"Running LinuxConf hooks"

INIT: Id "1" respawning too fast: disable for 5 minutes.
INIT: Id "2" respawning too fast: disable for 5 minutes.
INIT: Id "3" respawning too fast: disable for 5 minutes.
INIT: Id "4" respawning too fast: disable for 5 minutes.
INIT: Id "5" respawning too fast: disable for 5 minutes.
INIT: no more processes left in this runlevel


--Thanks in advance
 
Old 07-12-2002, 12:58 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,536

Rep: Reputation: 148Reputation: 148
You have not compiled something that's important. It's hard to tell you what from this error. I hope you still have the old kernel? Use it and build a new one.
 
Old 07-12-2002, 06:39 PM   #3
tarballedtux
Member
 
Registered: Aug 2001
Location: Off the coast of Madadascar
Posts: 498

Original Poster
Rep: Reputation: 30
Maybe this is unrelated to the afformentioned problem, I am getting an error that occurs before that about /dev/tty0: not found. Here's the exact messgae.

Loading default keymap (us): /etc/rc.sysinit: /dev/tty0: No such file our directory

I fairly certain that tty's are important so how would enable them in the kernel config. I probabaly left them out of the kernel config since I was trying to cut out parts I didn't think were needed.


--Thanks
 
Old 07-12-2002, 07:01 PM   #4
pickledbeans
Member
 
Registered: Jun 2002
Location: Bailey, CO
Distribution: Slackware
Posts: 483

Rep: Reputation: 31
Quote:
Originally posted by tarballedtux

Loading default keymap (us): /etc/rc.sysinit: /dev/tty0: No such file our directory
--Thanks
Well is /dev/tty0 there or not?
 
Old 07-12-2002, 07:51 PM   #5
tarballedtux
Member
 
Registered: Aug 2001
Location: Off the coast of Madadascar
Posts: 498

Original Poster
Rep: Reputation: 30
It is there. I types ls /dev | grep tty | more in the old stock kernel.
 
Old 07-13-2002, 03:44 AM   #6
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,536

Rep: Reputation: 148Reputation: 148
It looks you have not included Input devices-> Virtual terminal
 
Old 07-13-2002, 09:56 AM   #7
tarballedtux
Member
 
Registered: Aug 2001
Location: Off the coast of Madadascar
Posts: 498

Original Poster
Rep: Reputation: 30
OK I got the /dev/tty problem fixed but now when I boot it seems like the root / and /boot are being mounted in read-only mode. I don't remember changing anything. Weird thing is, this didn't happen with the other problematic kernel.

--tarballedtux
 
Old 07-13-2002, 01:01 PM   #8
rootman147
Member
 
Registered: May 2002
Location: Hangon...find / -name location
Distribution: Slackware
Posts: 46

Rep: Reputation: 15
that is normal, fsck needs to check them, it is only a problem if they don't remount read-only
 
Old 07-13-2002, 01:43 PM   #9
tarballedtux
Member
 
Registered: Aug 2001
Location: Off the coast of Madadascar
Posts: 498

Original Poster
Rep: Reputation: 30
No, it is a problem. It stays read only and eventually fails to boot. A whole bunch of errors get spit out about "Can't do <such and such> because file-system is read-only"


--tarballedtux
 
Old 07-13-2002, 02:28 PM   #10
rootman147
Member
 
Registered: May 2002
Location: Hangon...find / -name location
Distribution: Slackware
Posts: 46

Rep: Reputation: 15
oh sorry man I misunderstood
 
Old 07-14-2002, 04:23 AM   #11
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,536

Rep: Reputation: 148Reputation: 148
Quote:
Originally posted by tarballedtux
No, it is a problem. It stays read only and eventually fails to boot. A whole bunch of errors get spit out about "Can't do <such and such> because file-system is read-only"
I must say I'm lost. Which kernel are you talking about? Do you have this problem only with new kernel or also with the old one(this one from your distro)?
 
Old 07-14-2002, 07:15 PM   #12
tarballedtux
Member
 
Registered: Aug 2001
Location: Off the coast of Madadascar
Posts: 498

Original Poster
Rep: Reputation: 30
OK, this problem is with the new kernel(2.4.18). The old stock kernel is fine(2.4.9-34). Do I have to upgrade something like inittab or rc.sysinit to get the new kernel going?

--tarballedtux
 
Old 07-15-2002, 02:38 AM   #13
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,536

Rep: Reputation: 148Reputation: 148
No, all configuration files are the same. When one kernel is booting OK and there are problems only with the other one, it's definitelly a matter of the kernel. I don't remember an option giving such an effect. Maybe check the filesystem part (what you have as modules, what is compiled into your kernel etc).
 
Old 07-15-2002, 09:15 AM   #14
tarballedtux
Member
 
Registered: Aug 2001
Location: Off the coast of Madadascar
Posts: 498

Original Poster
Rep: Reputation: 30
Here's the transcribed "Filesystem Config)

EXT3 journalling file system support (EXPERIMENTAL) -- built in
JBD (ext3) debugging support -- built in
DOS FAT fs support -- built in
MSDOS fs support -- built in
VFAT (Windows-95) fs support -- built in
Virtual memory file system support (former shm fs) -- built in
ISO 9660 CDROM file system support -- built in
Micosoft Joliet CDROM extentions -- built in
/proc file system support -- built in
/dev file system support -- built in
Automatically mount at boot -- built in (This talking about /dev)
/dev/pts file system for Unix98 PTYs -- built in
Second Extended fs support -- built in
UDF file system support (read-only) -- module

--> Network File Systems
SMB file system support (to mount Windows shares etc.) -- built in

--> Native Language Support
Codepage 437 (United States, Canada)




--tarballedtux
 
Old 07-15-2002, 05:52 PM   #15
tarballedtux
Member
 
Registered: Aug 2001
Location: Off the coast of Madadascar
Posts: 498

Original Poster
Rep: Reputation: 30
Forget this guess and check operation. I got a generic working config and just modified it (Take out the the crap). I compiled and ran it booted fine I'm happy your happy. Now at least i have a good .config file so I can make oldconfig in the future

--tarablledtux
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
First boot i get: SYSLINUX 2.06 Boot Failed? davidh_R Slackware - Installation 2 11-19-2005 01:59 AM
failed features: boot.shm boot.loadmodules boot.swap cccc Suse/Novell 1 08-08-2005 07:23 AM
online_update failed - ERROR(Media:connection failed)[Connect failed] rover Suse/Novell 8 02-22-2005 07:57 AM
Boot failed?? new@linux Linux - Newbie 7 12-22-2002 08:36 PM
Boot failed esael Slackware 3 09-19-2002 01:11 PM


All times are GMT -5. The time now is 05:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration