LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-24-2005, 01:18 AM   #1
qwerty
Member
 
Registered: Feb 2005
Location: England
Distribution: Ubuntu 5.10
Posts: 80

Rep: Reputation: 15
Failed dependencies installing MPlayer


Hi, i'm trying to install MPlayer (MPlayer-1.0pre7-pm.3.i586.rpm) on Suse 10. The install fails giving the following error
Code:
error: Failed dependencies:
        libdirectfb-0.9.so.22 is needed by MPlayer-1.0pre7-pm.3
        libmad.so.0 is needed by MPlayer-1.0pre7-pm.3
Naturally when I first saw this I downloaded and installed the relevant programs but i still get the same failed dependencies when i try to install the mplayer rpm. I have checked and libmad.so.0 is in /usr/lib. I haven't been able to find libdirectfb-0.9.so.22 for download anywhere but libdirectfb-0.9.so.20 is in /usr/lib

Please can somebody help me to resolve these dependencies issues

Thanks

Last edited by qwerty; 10-24-2005 at 01:20 AM.
 
Old 10-24-2005, 06:43 AM   #2
freakyg
Member
 
Registered: Apr 2005
Distribution: LFS 5.0 and 6.1
Posts: 705

Rep: Reputation: 30
just make a symlink!
Code:
ln -s libdirectfb-0.9.so.20 libdirectfb-0.9.so.22
 
Old 10-24-2005, 07:21 AM   #3
perfect_circle
Senior Member
 
Registered: Oct 2004
Location: Athens, Greece
Distribution: Slackware, arch
Posts: 1,783

Rep: Reputation: 52
Never used suse but as far as I see DirectFB-0.9.22 should be in your dvd:
http://www.novell.com/products/linux.../directfb.html
 
Old 10-24-2005, 10:59 AM   #4
qwerty
Member
 
Registered: Feb 2005
Location: England
Distribution: Ubuntu 5.10
Posts: 80

Original Poster
Rep: Reputation: 15
Mplayer still doesn't pick up that libmad is installed

Hi, thanks for the help, i've now sorted the Directfb problem but the mplayer rpm is still giving the same error saying that it can't find libmad even though it is /usr/lib. Does anyone know how to resolve this?
 
Old 10-24-2005, 12:07 PM   #5
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,373

Rep: Reputation: 164Reputation: 164
As root, run ldconfig. It will link your new libraries. Run ldconfig each time you install a new library.

Check man ldconfig for more info.

Last edited by mlangdn; 10-24-2005 at 12:08 PM.
 
Old 10-24-2005, 12:32 PM   #6
qwerty
Member
 
Registered: Feb 2005
Location: England
Distribution: Ubuntu 5.10
Posts: 80

Original Poster
Rep: Reputation: 15
I tried ldconfig with the -v option and it gave the following out put
Code:
/usr/local/lib:
	libmad.so.0 -> libmad.so.0.2.1
	libfusion-0.9.so.23 -> libfusion.so
	libdirect-0.9.so.23 -> libdirect.so
So that means that libmad.so.0 is definitely installed but the mplayer rpm still doesn't find it
 
Old 10-24-2005, 02:03 PM   #7
qwerty
Member
 
Registered: Feb 2005
Location: England
Distribution: Ubuntu 5.10
Posts: 80

Original Poster
Rep: Reputation: 15
Hi, I fixed the problem now. I downloaded a libmad rpm from ftp://ftp.pbone.net/mirror/ftp.gwdg.....1b-0.i586.rpm and installed. I used the ldconfig program and the mplayer rpm installed fine after that.

Thanks to all who helped
 
Old 10-24-2005, 04:10 PM   #8
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,373

Rep: Reputation: 164Reputation: 164
Excellent! Must have needed a somewhat newer or different version.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
failed dependencies whilst installing koffice absolute0 Suse/Novell 2 09-20-2005 10:28 AM
RedHat 9 mplayer Failed Dependencies problem shawnb Red Hat 17 10-24-2004 08:41 PM
Failed dependencies, can't seem to find the right one (mplayer, fc2). brynjarh Linux - Newbie 1 07-08-2004 05:16 PM
failed dependencies installing galion-1.2.7-3 sasquash Fedora 1 11-22-2003 02:19 PM
Failed dependencies installing samba haysdb Linux - Newbie 5 05-16-2003 02:24 PM


All times are GMT -5. The time now is 11:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration