LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-27-2003, 02:44 PM   #1
Pcghost
Senior Member
 
Registered: Feb 2003
Location: The Real Washington
Distribution: Debian, Android
Posts: 1,819

Rep: Reputation: 46
Question cannot ping past adsl modem...


I am trying to set up our DSL connection using pppoe, on our gateway/Firwall (RH9). The interfaces are set up and seem to be configured. I ran through the instructions at roaring penguin and everything seems fine with the install, except... I run adsl-setup and inputed all the relevent user name etc. When I run adsl-start, I get a connection, and the ifconfig entry for ppp0 shows the correct ip address and all that. I double-checked the dns entries in /etc/resolve conf and they are correct. The machine can ping the adsl modem and gets the appropriate response, but I cannot ping the internet at all. No connection past the modem. When I hook the adsl line back up to our 2K mail server it works fine. Anyone have any idea what I should try next to solve this dillema?

Last edited by Pcghost; 05-28-2003 at 12:46 PM.
 
Old 05-28-2003, 12:48 PM   #2
Pcghost
Senior Member
 
Registered: Feb 2003
Location: The Real Washington
Distribution: Debian, Android
Posts: 1,819

Original Poster
Rep: Reputation: 46
bump!. I checked the /etc/ppp/ directory and the file pppoe.conf is not there. The instructions say there should be a file there by that name but it is not there. Am I reading old instructions? Help....
 
Old 05-29-2003, 11:30 PM   #3
geoff_f
Member
 
Registered: May 2003
Location: Canberra, Australia
Distribution: openSUSE 11.3
Posts: 445

Rep: Reputation: 31
If you got a recent version, you should have something like rp-pppoe-3.5-1.rpm. On my Mandrake 9.0 gateway, it definitely has a pppoe.conf file in /etc/ppp. It holds the info you entered in adsl-setup, like your external interface card and userID for your ISP. This file (pppoe.conf) is fundamental to rp-pppoe working, so if you don't have this file, then something went wrong when you ran adsl-setup. Did you run it as root?

Another thing to look at is your firewall. On my system, my firewall is configured in iptables; I had ppp0 set as the external interface with dial-up connection, and I thought I needed to change that to eth0 when I switched to adsl. I was wrong; switched it back to ppp0 and it all worked from there. Don't know if RH is the same but worth checking.

Geoff.
 
Old 05-29-2003, 11:53 PM   #4
geoff_f
Member
 
Registered: May 2003
Location: Canberra, Australia
Distribution: openSUSE 11.3
Posts: 445

Rep: Reputation: 31
The only other thing I could think of: is the version you installed compatible with your PC configuration? I notice the .rpm is i386; would this matter if your kernel is configured for i586? You could try downloading the src.rpm and re-building the binary rpm as per roaring penguin's instructions to see if that made any difference.

Geoff.
 
Old 05-30-2003, 09:24 AM   #5
camelrider
Member
 
Registered: Apr 2003
Location: Juneau, Alaska
Posts: 247

Rep: Reputation: 31
I don't know why you have no "/etc/ppp/pppoe.conf". Did you run "adsl-setup" as root?

Another thing is to empty the contents of the file "/etc/ppp/options", as mentioned somewhere in the rp-pppoe docs.

Also, before running "adsl-start" you must have eth0 down.("ifdown eth0" or "ifconfig eth0 down"}
 
Old 05-30-2003, 12:17 PM   #6
core
Member
 
Registered: May 2003
Location: Berlin
Distribution: Slackware 9.1 Kernel: 2.6.4
Posts: 60

Rep: Reputation: 15
i don't know if there's the Shorewall firewall activated, like it is in mandrake 9.1.
If so, read through the /etc/shorewall/shorewall.conf there's a setting you must enable fpr pppoe connections, if this isn't done, you will not get any response from web.

greetings
 
Old 05-31-2003, 11:07 AM   #7
Pcghost
Senior Member
 
Registered: Feb 2003
Location: The Real Washington
Distribution: Debian, Android
Posts: 1,819

Original Poster
Rep: Reputation: 46
I finally found the problem.. It turns out that the version of rp-pppoe that ships with Red Hat 9 is somewhat broken. Once a connection is made with the DSL modem, the machine loses its default gateway. It has something to do with the DHCP on the interface being aliased as ppp0. Anyhow, my fix was simple. At the end of my firewall script I added the following lines, so that the porblem would be fixed automatically upon connect.

route del default
route add default gw $EXTIP

(where $EXTIP is the external ip address on the DSL line)

Worked like a charm. Thanks for the help folks..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
adsl-status can't read pppoe PID file with rp-pppoe program setup Smarvy Linux - Newbie 2 03-13-2004 11:35 PM
Need help with PPPoE ADSL connection for Mandrake Linux 9.1... jj_frap Linux - Newbie 4 11-01-2003 09:55 PM
PPPoE with ADSL merlin371 Linux - Networking 6 07-25-2003 04:39 PM
PPPoE ADSL internet connection EL Nino Linux - Networking 2 02-04-2003 09:47 PM
pppoe adsl connection tonyh Linux - Networking 0 05-22-2002 08:29 AM


All times are GMT -5. The time now is 12:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration