Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 04-01-2003, 08:36 PM   #1
LQ Guru
Registered: Mar 2003
Location: New Jersey
Distribution: Arch Linux
Posts: 1,445

Rep: Reputation: 46
extension glx missing

OK, I know, another Nvidia Driver problem, but I was chugging along until now.

I installed the new nvidia drivers (the single package that just came out) and edited my xf86config file to remove the load "dri" and load "GLcore". The load "glx" was already in there. I also changed the driver to nvidia. X works fine, but when I try to run a 3D game, I get:

Xlib: Extension "GLX" missing on display ":0.0"

I assumed it was because the load "glx" was missing from the xf86config, but its there. What could be wrong. Do I need to add load "glx" to another file, or is it something else.

I know this must annoy you, but thank you for any help.
Old 04-01-2003, 10:05 PM   #2
Registered: Feb 2003
Distribution: Gentoo, FreeBSD, LFS
Posts: 298
Blog Entries: 21

Rep: Reputation: 30
is there a '#' (without the single quotes) before Load GLX?
Old 04-01-2003, 11:05 PM   #3
LQ Guru
Registered: Mar 2003
Location: New Jersey
Distribution: Arch Linux
Posts: 1,445

Original Poster
Rep: Reputation: 46
OK, I solved it. There was a space between load dri and load glx. For some reason, that was stopping it from working. I dont know why though, there was no other code between them.

I can never get used to the precision needed in Linux, like how folders and files are case sensitive, too many mess ups just from that.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
extension "GLX" missing -- KDE won't start? thesunray Linux - Software 1 09-05-2005 07:50 PM
Another 'extension "GLX" missing on display' nvidia driver problem compjinx Linux - Software 5 10-27-2004 01:56 AM
Xlib: extension "GLX" missing citrus Linux - General 5 02-06-2004 03:48 PM
(II) [GLX]: Initializing GLX extension - X wont go hydro Linux - Software 3 02-20-2003 07:12 PM
extension "GLX" missing Quake3Arena phoenix Linux - Software 3 01-16-2003 12:38 PM

All times are GMT -5. The time now is 07:28 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration