LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 11-07-2004, 03:40 PM   #1
mrsolo
Member
 
Registered: Jun 2002
Location: Where ever the Navy sends me
Distribution: Gentoo
Posts: 320

Rep: Reputation: 30
eth0 causes looooong boot time


Hey folks

I currently have my deafult network interface disabled at boot time. Here's why; my main machine is a laptop and I use it in different situations a lot. If I have the eth0 interface set to start on boot and I have the network unplugged, it takes about 5 minutes for it to realize this and continue booting. Is there a way to cut back the time it takes for the computer to boot without having to set eth0 to not start at boot.
 
Old 11-07-2004, 05:02 PM   #2
ElPuello
Member
 
Registered: Apr 2004
Location: Copenhagen, Denmark
Distribution: Gentoo + Debian PPC
Posts: 44

Rep: Reputation: 15
Well, you could edit your /etc/dhclient.conf and add a timeout; thats what I do on my laptop.

For instance

timeout 10;

gives the client ten seconds to get an offer and then lets the boot carry on.

Hope this helps
 
Old 11-07-2004, 05:47 PM   #3
mrsolo
Member
 
Registered: Jun 2002
Location: Where ever the Navy sends me
Distribution: Gentoo
Posts: 320

Original Poster
Rep: Reputation: 30
it seems that I don't have this file, should I add it to make it do a 10 sec timeout?
 
Old 11-07-2004, 05:52 PM   #4
mrsolo
Member
 
Registered: Jun 2002
Location: Where ever the Navy sends me
Distribution: Gentoo
Posts: 320

Original Poster
Rep: Reputation: 30
I added it and it didn't do anything, any other ideas?
 
Old 11-07-2004, 06:28 PM   #5
faralen
LQ Newbie
 
Registered: Oct 2003
Distribution: Gentoo
Posts: 13

Rep: Reputation: 0
Assuming you're using DHCP, try opening /etc/sysconfig/network if it exists, and adding the line "DHCP_TIMEOUT=10" (or however many seconds you'd like).
It varies a little between different distros, so if that doesn't work, what are you running?
 
Old 11-07-2004, 06:30 PM   #6
mrsolo
Member
 
Registered: Jun 2002
Location: Where ever the Navy sends me
Distribution: Gentoo
Posts: 320

Original Poster
Rep: Reputation: 30
I use /etc/sysconf/network all the time. I will try adding that there and see what happens. My laptop is running MDK 10.0 with a lot of updates.
 
Old 11-07-2004, 07:16 PM   #7
mrsolo
Member
 
Registered: Jun 2002
Location: Where ever the Navy sends me
Distribution: Gentoo
Posts: 320

Original Poster
Rep: Reputation: 30
That didn't do a thing, any more ideas that could solve this?
 
Old 11-07-2004, 07:28 PM   #8
faralen
LQ Newbie
 
Registered: Oct 2003
Distribution: Gentoo
Posts: 13

Rep: Reputation: 0
If I remember right, the /sbin/ifup script starts the network interfaces, and calls the dhcpcd program from it. You could try searching through the file and if you see dhcpcd being called, add "-t 10" after it (for a timeout of 10 seconds).

Otherwise, sorry, out of ideas...
 
Old 11-07-2004, 07:48 PM   #9
mAineAc
Member
 
Registered: Nov 2000
Location: Hermon, ME
Distribution: slackware
Posts: 201

Rep: Reputation: 30
If you check out this page it tells you how to configure your dhcp:
http://www.whitefang.com/dhcp-agent/...p-agent_2.html

About halfway down is a section that says configureable variables nad it has a section Client Configuration Variable: dhcp-discovery-retries . I think this will force it not to try so long.
 
Old 11-07-2004, 09:46 PM   #10
Mortus Canis
LQ Newbie
 
Registered: Jun 2003
Location: Gonzaga University
Distribution: Slackware, RHEL
Posts: 23

Rep: Reputation: 15
Quote:
Originally posted by faralen
If I remember right, the /sbin/ifup script starts the network interfaces, and calls the dhcpcd program from it. You could try searching through the file and if you see dhcpcd being called, add "-t 10" after it (for a timeout of 10 seconds).

Otherwise, sorry, out of ideas...
faralen is right, I did this exact thing on my laptop. It works.
 
Old 11-07-2004, 10:29 PM   #11
nykobing
LQ Newbie
 
Registered: Apr 2004
Distribution: Kubuntu
Posts: 11

Rep: Reputation: 0
I use Mandrake with sbc dsl and I was having this problem too. I found a webpage and they said to:

eth0 fails to start: Try removing the "/etc/sysconfig/network-scripts/ifcfg-eth0" file.


I did that and everything worked perfect after that. I found it at http://users.dslextreme.com/~craig.l...notes/dsl.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting eth0 at boot time ? Antonius Linux - Newbie 1 01-19-2005 08:27 PM
eth0 & wlan0 lag longer than usual at boot time loads lostlyre Linux - Wireless Networking 0 04-02-2004 03:09 PM
First time user can't get linux to boot. Locks on ETH0 DGath Linux - Newbie 10 06-29-2003 06:48 PM
howto disable eth0 at boot time rydogg Linux - Newbie 2 06-16-2003 10:33 AM
How to not init eth0 at boot time aldaeron Linux - Networking 4 08-07-2002 08:30 PM


All times are GMT -5. The time now is 09:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration