LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-17-2001, 01:38 PM   #1
Kenelm
LQ Newbie
 
Registered: Dec 2001
Posts: 20

Rep: Reputation: 0
Error with LILO with Graphical Menu


Big "HEY" to everyone, this will be my first post here. I have a problem and I have no clue where to begin. When installing Linux Mandrake 8.1 at the boot loader section, I want the LILO with graphical menu. I put the boot loader on the MBR and set windows as the default (for the family) after 5 seconds. After clicking OK I am presented the error " Installation of LILO failed. The following error occured: Use of the 'lba32' option may help on newer (EDD BIOS) systems. Fatal: geo_comp_addr: Cylinder number is too big (4414 > 0123) " Weird thing is, when I setup everthing the same with GRUB I get no errors, but I want the graphical menu! Does anyone out there know what's going on and how to fix this.
 
Old 12-17-2001, 02:05 PM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 235Reputation: 235Reputation: 235
you may need to add lba32 to your lilo.conf file... looks like this:

linear=lba32

then make the changes to lilo by running lilo from the command..

/sbin/lilo

reboot and see if that works. if this is during the install, there should be a option to add that in.. well i know some other distro's give you that option.. i am not that familiar with the installation process of mandrake.. if you have already surpassed this, you can boot into mandrake with a rescue disk to gain access to your files, or if your using grub now, you should be able to boot up and then install lilo to the MBR to overwrite grub to use it instead.

let us know...
 
Old 12-17-2001, 03:09 PM   #3
Kenelm
LQ Newbie
 
Registered: Dec 2001
Posts: 20

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by trickykid
you may need to add lba32 to your lilo.conf file... looks like this:

linear=lba32

then make the changes to lilo by running lilo from the command..

/sbin/lilo

reboot and see if that works. if this is during the install, there should be a option to add that in.. well i know some other distro's give you that option.. i am not that familiar with the installation process of mandrake.. if you have already surpassed this, you can boot into mandrake with a rescue disk to gain access to your files, or if your using grub now, you should be able to boot up and then install lilo to the MBR to overwrite grub to use it instead.

let us know...

Well, being a n00b, I followed the instructions to the best of my abilities, and found that lba32 was already in lilo.conf, I had checked lba when I picked GRUB during the 1st install. At the command line, when I type /sbin/lilo, I get the same error message talking about the 1024 limit.
**note** I tried LILO with text option and still get same error message.
 
Old 12-17-2001, 03:48 PM   #4
bluecadet
Member
 
Registered: Oct 2001
Distribution: MD81 RH71
Posts: 555

Rep: Reputation: 30
wether have have it set for graphical or text menu, i's totally irrelevant...

i always have just 'lba32' and remove the 'linear' optino if there is one. i've not seen the two used as a variable=value pair before...
 
Old 12-17-2001, 06:17 PM   #5
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
Grub has a few advantages over lilo

it also has a graphical menu so you're in luck.
 
Old 12-17-2001, 07:50 PM   #6
Kenelm
LQ Newbie
 
Registered: Dec 2001
Posts: 20

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by DavidPhillips
Grub has a few advantages over lilo

it also has a graphical menu so you're in luck.
And this graphical menu you speak of, where is this?
 
Old 12-18-2001, 04:06 AM   #7
ajtaus
Member
 
Registered: Dec 2001
Location: Home = Australia, Work = UK
Distribution: Mandrake 8.1
Posts: 31

Rep: Reputation: 15
I get the same error with LILO graphical menu when setting windows to default. it works fine when I set linux default. I have no idea why...
 
Old 12-18-2001, 04:50 AM   #8
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 235Reputation: 235Reputation: 235
sorry about the confusion.. you either have lba32 or linear in lilo.. or neither, but if you using lilo 21.4 or later.. always use lba32, its there by default so you won't have the 1024 limit problem... if you use linear, it keeps it from having geometry problems but usually with it you have to have your kernel within the first 1024 cylinder limit.

whats your lilo.conf file look like.. ?? can you post it here ?? if its booting into linux fine when its default, that might not be the problem.
 
Old 12-18-2001, 05:09 AM   #9
ajtaus
Member
 
Registered: Dec 2001
Location: Home = Australia, Work = UK
Distribution: Mandrake 8.1
Posts: 31

Rep: Reputation: 15
I'll try to find the file tonight and post it. It's on my pc at home.
 
Old 12-18-2001, 08:24 AM   #10
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
this line in grub.conf will set the file for the menu, also there are other options like color you can set, it's in the info pages

splashimage=(hd0,0)/grub/splash.xpm.gz

you can edit the file or make your own if you don't like it.

run this in terminal

info grub
 
Old 12-18-2001, 08:31 AM   #11
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
if you can't get it maybe your vga driver will not support it.

On my laptop I have added this line to grub.conf

vga=773

on one of my desktops I use

vga=791


by the way I don't know if this affects the boot menu but it makes a kewl little penguin on the screen when your system is coming up.


and of course it will work with lilo as well
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
graphical lilo....doensn't go graphical -0- Slackware 3 02-01-2005 08:47 PM
lilo with graphical menu not found muneebs123 Mandriva 1 06-17-2004 04:05 AM
lilo graphical menu???? azathot Mandriva 3 02-24-2004 10:14 PM
LILO installation - no graphical menu dr. gonzo Fedora - Installation 2 01-22-2004 11:07 AM
Lilo graphical menu ernie Linux - General 2 01-02-2002 09:35 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration