LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Error when trying to run wine: "/usr/bin/wine: No such file or directory" (http://www.linuxquestions.org/questions/linux-software-2/error-when-trying-to-run-wine-usr-bin-wine-no-such-file-or-directory-787683/)

Lolwhut 02-07-2010 11:35 PM

Error when trying to run wine: "/usr/bin/wine: No such file or directory"
 
Hello, I have a fresh install of Slackware 13 AMD64 (also installed slapt-get, changed passwords, set default wm to xfce, etc..), and today I tried to install the Slackware port of Wine from WineHQ.org, and the install succeeded. When I tried to run it
Code:

wine
It returned
Code:

/usr/bin/wine: No such file or directory
I am not sure why this is happening, as it worked on my 32-bit systems. My $PATH variable is this:
Code:

bash-3.1# echo $PATH
/usr/local/sbin:/usr/local/bin:/sbin:/usr/sbin:/bin:/usr/bin

Thank you, and any help would be greatly appreciated. If needed, here is what was shown while installing wine:
Code:

bash-3.1# installpkg wine-1.1.29-i486-1kjz.tgz
Verifying package wine-1.1.29-i486-1kjz.tgz.
Installing package wine-1.1.29-i486-1kjz.tgz:
PACKAGE DESCRIPTION:
# WINE - Wine Is Not an Emulator
#
# Wine is an Open Source implementation of the Windows API on top of
# X and Unix; it is a compatibility layer for running Windows programs.
# Wine does not require Microsoft Windows, as it is a completely free
# alternative implementation of the Windows API.  However, Wine can
# optionally use native Windows DLLs if they are available.  Wine
# provides both a development toolkit for porting Windows source code
# to Unix, as well as a program loader to run Windows applications.
# Homepage: http://www.winehq.com/
# Packaged by Ken Zalewski (kennyz@nycap.rr.com)

Executing install script for wine-1.1.29-i486-1kjz.tgz.
Package wine-1.1.29-i486-1kjz.tgz installed.

Also, all the files are there. They are just not being recognized. "ls /usr/bin/wine*" shows the files are there.

Code:

bash-3.1$ ls /usr/bin/wine*
/usr/bin/wine                /usr/bin/winecpp  /usr/bin/winemaker
/usr/bin/wine-preloader  /usr/bin/winedbg  /usr/bin/winemine
/usr/bin/wineboot        /usr/bin/winedump  /usr/bin/winepath
/usr/bin/winebuild        /usr/bin/winefile  /usr/bin/wineprefixcreate
/usr/bin/winecfg        /usr/bin/wineg++  /usr/bin/wineserver
/usr/bin/wineconsole        /usr/bin/winegcc


business_kid 02-08-2010 04:30 AM

Just be aware there is no dependency checking in slackware. Are all the dependencies installed? Try this:
cd /usr/bin && ldd wine
Check if all the libs are in sight. Also run winecfg. It needs a configuration to start. It finds your disk, you set basic options about how it plays with your hardware, and which version of windows it pretends to be.

Lolwhut 02-08-2010 11:02 AM

I tried to run "ldd wine" but it returned:
Code:

bash-3.1# cd /usr/bin && ldd wine
                  not a dynamic executable

I did chmod +x on all of them aswell, but it did not change anything. Also, if I try to run winecfg, it returns:
Code:

line 29: /usr/bin/wine: No such file or directory
line 29: /usr/bin/wine: Success


Lolwhut 02-08-2010 07:50 PM

Might building wine on the actual system fix this? Or will it be the same as installing the wine package.

business_kid 02-09-2010 07:28 AM

I'm on slamd64-12.2 (=64 bit slackware before there was one, if you get me).
Code:

bash-3.1$ ldd /usr/bin/wine
        linux-gate.so.1 =>  (0xf7f41000)
        libwine.so.1 => /usr/lib/libwine.so.1 (0xf7e05000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xf7dee000)
        libc.so.6 => /lib/libc.so.6 (0xf7ca1000)
        libdl.so.2 => /lib/libdl.so.2 (0xf7c9d000)
        /lib/ld-linux.so.2 (0xf7f42000)

Try ls -l /usr/bin/wine.
It might be a symlink to /opt/somewhere/wine or the like. This seems like your problem. Follow this to the executable, and try ldd on that.

JimBrewster 02-09-2010 09:42 AM

Try running these commands:
Code:

ls /var/log/packages/ | grep wine
..to find the full package name.
Then:
Code:

less /var/log/packages/[full package name]
..to see all the files that were installed.
That should show you the path to the wine executable. If it's somewhere in /opt you might need to add it to your $PATH variable. If it's in /usr/local/bin it should be in your $PATH. Run 'echo $PATH' to be sure...

Lolwhut 02-09-2010 07:08 PM

I do believe I have found what I need to do. I need to set up a multilib environment if I am reading correctly. I will edit this post if I succeed.

zuzoa 05-11-2010 10:30 AM

I have this same problem. I am running Slackware 13 64-bit, and installed their txz package from sourceforge.

Quote:

bash-3.1$ stat /usr/bin/wine
File: `/usr/bin/wine'
Size: 7096 Blocks: 16 IO Block: 4096 regular file
Device: 801h/2049d Inode: 267024 Links: 1
Access: (0755/-rwxr-xr-x) Uid: ( 0/ root) Gid: ( 0/ root)
Access: 2010-05-11 10:00:05.612861294 -0400
Modify: 2010-04-19 11:21:36.000000000 -0400
Change: 2010-04-29 16:51:11.443962845 -0400
bash-3.1$ /usr/bin/wine
bash: /usr/bin/wine: No such file or directory

business_kid 05-12-2010 05:21 AM

Brief 32/64 bit howto.

Except for Debian & clones, 32bit = /usr/lib, /usr/local/lib, etc
64bit = /usr/lib64
Debian uses /usr/lib32 & /usr/lib respectively.
Wine is usually compiled 32 bit, and needs/uses 32 bit libs, because windows programs in the main are 32 bit


All times are GMT -5. The time now is 05:33 PM.