LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   error when trying to install perl modules (http://www.linuxquestions.org/questions/linux-software-2/error-when-trying-to-install-perl-modules-186809/)

jimi_j 05-28-2004 02:00 AM

error when trying to install perl modules
 
hi there , when updating SA i get an msg asking for some perl dependencies, when i get those dependencies from CPAN and try to install them i get the following error;

Executing Makefile.PL && make ..

sh: line 1: Makefile.PL: command not found


all this is being attempted from webmin, anyone know why this might be?

hw-tph 05-28-2004 03:52 AM

I am not really accustomed to webmin, but if environment variables are not properly set (as if you had SSH'd in to the server) I assume you could experience that kind of problems. Do you get the same problem when you SSH in, su to root and run the CPAN shell using perl -MCPAN -e shell ?


Håkan

jimi_j 05-29-2004 05:38 PM

hay , thanks for the reply, when running from the CPAN prompt i am now getting the warning;

"could not locate your pod2man program. please make sure your pod2man program is in your PATH before u execute make."

then the make fails with the error;

Makefile:94: ***missing seperator .stop.
/usr/bin/make --NOT OK

i have checked to see if pod2man is in the PATH with the cmd "which pod2man" and i get the output "/usr/bin/pod2man" so i'm assuming it is indeed in the PATH.
i've run the cmd "export PATH=$PATH:/usr/bin/pod2man" and then i then get the shell to re-read its init file by typing the following "source ~/.bashrc" just in case, but this makes no difference...so now i completely stumped...again...

TXM 07-19-2004 11:17 PM

Try this before running the "perl -MCPAN -e shell":

export LANG=en_US


All times are GMT -5. The time now is 03:35 AM.