LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-14-2004, 10:56 AM   #1
RoaCh Of DisCor
Member
 
Registered: Apr 2004
Location: Washington State
Distribution: SuSE 9.3 / Slackware-Current
Posts: 701

Rep: Reputation: 30
Error when building kdemultimedia.


make[6]: Entering directory `/home/roach/konstruct/kde/kdemultimedia/work/kdemultimedia-3.3.1/mpeglib/lib'
make[6]: Nothing to be done for `all-am'.
make[6]: Leaving directory `/home/roach/konstruct/kde/kdemultimedia/work/kdemultimedia-3.3.1/mpeglib/lib'
make[5]: Leaving directory `/home/roach/konstruct/kde/kdemultimedia/work/kdemultimedia-3.3.1/mpeglib/lib'
Making all in example
make[5]: Entering directory `/home/roach/konstruct/kde/kdemultimedia/work/kdemultimedia-3.3.1/mpeglib/example'
Making all in mpgplay
make[6]: Entering directory `/home/roach/konstruct/kde/kdemultimedia/work/kdemultimedia-3.3.1/mpeglib/example/mpgplay'
/bin/sh ../../../libtool --silent --mode=link --tag=CXX g++ -Wnon-virtual-dtor -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -O2 -I/root/kde3.3.1/include -I/usr/X11R6/include -L/root/kde3.3.1/lib -L/usr/X11R6/lib -O2 -pipe -I/root/kde3.3.1/include -I/usr/X11R6/include -L/root/kde3.3.1/lib -L/usr/X11R6/lib -O2 -pipe -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -L/root/kde3.3.1/lib -L/usr/X11R6/lib -L/root/kde3.3.1/lib -L/usr/X11R6/lib -o mpgplay -L/usr/X11R6/lib -L/root/kde3.3.1/lib mpgplay.o ../../lib/libmpeg.la -lX11 -lXext -lm -lstdc++ -lXv -lXxf86dga -lXxf86vm -lcdda_paranoia -lcdda_interface -lvorbisfile -lvorbis -logg -lpthread
mpgplay.o(.text+0x47): In function `main':
: undefined reference to `InputPlugin::createInputStream(char const*, int)'
../../lib/.libs/libmpeg.so: undefined reference to `BufferInputStream::forwardReadPtr(int)'
../../lib/.libs/libmpeg.so: undefined reference to `BufferInputStream::BufferInputStream[in-charge](int, int, char const*)'
../../lib/.libs/libmpeg.so: undefined reference to `InputStream::getUrl()'
../../lib/.libs/libmpeg.so: undefined reference to `BufferInputStream::write(char*, int, TimeStamp*)'
../../lib/.libs/libmpeg.so: undefined reference to `BufferInputStream::readRemote(char**, int)'
../../lib/.libs/libmpeg.so: undefined reference to `FileAccessWrapper::FileAccessWrapper[in-charge](InputStream*)'
../../lib/.libs/libmpeg.so: undefined reference to `BufferInputStream::getFillgrade()'
../../lib/.libs/libmpeg.so: undefined reference to `BufferInputStream::write(InputStream*, int, TimeStamp*)'
collect2: ld returned 1 exit status
make[6]: *** [mpgplay] Error 1
make[6]: Leaving directory `/home/roach/konstruct/kde/kdemultimedia/work/kdemultimedia-3.3.1/mpeglib/example/mpgplay'
make[5]: *** [all-recursive] Error 1
make[5]: Leaving directory `/home/roach/konstruct/kde/kdemultimedia/work/kdemultimedia-3.3.1/mpeglib/example'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/home/roach/konstruct/kde/kdemultimedia/work/kdemultimedia-3.3.1/mpeglib'

Anyone know a solution for this? Thanks. -RoaCh

Last edited by RoaCh Of DisCor; 10-14-2004 at 11:24 AM.
 
Old 10-14-2004, 11:59 AM   #2
RoaCh Of DisCor
Member
 
Registered: Apr 2004
Location: Washington State
Distribution: SuSE 9.3 / Slackware-Current
Posts: 701

Original Poster
Rep: Reputation: 30
Anyone?!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDEMultimedia vs. K3B - why not both!? lefty.crupps MEPIS 7 09-07-2005 09:04 PM
rpm -e kdemultimedia kdeaddons konstantine Linux - Newbie 1 03-31-2005 06:23 PM
problem with compiling kdemultimedia-3.3.2 in suse-9.2 tony yu Suse/Novell 3 02-08-2005 08:40 AM
Slackware-current kdemultimedia upgrade? roastpork Slackware 2 01-19-2004 05:32 PM
Installing KDEMultimedia digsby0007 Linux - Software 1 02-07-2003 09:57 AM


All times are GMT -5. The time now is 12:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration