LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Error throwing while installing vsftpd package in rhel 6. using rhel 6 dvd. (http://www.linuxquestions.org/questions/linux-software-2/error-throwing-while-installing-vsftpd-package-in-rhel-6-using-rhel-6-dvd-4175453000/)

redhatlbug 03-06-2013 01:22 PM

Error throwing while installing vsftpd package in rhel 6. using rhel 6 dvd.
 
Hi all,

Im studying rhcsa as of now, so yum installation and dependencies are messing me to not workit out.

i have dual os, win 7 & rhel 6.

i have tried this installation of vsftpd package with rhel 6 dvd in VM rhel 6 in win 7 as well as host rhel 6.still the same issue.
below error message is throwing.

but while i click the package thru graphical installation it installs successfully.

gone thru search on this forum and found nothing so, clear me where im doing the wrong.


[root@redhat Packages]# yum install *ftp* -y
Loaded plugins: refresh-packagekit, rhnplugin
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
Examining ftp-0.17-51.1.el6.x86_64.rpm: ftp-0.17-51.1.el6.x86_64
Marking ftp-0.17-51.1.el6.x86_64.rpm to be installed
Examining gvfs-obexftp-1.4.3-9.el6.x86_64.rpm: gvfs-obexftp-1.4.3-9.el6.x86_64
gvfs-obexftp-1.4.3-9.el6.x86_64.rpm: does not update installed package.
Examining lftp-4.0.9-1.el6.i686.rpm: lftp-4.0.9-1.el6.i686
Marking lftp-4.0.9-1.el6.i686.rpm to be installed
Examining lftp-4.0.9-1.el6.x86_64.rpm: lftp-4.0.9-1.el6.x86_64
Marking lftp-4.0.9-1.el6.x86_64.rpm to be installed
Examining report-config-ftp-0.18-7.el6.x86_64.rpm: report-config-ftp-0.18-7.el6.x86_64
report-config-ftp-0.18-7.el6.x86_64.rpm: does not update installed package.
Examining report-plugin-ftp-0.18-7.el6.x86_64.rpm: report-plugin-ftp-0.18-7.el6.x86_64
report-plugin-ftp-0.18-7.el6.x86_64.rpm: does not update installed package.
Examining tftp-0.49-5.1.el6.x86_64.rpm: tftp-0.49-5.1.el6.x86_64
Marking tftp-0.49-5.1.el6.x86_64.rpm to be installed
Examining tftp-server-0.49-5.1.el6.x86_64.rpm: tftp-server-0.49-5.1.el6.x86_64
Marking tftp-server-0.49-5.1.el6.x86_64.rpm to be installed
Examining vsftpd-2.2.2-6.el6.x86_64.rpm: vsftpd-2.2.2-6.el6.x86_64
vsftpd-2.2.2-6.el6.x86_64.rpm: does not update installed package.
Resolving Dependencies
--> Running transaction check
---> Package ftp.x86_64 0:0.17-51.1.el6 set to be updated
---> Package lftp.i686 0:4.0.9-1.el6 set to be updated
--> Processing Dependency: ld-linux.so.2 for package: lftp-4.0.9-1.el6.i686
--> Processing Dependency: ld-linux.so.2(GLIBC_2.3) for package: lftp-4.0.9-1.el6.i686
--> Processing Dependency: libc.so.6 for package: lftp-4.0.9-1.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.0) for package: lftp-4.0.9-1.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1) for package: lftp-4.0.9-1.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1.2) for package: lftp-4.0.9-1.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1.3) for package: lftp-4.0.9-1.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.2) for package: lftp-4.0.9-1.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.2.3) for package: lftp-4.0.9-1.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.3) for package: lftp-4.0.9-1.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.3.4) for package: lftp-4.0.9-1.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: lftp-4.0.9-1.el6.i686
--> Processing Dependency: libdl.so.2 for package: lftp-4.0.9-1.el6.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.0) for package: lftp-4.0.9-1.el6.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.1) for package: lftp-4.0.9-1.el6.i686
--> Processing Dependency: libgcc_s.so.1 for package: lftp-4.0.9-1.el6.i686
--> Processing Dependency: libgcc_s.so.1(GCC_3.0) for package: lftp-4.0.9-1.el6.i686
--> Processing Dependency: libgcc_s.so.1(GCC_3.3) for package: lftp-4.0.9-1.el6.i686
--> Processing Dependency: libgcc_s.so.1(GCC_4.2.0) for package: lftp-4.0.9-1.el6.i686
--> Processing Dependency: libgnutls.so.26 for package: lftp-4.0.9-1.el6.i686
--> Processing Dependency: libgnutls.so.26(GNUTLS_1_4) for package: lftp-4.0.9-1.el6.i686
--> Processing Dependency: libreadline.so.6 for package: lftp-4.0.9-1.el6.i686
--> Processing Dependency: libresolv.so.2 for package: lftp-4.0.9-1.el6.i686
--> Processing Dependency: libresolv.so.2(GLIBC_2.0) for package: lftp-4.0.9-1.el6.i686
--> Processing Dependency: libresolv.so.2(GLIBC_2.2) for package: lftp-4.0.9-1.el6.i686
--> Processing Dependency: librt.so.1 for package: lftp-4.0.9-1.el6.i686
--> Processing Dependency: librt.so.1(GLIBC_2.2) for package: lftp-4.0.9-1.el6.i686
--> Processing Dependency: libtinfo.so.5 for package: lftp-4.0.9-1.el6.i686
--> Processing Dependency: libutil.so.1 for package: lftp-4.0.9-1.el6.i686
--> Processing Dependency: libutil.so.1(GLIBC_2.0) for package: lftp-4.0.9-1.el6.i686
---> Package lftp.x86_64 0:4.0.9-1.el6 set to be updated
---> Package tftp.x86_64 0:0.49-5.1.el6 set to be updated
---> Package tftp-server.x86_64 0:0.49-5.1.el6 set to be updated
--> Processing Dependency: xinetd for package: tftp-server-0.49-5.1.el6.x86_64
--> Finished Dependency Resolution
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: libtinfo.so.5
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: ld-linux.so.2
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: ld-linux.so.2(GLIBC_2.3)
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: libreadline.so.6
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: libgcc_s.so.1
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: libgcc_s.so.1(GCC_3.3)
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: libc.so.6(GLIBC_2.2)
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: libc.so.6(GLIBC_2.0)
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: libgnutls.so.26(GNUTLS_1_4)
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: libc.so.6(GLIBC_2.1.3)
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: libutil.so.1(GLIBC_2.0)
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: libdl.so.2(GLIBC_2.0)
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: libc.so.6(GLIBC_2.4)
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: libc.so.6
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: libutil.so.1
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: libc.so.6(GLIBC_2.1.2)
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: libresolv.so.2
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: libresolv.so.2(GLIBC_2.2)
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: libc.so.6(GLIBC_2.3)
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: libgnutls.so.26
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: libc.so.6(GLIBC_2.1)
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: libgcc_s.so.1(GCC_3.0)
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: libdl.so.2(GLIBC_2.1)
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: librt.so.1(GLIBC_2.2)
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: libgcc_s.so.1(GCC_4.2.0)
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: librt.so.1
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: libdl.so.2
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: libc.so.6(GLIBC_2.2.3)
Error: Package: tftp-server-0.49-5.1.el6.x86_64 (/tftp-server-0.49-5.1.el6.x86_64)
Requires: xinetd
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: libc.so.6(GLIBC_2.3.4)
Error: Package: lftp-4.0.9-1.el6.i686 (/lftp-4.0.9-1.el6.i686)
Requires: libresolv.so.2(GLIBC_2.0)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

rayfordj 03-07-2013 05:08 PM

It appears you are trying to install anything with the name ftp (*ftp*) and it is trying to install both architecture version (i*86, aka: 32bit as well as x86_64 aka: 64bit), but the 32bit packages have dependencies that conflict with the installed 64bit packages, so it is failing. If you only need vsftpd, try: yum install vsftpd. If you still want to install everything with ftp in the name, you may have better luck sticking to your installed architecture and go with something like: yum install *ftp*.x86_64

chrism01 03-07-2013 05:38 PM

Also
Code:

Examining vsftpd-2.2.2-6.el6.x86_64.rpm: vsftpd-2.2.2-6.el6.x86_64
vsftpd-2.2.2-6.el6.x86_64.rpm: does not update installed package.

says vsftpd is already installed.

redhatlbug 03-08-2013 12:25 PM

also tried the same but still receiving error message....


[root@redhat Packages]# yum install vsftpd-2.2.2-6.el6.x86_64.rpm -y
Loaded plugins: refresh-packagekit, rhnplugin
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
Examining vsftpd-2.2.2-6.el6.x86_64.rpm: vsftpd-2.2.2-6.el6.x86_64
Marking vsftpd-2.2.2-6.el6.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package vsftpd.x86_64 0:2.2.2-6.el6 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved


================================================================================
Package Arch Version Repository Size
================================================================================
Installing:
vsftpd x86_64 2.2.2-6.el6 /vsftpd-2.2.2-6.el6.x86_64 331 k

Transaction Summary
================================================================================
Install 1 Package(s)
Upgrade 0 Package(s)

Total size: 331 k
Installed size: 331 k
Downloading Packages:
warning: rpmts_HdrFromFdno: Header V3 RSA/SHA256 Signature, key ID fd431d51: NOKEY


Public key for vsftpd-2.2.2-6.el6.x86_64.rpm is not installed
[root@redhat Packages]#

=========================================================

and also same error throwing while trying to install kickstart package.


[root@redhat Packages]# yum install system-config-kickstart-2.8.6.2-1.el6.noarch.rpm
Loaded plugins: refresh-packagekit, rhnplugin
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
Examining system-config-kickstart-2.8.6.2-1.el6.noarch.rpm: system-config-kickstart-2.8.6.2-1.el6.noarch
Marking system-config-kickstart-2.8.6.2-1.el6.noarch.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package system-config-kickstart.noarch 0:2.8.6.2-1.el6 set to be updated
--> Processing Dependency: anaconda >= 11.4.0.42-1 for package: system-config-kickstart-2.8.6.2-1.el6.noarch
--> Processing Dependency: pykickstart >= 0.96 for package: system-config-kickstart-2.8.6.2-1.el6.noarch
--> Processing Dependency: system-config-language for package: system-config-kickstart-2.8.6.2-1.el6.noarch
--> Finished Dependency Resolution
Error: Package: system-config-kickstart-2.8.6.2-1.el6.noarch (/system-config-kickstart-2.8.6.2-1.el6.noarch)
Requires: system-config-language
Error: Package: system-config-kickstart-2.8.6.2-1.el6.noarch (/system-config-kickstart-2.8.6.2-1.el6.noarch)
Requires: pykickstart >= 0.96
Error: Package: system-config-kickstart-2.8.6.2-1.el6.noarch (/system-config-kickstart-2.8.6.2-1.el6.noarch)
Requires: anaconda >= 11.4.0.42-1
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
[root@redhat Packages]#

chrism01 03-10-2013 06:09 AM

Code:

warning: rpmts_HdrFromFdno: Header V3 RSA/SHA256 Signature, key ID fd431d51: NOKEY
Either install the GPG key from the DVD, or edit the repo file and disable the gpgcheck.

Incidentally, when installing a pkg, just ask for it by pkg name, not the rpm filename eg
Code:

yum install vsftpd


All times are GMT -5. The time now is 07:11 AM.